You are not logged in.

#1 2020-04-20 10:05:33

radli
Member
Registered: 2018-04-27
Posts: 28

virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

6.1.8 is here https://www.archlinux.org/packages/comm … est-utils/

community/virtualbox-guest-modules-arch 6.0.8-17.0 [installed]
    Virtualbox guest kernel modules for Arch Kernel
community/virtualbox-guest-utils 6.0.8-2.0 [installed]
    VirtualBox Guest userspace utilities

https://www.archlinux.org/packages/core/x86_64/linux/

Provides:	VIRTUALBOX-GUEST-MODULES, WIREGUARD-MODULE
Replaces:	virtualbox-guest-modules-arch, wireguard-arch

Last edited by radli (2020-05-20 13:22:05)

Offline

#2 2020-04-21 16:46:12

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 127
Website

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Is part of virtualbox which refuses to build for some time, either due to exhausting the virtual address
space of 4GB or in extremely helpful errors like 'Vbox.sh not found".

Offline

#3 2020-04-21 19:34:44

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 127
Website

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

/build/virtualbox/src/VirtualBox-6.1.6/src/VBox/Additions/x11/VBoxClient/display-svga-x11.cpp:313:49: error: invalid conversion from â {aka â} to âEAD
  313 |         rc = RTThreadCreate(&mX11MonitorThread, x11MonitorThreadFunction, 0, 0,
      |                                                 ^~~~~~~~~~~~~~~~~~~~~~~~
      |                                                 |
      |                                                 int (*)(RTTHREAD, void*) {aka int (*)(RTTHREADINT*, void*)}
In file included from /build/virtualbox/src/VirtualBox-6.1.6/src/VBox/Additions/x11/VBoxClient/display-svga-x11.cpp:49:
/build/virtualbox/src/VirtualBox-6.1.6/include/iprt/thread.h:279:59: note:   initializing argument 2 of â
  279 | RTDECL(int) RTThreadCreate(PRTTHREAD pThread, PFNRTTHREAD pfnThread, void *pvUser, size_t cbStack,
      |                                               ~~~~~~~~~~~~^~~~~~~~~
kmk: *** [/build/virtualbox/src/VirtualBox-6.1.6/kBuild/footer-pass2-compiling-targets.kmk:277: /build/virtualbox/src/VirtualBox-6.1.6/out/linux.x86/release/obj/VBoxClient/display-svga-x11.o] Error 1
kmk: *** Waiting for unfinished jobs....

Yep, upstream (the authors) don't even bother to compile the code on 32-bit..
..I'm inclined to blacklist the whole load of virtualbox..

Offline

#4 2020-04-22 09:15:53

radli
Member
Registered: 2018-04-27
Posts: 28

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Thank you for your efforts and for the detailed error description.

I googled by your error string and found this

https://www.virtualbox.org/ticket/19494

They have just fixed the error and the fix is going to be in the next 6.1.x release.

[url=https://imgur.com/T5RUpFr.png]
  T5RUpFr.png
[/url]

Btw,
It takes 7 days for them to fix a problem for 32-bit.

Offline

#5 2020-04-22 14:31:44

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 127
Website

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Thanks for digging into this. :-)
So, let's try a build in 7 days.. ;-)

Offline

#6 2020-05-20 13:21:13

radli
Member
Registered: 2018-04-27
Posts: 28

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Hello,

6.1.8 is out https://www.archlinux.org/packages/comm … est-utils/

and the fix is on the board
https://www.virtualbox.org/ticket/19494

Could you update the package
virtualbox-guest-utils
?

Thank you.

Offline

#7 2020-05-20 17:55:23

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 596

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Hmm, was abumann actually building 6.1.8 there, because his path suggests he was building 6.1.6, which according to that ticket won't build on 32-bit machines.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#8 2020-05-21 11:22:09

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 127
Website

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Currently failing with a missing VBoxCOM.a library which leads to

kmk: *** No rule to make target '/build/virtualbox/src/VirtualBox-6.1.8/out/linux.x86/release/lib/VBoxCOM.a', needed by '/build/virtualbox/src/VirtualBox-6.1.8/out/linux.x86/release/obj/vboximg-mount/vboximg-mount'.  Stop.

libxpcom is enabled, as far as I can tell. Currently diffing some 32-bit and 64-bit build logs (to find the 10 differences
in the picture).

No, for some reason 32-bit doesn't build xpcom, disabling vboximg-mount for now..

Offline

#9 2020-05-21 16:40:47

radli
Member
Registered: 2018-04-27
Posts: 28

Re: virtualbox-guest-utils version (6.0.8) is too old, needed (6.1.8)

Actually, I don't use the command https://www.virtualbox.org/manual/ch05. … ximg-mount

Offline

Board footer

Powered by FluxBB