You are not logged in.

#1 2020-06-09 12:53:00

anabasis
Member
Registered: 2020-06-09
Posts: 8

[SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

hi,
i have updated my system but now chromium doesn't run: it says it need icu64 but the last version of icu is 67.
How can i solve? Why there isn't last version of chromium for i686?

Last edited by anabasis (2020-06-11 12:28:30)

Offline

#2 2020-06-09 16:14:15

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 618

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

Chromium is currently failing to build because it's trying to inline sse only instructions using intrinsics.

I get the feeling they've given up building chromium for plain i686.  Are you sure your hardware can't run pentium4 instructions?

Edit: And here's the bug.  Looks like these days, using invalid intrinsics causes a build error, so we don't even get a packaged output any more.  Those logged errors look to be very similar if not the same opcodes, although the function name has changed.

Last edited by levi (2020-06-09 16:47:43)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2020-06-09 18:09:09

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

thx for reply,
how can i know if my hardware runs pentium4 instructions? i have an old Intel Core Duo of 2006:

$ cat /proc/cpuinfo |grep flag
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ht tm pbe nx lm constant_tsc arch_perfmon pebs bts cpuid aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm tpr_shadow dtherm

i have tried to put old libicui18n.so.64,libicuuc.so.64 and libicudata.so.64 in /usr/lib. Now chromium runs but after the CPU goes to 100% (systemd-coredump) and it crashes:

$ chromium

(chromium:5039): Gtk-WARNING **: 19:00:36.528: Theme parsing error: gtk.css:9:0: expected '}' after declarations
[5039:5171:0609/190038.845053:ERROR:object_proxy.cc(619)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
$ ls -l /usr/lib/|grep libicu
lrwxrwxrwx   1 root root        18  1 mag 16.28 libicudata.so -> libicudata.so.67.1
-rwxr-xr-x   1 root root  27537852  9 giu 18.58 libicudata.so.64
lrwxrwxrwx   1 root root        18  1 mag 16.28 libicudata.so.67 -> libicudata.so.67.1
-rwxr-xr-x   1 root root  28402108  1 mag 16.28 libicudata.so.67.1
lrwxrwxrwx   1 root root        18  1 mag 16.28 libicui18n.so -> libicui18n.so.67.1
-rwxr-xr-x   1 root root   3167764  9 giu 18.57 libicui18n.so.64
lrwxrwxrwx   1 root root        18  1 mag 16.28 libicui18n.so.67 -> libicui18n.so.67.1
-rwxr-xr-x   1 root root   3204792  1 mag 16.28 libicui18n.so.67.1
lrwxrwxrwx   1 root root        16  1 mag 16.28 libicuio.so -> libicuio.so.67.1
lrwxrwxrwx   1 root root        16  1 mag 16.28 libicuio.so.67 -> libicuio.so.67.1
-rwxr-xr-x   1 root root     58720  1 mag 16.28 libicuio.so.67.1
lrwxrwxrwx   1 root root        18  1 mag 16.28 libicutest.so -> libicutest.so.67.1
lrwxrwxrwx   1 root root        18  1 mag 16.28 libicutest.so.67 -> libicutest.so.67.1
-rwxr-xr-x   1 root root     71724  1 mag 16.28 libicutest.so.67.1
lrwxrwxrwx   1 root root        16  1 mag 16.28 libicutu.so -> libicutu.so.67.1
lrwxrwxrwx   1 root root        16  1 mag 16.28 libicutu.so.67 -> libicutu.so.67.1
-rwxr-xr-x   1 root root    215156  1 mag 16.28 libicutu.so.67.1
lrwxrwxrwx   1 root root        16  1 mag 16.28 libicuuc.so -> libicuuc.so.67.1
-rwxr-xr-x   1 root root   1918180  9 giu 18.58 libicuuc.so.64
lrwxrwxrwx   1 root root        16  1 mag 16.28 libicuuc.so.67 -> libicuuc.so.67.1
-rwxr-xr-x   1 root root   1979752  1 mag 16.28 libicuuc.so.67.1

Last edited by anabasis (2020-06-09 18:12:41)

Offline

#4 2020-06-09 22:58:37

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 618

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

A core duo not only runs pentium 4 instructions but should be even able to run x64 opcodes, so could if you really wanted to run chromium even use the upstream archlinux project.  I think pentium 4 flags are sse, sse2 and ssse3, but I may be mistaken.

So are you saying that running arch32 on this hardware, auto in your pacman.conf translates to i686, and not pentium4 (i.e. it's installed i686 packages)?  That seems odd to me, but the auto-detection does seem to have some corner cases where it makes the wrong decision, and it wouldn't completely flummox me if that were the case here.  If that is happening and you still want to help out with the arch32 project by using it, you can always change the Architecture = line in there to read 'pentium4' rather than 'auto', and then refresh your installed packages by doing a '# pacman -Qqn|pacman -S'.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2020-06-10 07:22:10

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 143
Website

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

chromium on i686 is broken for quite a while, hence the problem with icu, as icu has been updated and chromium on i686 doesn't rebuild.
Use the pentium4 architecture if you use chromium.

Offline

#6 2020-06-10 09:36:43

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

levi wrote:

A core duo not only runs pentium 4 instructions but should be even able to run x64 opcodes, so could if you really wanted to run chromium even use the upstream archlinux project.

yes, my CPU supports x64, time ago i tried to install ArchLinux64 but it was too slow because it uses too much RAM (i have only 1GB)

levi wrote:

If that is happening and you still want to help out with the arch32 project by using it, you can always change the Architecture = line in there to read 'pentium4' rather than 'auto', and then refresh your installed packages by doing a '# pacman -Qqn|pacman -S'.

on pacman.conf there is "Architecture = i686", i don't know why, maybe because it's the pacman.conf of old ArchLinux. now i'm trying to set "auto", launch your pacman command and see what happens.

EDIT:
your command doesn't work:

# pacman -Qqn|pacman -S
error: no targets specified (use -h for help)

Last edited by anabasis (2020-06-10 09:40:30)

Offline

#7 2020-06-10 10:44:00

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

i have solved installing pentium4 version of chromium and re2:

# pacman -U http://pool.mirror.archlinux32.org/pentium4/extra/chromium-81.0.4044.138-2.0-pentium4.pkg.tar.zst http://pool.mirror.archlinux32.org/pentium4/extra/re2-1:20200401-1.0-pentium4.pkg.tar.zst

now chromium works good.

Last edited by anabasis (2020-06-10 10:44:18)

Offline

#8 2020-06-10 17:23:27

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

levi wrote:

If that is happening and you still want to help out with the arch32 project by using it, you can always change the Architecture = line in there to read 'pentium4' rather than 'auto', and then refresh your installed packages by doing a '# pacman -Qqn|pacman -S'.

maybe you mean "pacman -S $(pacman -Qqn)"?
it says error:

[...]
warning: perl-alien-build-2.23-1.0 is up to date -- reinstalling
warning: perl-alien-libxml2-0.16-1.0 is up to date -- reinstalling
warning: perl-capture-tiny-0.48-3.0 is up to date -- reinstalling
warning: perl-clone-0.45-1.0 is up to date -- reinstalling
warning: perl-dbi-1.643-1.0 is up to date -- reinstalling
warning: perl-encode-locale-1.05-6.0 is up to date -- reinstalling
warning: perl-error-0.17029-1.1 is up to date -- reinstalling
warning: perl-ffi-checklib-0.27-1.0 is up to date -- reinstalling
warning: perl-file-chdir-0.1011-3.0 is up to date -- reinstalling
warning: perl-file-listing-6.04-7.0 is up to date -- reinstalling
warning: perl-file-which-1.23-3.0 is up to date -- reinstalling
warning: perl-html-parser-3.72-8.0 is up to date -- reinstalling
warning: perl-html-tagset-3.20-9.0 is up to date -- reinstalling
warning: perl-http-cookies-6.08-2.0 is up to date -- reinstalling
warning: perl-http-daemon-6.06-1.1 is up to date -- reinstalling
warning: perl-http-date-6.05-2.0 is up to date -- reinstalling
warning: perl-http-message-6.24-1.0 is up to date -- reinstalling
warning: perl-http-negotiate-6.01-7.0 is up to date -- reinstalling
warning: perl-io-html-1.001-6.0 is up to date -- reinstalling
warning: perl-libwww-6.44-1.0 is up to date -- reinstalling
warning: perl-lwp-mediatypes-6.02-7.0 is up to date -- reinstalling
warning: perl-mailtools-2.21-3.0 is up to date -- reinstalling
warning: perl-net-http-6.19-3.0 is up to date -- reinstalling
warning: perl-path-tiny-0.112-1.0 is up to date -- reinstalling
warning: perl-timedate-2.33-1.0 is up to date -- reinstalling
warning: perl-try-tiny-0.30-4.0 is up to date -- reinstalling
warning: perl-uri-1.76-3.0 is up to date -- reinstalling
warning: perl-www-robotrules-6.02-7.0 is up to date -- reinstalling
warning: perl-xml-libxml-2.0205-1.0 is up to date -- reinstalling
warning: perl-xml-namespacesupport-1.12-4.0 is up to date -- reinstalling
warning: perl-xml-parser-2.46-1.0 is up to date -- reinstalling
warning: perl-xml-sax-1.02-1.0 is up to date -- reinstalling
warning: perl-xml-sax-base-1.09-4.0 is up to date -- reinstalling
warning: phonon-qt5-4.11.1-2.0 is up to date -- reinstalling
warning: phonon-qt5-gstreamer-4.10.0-2.0 is up to date -- reinstalling
warning: pinentry-1.1.0-5.0 is up to date -- reinstalling
warning: pipewire-0.3.4-1.0 is up to date -- reinstalling
warning: pixman-0.40.0-1.0 is up to date -- reinstalling
warning: pkgconf-1.7.3-1.0 is up to date -- reinstalling
warning: pkgfile-21-1.0 is up to date -- reinstalling
warning: polkit-0.116-5.1 is up to date -- reinstalling
warning: polkit-qt5-0.113.0-2.0 is up to date -- reinstalling
warning: poppler-0.88.0-1.0 is up to date -- reinstalling
warning: poppler-data-0.4.9-2.0 is up to date -- reinstalling
warning: poppler-glib-0.88.0-1.0 is up to date -- reinstalling
warning: poppler-qt5-0.88.0-1.0 is up to date -- reinstalling
warning: popt-1.16-12.0 is up to date -- reinstalling
warning: portaudio-1:19.6.0-6.1 is up to date -- reinstalling
warning: portsmf-234-2.0 is up to date -- reinstalling
warning: procps-ng-3.3.16-2.0 is up to date -- reinstalling
warning: protobuf-3.11.4-1.1 is up to date -- reinstalling
warning: psmisc-23.3-2.0 is up to date -- reinstalling
warning: pulseaudio-13.0-3.1 is up to date -- reinstalling
warning: pulseaudio-alsa-2-5.0 is up to date -- reinstalling
warning: pyalpm-0.9.1-2.2 is up to date -- reinstalling
warning: pygobject-devel-3.36.1-1.0 is up to date -- reinstalling
warning: pygtk-2.24.0-8.5 is up to date -- reinstalling
warning: python-3.8.3-1.0 is up to date -- reinstalling
warning: python-appdirs-1.4.4-1.0 is up to date -- reinstalling
warning: python-beaker-1.11.0-4.0 is up to date -- reinstalling
warning: python-cairo-1.19.1-1.1 is up to date -- reinstalling
warning: python-certifi-2019.11.28-1.0 is up to date -- reinstalling
warning: python-chardet-3.0.4-5.0 is up to date -- reinstalling
warning: python-css-parser-1.0.4-3.1 is up to date -- reinstalling
warning: python-dateutil-2.8.1-3.0 is up to date -- reinstalling
warning: python-dbus-1.2.16-1.0 is up to date -- reinstalling
warning: python-dbus-common-1.2.16-1.0 is up to date -- reinstalling
warning: python-distro-1.5.0-1.0 is up to date -- reinstalling
warning: python-dulwich-0.20.2-1.0 is up to date -- reinstalling
warning: python-feedparser-5.2.1-6.0 is up to date -- reinstalling
warning: python-gobject-3.36.1-1.0 is up to date -- reinstalling
warning: python-idna-2.9-1.0 is up to date -- reinstalling
warning: python-lhafile-0.2.2-3.1 is up to date -- reinstalling
warning: python-lxml-4.5.1-1.0 is up to date -- reinstalling
warning: python-opengl-3.1.5-1.0 is up to date -- reinstalling
warning: python-ordered-set-3.1.1-2.0 is up to date -- reinstalling
warning: python-packaging-20.4-1.0 is up to date -- reinstalling
warning: python-pycups-2.0.1-1.0 is up to date -- reinstalling
warning: python-pycurl-7.43.0.5-1.1 is up to date -- reinstalling
warning: python-pyenchant-2.0.0-5.1 is up to date -- reinstalling
warning: python-pyparsing-2.4.7-1.0 is up to date -- reinstalling
warning: python-regex-2020.5.14-1.0 is up to date -- reinstalling
warning: python-requests-2.23.0-1.0 is up to date -- reinstalling
warning: python-setuptools-1:47.1.1-1.0 is up to date -- reinstalling
warning: python-sgmllib-5.2.1-6.0 is up to date -- reinstalling
warning: python-six-1.15.0-1.0 is up to date -- reinstalling
warning: python-urllib3-1.25.9-1.1 is up to date -- reinstalling
warning: python2-2.7.18-1.0 is up to date -- reinstalling
warning: python2-cairo-1.18.2-4.2 is up to date -- reinstalling
warning: python2-gobject2-2.28.7-5.0 is up to date -- reinstalling
warning: python2-numpy-1.16.6-1.0 is up to date -- reinstalling
warning: qpdf-10.0.1-1.0 is up to date -- reinstalling
warning: qt5-base-5.15.0-2.0 is up to date -- reinstalling
warning: qt5-charts-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-declarative-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-imageformats-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-location-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-multimedia-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-script-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-sensors-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-speech-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-svg-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-tools-5.14.2-2.1 is up to date -- reinstalling
warning: qt5-webchannel-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-webengine-5.15.0-1.1 is up to date -- reinstalling
warning: qt5-webkit-5.212.0alpha4-6.0 is up to date -- reinstalling
warning: qt5-x11extras-5.15.0-1.0 is up to date -- reinstalling
warning: qt5-xmlpatterns-5.15.0-1.0 is up to date -- reinstalling
warning: quazip-0.9.1-1.0 is up to date -- reinstalling
warning: raptor-2.0.15-13.0 is up to date -- reinstalling
warning: rasqal-1:0.9.33-3.0 is up to date -- reinstalling
warning: readline-8.0.004-1.0 is up to date -- reinstalling
warning: recode-3.7.6-2.0 is up to date -- reinstalling
warning: redland-1:1.0.17-7.4 is up to date -- reinstalling
warning: reiserfsprogs-3.6.27-3.0 is up to date -- reinstalling
warning: rest-0.8.1-3.0 is up to date -- reinstalling
warning: retroarch-1.8.5-1.0 is up to date -- reinstalling
warning: rhash-1.3.9-1.0 is up to date -- reinstalling
warning: rsync-3.1.3-3.0 is up to date -- reinstalling
warning: rtkit-0.13-1.0 is up to date -- reinstalling
warning: rtmpdump-1:2.4.r96.fa8646d-5.3 is up to date -- reinstalling
warning: rubberband-1.8.2-3.3 is up to date -- reinstalling
warning: run-parts-4.8.6.1-2.1 is up to date -- reinstalling
warning: s-nail-14.9.19-1.0 is up to date -- reinstalling
warning: sane-1.0.30-1.0 is up to date -- reinstalling
warning: sbc-1.4-1.3 is up to date -- reinstalling
warning: scantailor-0.9.12.2-4.5 is up to date -- reinstalling
warning: scummvm-2.1.2-1.0 is up to date -- reinstalling
warning: sdl-1.2.15-14.0 is up to date -- reinstalling
warning: sdl2-2.0.12-1.0 is up to date -- reinstalling
warning: sdl2_net-1:2.0.1-3.0 is up to date -- reinstalling
warning: sdl_net-1.2.8-5.0 is up to date -- reinstalling
warning: sdl_sound-1.0.3-7.0 is up to date -- reinstalling
warning: sed-4.8-1.0 is up to date -- reinstalling
warning: serd-0.30.4-1.0 is up to date -- reinstalling
warning: serf-1.3.9-3.0 is up to date -- reinstalling
warning: setconf-0.7.6-1.0 is up to date -- reinstalling
warning: shaderc-2020.0-1.0 is up to date -- reinstalling
warning: shadow-4.8.1-1.1 is up to date -- reinstalling
warning: shared-mime-info-2.0+1+g6bf9e4f-2.0 is up to date -- reinstalling
warning: sigil-1.2.1-1.1 is up to date -- reinstalling
warning: simplescreenrecorder-0.4.2-1.0 is up to date -- reinstalling
warning: smartmontools-7.1-1.0 is up to date -- reinstalling
warning: smbclient-4.11.3-3.0 is up to date -- reinstalling
warning: smpeg-0.4.5-4.0 is up to date -- reinstalling
warning: smplayer-20.4.2-1.0 is up to date -- reinstalling
warning: smtube-20.1.0-1.1 is up to date -- reinstalling
warning: snappy-1.1.8-1.0 is up to date -- reinstalling
warning: solid-5.70.0-1.0 is up to date -- reinstalling
warning: sonnet-5.70.0-1.0 is up to date -- reinstalling
warning: sord-0.16.4-1.3 is up to date -- reinstalling
warning: sound-theme-freedesktop-0.8-4.0 is up to date -- reinstalling
warning: soundtouch-2.1.2-2.0 is up to date -- reinstalling
warning: spandsp-0.0.6-3.0 is up to date -- reinstalling
warning: speex-1.2.0-2.0 is up to date -- reinstalling
warning: speexdsp-1.2.0-2.0 is up to date -- reinstalling
warning: spirv-tools-2020.2-1.0 is up to date -- reinstalling
warning: sqlite-3.32.1-1.0 is up to date -- reinstalling
warning: sratom-0.6.4-1.3 is up to date -- reinstalling
warning: srt-1.4.1-1.0 is up to date -- reinstalling
warning: startup-notification-0.12-6.0 is up to date -- reinstalling
warning: subversion-1.14.0-1.0 is up to date -- reinstalling
warning: sudo-1.9.0-1.0 is up to date -- reinstalling
warning: suil-0.10.6-2.0 is up to date -- reinstalling
warning: suitesparse-5.7.2-1.0 is up to date -- reinstalling
warning: sysfsutils-2.1.0-11.0 is up to date -- reinstalling
warning: syslinux-6.04.pre2.r11.gbf6db5b4-3.0 is up to date -- reinstalling
warning: system-config-printer-1.5.12+33+g23b454ef-1.0 is up to date -- reinstalling
warning: systemd-245.5-2.0 is up to date -- reinstalling
warning: systemd-libs-245.5-2.0 is up to date -- reinstalling
warning: systemd-sysvcompat-245.5-2.0 is up to date -- reinstalling
warning: t1lib-5.1.2-7.0 is up to date -- reinstalling
warning: taglib-1.11.1-4.0 is up to date -- reinstalling
warning: talloc-2.3.1-1.0 is up to date -- reinstalling
warning: tar-1.32-3.0 is up to date -- reinstalling
warning: tdb-1.4.3-2.0 is up to date -- reinstalling
warning: telegram-desktop-2.1.7-1.0 is up to date -- reinstalling
warning: tepl-4.4.0-1.0 is up to date -- reinstalling
warning: tevent-1:0.10.2-1.0 is up to date -- reinstalling
warning: texinfo-6.7-3.0 is up to date -- reinstalling
warning: thin-provisioning-tools-0.8.5-3.0 is up to date -- reinstalling
warning: tree-1.8.0-2.0 is up to date -- reinstalling
warning: tslib-1.21-2.0 is up to date -- reinstalling
warning: ttf-bitstream-vera-1.10-13.0 is up to date -- reinstalling
warning: ttf-dejavu-2.37-3.0 is up to date -- reinstalling
warning: ttf-indic-otf-0.2-9.1 is up to date -- reinstalling
warning: ttf-liberation-2.1.0-1.0 is up to date -- reinstalling
warning: ttf-sazanami-20040629-10.1 is up to date -- reinstalling
warning: tvtime-1.0.11-3.2 is up to date -- reinstalling
warning: twolame-0.4.0-2.3 is up to date -- reinstalling
warning: tzdata-2020a-1.0 is up to date -- reinstalling
warning: uchardet-0.0.7-1.0 is up to date -- reinstalling
warning: udisks2-2.9.0-1.0 is up to date -- reinstalling
warning: unrar-1:5.9.3-2.0 is up to date -- reinstalling
warning: unzip-6.0-14.0 is up to date -- reinstalling
warning: upower-0.99.11-2.0 is up to date -- reinstalling
warning: usbmuxd-1.1.0+69+g8a69f1a-1.1 is up to date -- reinstalling
warning: usbutils-012-2.0 is up to date -- reinstalling
warning: util-linux-2.35.1-2.0 is up to date -- reinstalling
warning: v4l-utils-1.20.0-1.0 is up to date -- reinstalling
warning: vamp-plugin-sdk-2.10.0-1.0 is up to date -- reinstalling
warning: vi-1:070224-4.0 is up to date -- reinstalling
warning: vice-3.4-2.1 is up to date -- reinstalling
warning: vid.stab-1.1-2.4 is up to date -- reinstalling
warning: vlc-3.0.10-1.0 is up to date -- reinstalling
warning: volume_key-0.3.12-2.0 is up to date -- reinstalling
warning: vte-common-0.60.3-1.0 is up to date -- reinstalling
warning: vte3-0.60.3-1.0 is up to date -- reinstalling
warning: vulkan-icd-loader-1.2.141-1.0 is up to date -- reinstalling
warning: wavpack-5.3.0-1.0 is up to date -- reinstalling
warning: wayland-1.18.0-2.3 is up to date -- reinstalling
warning: wayland-protocols-1.20-1.0 is up to date -- reinstalling
warning: webkit2gtk-2.28.2-2.0 is up to date -- reinstalling
warning: webrtc-audio-processing-0.3.1-1.2 is up to date -- reinstalling
warning: weston-8.0.0-2.0 is up to date -- reinstalling
warning: wget-1.20.3-2.2 is up to date -- reinstalling
warning: which-2.21-5.2 is up to date -- reinstalling
warning: wildmidi-0.4.3-1.0 is up to date -- reinstalling
warning: wine-5.9-1.0 is up to date -- reinstalling
warning: winetricks-20200412-1.0 is up to date -- reinstalling
warning: wireless_tools-30.pre9-3.0 is up to date -- reinstalling
warning: woff2-1.0.2-3.0 is up to date -- reinstalling
warning: wpebackend-fdo-1.6.0-1.0 is up to date -- reinstalling
warning: wxgtk-common-3.0.5.1-1.0 is up to date -- reinstalling
warning: wxgtk2-3.0.5.1-1.0 is up to date -- reinstalling
warning: wxgtk3-3.0.5.1-1.0 is up to date -- reinstalling
warning: x264-3:0.159.r2999.296494a-1.0 is up to date -- reinstalling
warning: x265-3.3-1.0 is up to date -- reinstalling
warning: xbitmaps-1.1.2-2.0 is up to date -- reinstalling
warning: xcb-proto-1.14-1.0 is up to date -- reinstalling
warning: xcb-util-0.4.0-3.0 is up to date -- reinstalling
warning: xcb-util-cursor-0.1.3-3.0 is up to date -- reinstalling
warning: xcb-util-image-0.4.0-3.0 is up to date -- reinstalling
warning: xcb-util-keysyms-0.4.0-3.0 is up to date -- reinstalling
warning: xcb-util-renderutil-0.3.9-3.0 is up to date -- reinstalling
warning: xcb-util-wm-0.4.1-3.0 is up to date -- reinstalling
warning: xcb-util-xrm-1.3-2.0 is up to date -- reinstalling
warning: xdg-dbus-proxy-0.1.2-2.0 is up to date -- reinstalling
warning: xdg-utils-1.1.3+19+g9816ebb-1.0 is up to date -- reinstalling
warning: xdotool-3.20160805.1-2.0 is up to date -- reinstalling
warning: xf86-input-libinput-0.30.0-1.0 is up to date -- reinstalling
warning: xf86-video-ati-1:19.1.0-1.1 is up to date -- reinstalling
warning: xf86-video-fbdev-0.5.0-1.6 is up to date -- reinstalling
warning: xf86-video-nouveau-1.0.16-1.3 is up to date -- reinstalling
warning: xf86-video-vesa-2.4.0-3.0 is up to date -- reinstalling
warning: xfsprogs-5.6.0-2.0 is up to date -- reinstalling
warning: xkeyboard-config-2.30-1.0 is up to date -- reinstalling
warning: xmlsec-1.2.30-2.0 is up to date -- reinstalling
warning: xorg-bdftopcf-1.1-2.0 is up to date -- reinstalling
warning: xorg-font-util-1.3.2-1.0 is up to date -- reinstalling
warning: xorg-font-utils-7.6-6.0 is up to date -- reinstalling
warning: xorg-fonts-alias-1.0.3-3.0 is up to date -- reinstalling
warning: xorg-fonts-encodings-1.0.5-2.0 is up to date -- reinstalling
warning: xorg-luit-1.1.1-3.2 is up to date -- reinstalling
warning: xorg-mkfontscale-1.2.1-2.1 is up to date -- reinstalling
warning: xorg-server-1.20.8-1.0 is up to date -- reinstalling
warning: xorg-server-common-1.20.8-1.0 is up to date -- reinstalling
warning: xorg-server-devel-1.20.8-1.0 is up to date -- reinstalling
warning: xorg-setxkbmap-1.3.2-1.0 is up to date -- reinstalling
warning: xorg-twm-1.0.10-2.0 is up to date -- reinstalling
warning: xorg-util-macros-1.19.2-2.0 is up to date -- reinstalling
warning: xorg-xauth-1.1-1.0 is up to date -- reinstalling
warning: xorg-xdriinfo-1.0.6-2.0 is up to date -- reinstalling
warning: xorg-xinit-1.4.1-1.1 is up to date -- reinstalling
warning: xorg-xkbcomp-1.4.3-1.0 is up to date -- reinstalling
warning: xorg-xlsfonts-1.0.6-2.0 is up to date -- reinstalling
warning: xorg-xmessage-1.0.5-2.0 is up to date -- reinstalling
warning: xorg-xmodmap-1.0.10-1.0 is up to date -- reinstalling
warning: xorg-xprop-1.2.4-1.0 is up to date -- reinstalling
warning: xorg-xrandr-1.5.1-1.0 is up to date -- reinstalling
warning: xorg-xrdb-1.2.0-1.0 is up to date -- reinstalling
warning: xorg-xset-1.2.4-2.0 is up to date -- reinstalling
warning: xorgproto-2020.1-1.0 is up to date -- reinstalling
warning: xsane-0.999-5.0 is up to date -- reinstalling
warning: xsane-gimp-0.999-5.0 is up to date -- reinstalling
warning: xterm-356-1.0 is up to date -- reinstalling
warning: xtrans-1.4.0-2.0 is up to date -- reinstalling
warning: xvidcore-1.3.7-1.0 is up to date -- reinstalling
warning: xxhash-0.7.3-1.0 is up to date -- reinstalling
warning: xz-5.2.5-1.0 is up to date -- reinstalling
warning: yajl-2.1.0-2.3 is up to date -- reinstalling
warning: youtube-dl-2020.05.29-1.0 is up to date -- reinstalling
warning: zbar-0.23.1-1.0 is up to date -- reinstalling
warning: zenity-3.32.0+17+gfb0938f-2.0 is up to date -- reinstalling
warning: zip-3.0-9.0 is up to date -- reinstalling
warning: zlib-1:1.2.11-4.0 is up to date -- reinstalling
warning: zsnes-1.51-20.5 is up to date -- reinstalling
warning: zstd-1.4.5-1.0 is up to date -- reinstalling
warning: zvbi-0.2.35-4.0 is up to date -- reinstalling
error: failed to prepare transaction (package architecture is not valid)
:: package a52dec-0.7.4-11.0-i686 does not have a valid architecture
:: package aalib-1.4rc5-14.0-i686 does not have a valid architecture
:: package alsa-lib-1.2.2-1.0-i686 does not have a valid architecture
:: package alsa-plugins-1.2.2-1.2-i686 does not have a valid architecture
:: package alsa-utils-1.2.2-1.1-i686 does not have a valid architecture
:: package amtk-5.0.2-1.0-i686 does not have a valid architecture
:: package amule-11025-1.0-i686 does not have a valid architecture
:: package android-file-transfer-3.9-1.5-i686 does not have a valid architecture
:: package aom-1.0.0.errata1+avif-1.0-i686 does not have a valid architecture
:: package apr-1.6.5-3.0-i686 does not have a valid architecture
:: package apr-util-1.6.1-5.5-i686 does not have a valid architecture
:: package aribb24-1.0.3-2.1-i686 does not have a valid architecture
:: package aspell-0.60.8-2.0-i686 does not have a valid architecture
:: package at-spi2-atk-2.34.2-1.0-i686 does not have a valid architecture
:: package at-spi2-core-2.36.0-1.0-i686 does not have a valid architecture
:: package atk-2.36.0-1.0-i686 does not have a valid architecture
:: package atkmm-2.28.0-2.0-i686 does not have a valid architecture
:: package attica-5.70.0-1.0-i686 does not have a valid architecture
:: package audacity-1:2.3.3-2.1-i686 does not have a valid architecture
:: package avahi-0.8+15+ge8a3dd0-1.0-i686 does not have a valid architecture
:: package avidemux-cli-2.7.4-4.0-i686 does not have a valid architecture
:: package avidemux-qt-2.7.4-4.0-i686 does not have a valid architecture
:: package babl-0.1.74-1.0-i686 does not have a valid architecture
:: package bc-1.07.1-4.0-i686 does not have a valid architecture
:: package blas-3.9.0-3.0-i686 does not have a valid architecture
:: package bluez-libs-5.54-2.0-i686 does not have a valid architecture
:: package boost-libs-1.72.0-2.0-i686 does not have a valid architecture
:: package brotli-1.0.7-3.1-i686 does not have a valid architecture
:: package bubblewrap-0.4.1-1.0-i686 does not have a valid architecture
:: package cabextract-1.9.1-1.1-i686 does not have a valid architecture
:: package cairo-1.17.2+25+gaee96d175-1.0-i686 does not have a valid architecture
:: package cairo-perl-1.107-1.0-i686 does not have a valid architecture
:: package cairomm-1.12.2-4.0-i686 does not have a valid architecture
:: package cblas-3.9.0-3.0-i686 does not have a valid architecture
:: package cdparanoia-10.2-8.0-i686 does not have a valid architecture
:: package celt-0.11.3-4.0-i686 does not have a valid architecture
:: package chromaprint-1.5.0-1.0-i686 does not have a valid architecture
:: package chromium-74.0.3729.169-2.0-i686 does not have a valid architecture
:: package cifs-utils-6.10-1.1-i686 does not have a valid architecture
:: package clucene-2.3.3.4-11.0-i686 does not have a valid architecture
:: package cmake-3.17.2-1.0-i686 does not have a valid architecture
:: package cmark-0.29.0-2.0-i686 does not have a valid architecture
:: package colord-1.4.4+9+g1ce26da-1.0-i686 does not have a valid architecture
:: package confuse-3.2.2-1.6-i686 does not have a valid architecture
:: package conky-1.11.5-2.1-i686 does not have a valid architecture
:: package convertlit-1.8-10.0-i686 does not have a valid architecture
:: package crypto++-8.2.0-3.0-i686 does not have a valid architecture
:: package cups-2.3.3-1.0-i686 does not have a valid architecture
:: package cups-filters-1.27.5-1.0-i686 does not have a valid architecture
:: package dav1d-0.7.0-1.0-i686 does not have a valid architecture
:: package dbus-c++-0.9.0-9.0-i686 does not have a valid architecture
:: package dbus-glib-0.110-2.0-i686 does not have a valid architecture
:: package dconf-0.36.0-1.0-i686 does not have a valid architecture
:: package desktop-file-utils-0.24-2.0-i686 does not have a valid architecture
:: package djview-4.10.6-2.6-i686 does not have a valid architecture
:: package djvulibre-3.5.27-6.0-i686 does not have a valid architecture
:: package dosbox-0.74.3-1.3-i686 does not have a valid architecture
:: package double-conversion-3.1.5-1.0-i686 does not have a valid architecture
:: package easytag-2.4.3-2.2-i686 does not have a valid architecture
:: package ebook-tools-0.2.2-6.2-i686 does not have a valid architecture
:: package ecm-tools-1.03-2.5-i686 does not have a valid architecture
:: package egl-wayland-1.1.5-1.0-i686 does not have a valid architecture
:: package enca-1.19-4.0-i686 does not have a valid architecture
:: package enchant-2.2.8-1.0-i686 does not have a valid architecture
:: package evince-3.36.3-1.0-i686 does not have a valid architecture
:: package exiv2-0.27.2-1.2-i686 does not have a valid architecture
:: package expac-10-2.0-i686 does not have a valid architecture
:: package faac-1.30-2.0-i686 does not have a valid architecture
:: package faad2-2.9.2-1.0-i686 does not have a valid architecture
:: package faudio-20.06-1.0-i686 does not have a valid architecture
:: package feh-3.4.1-1.0-i686 does not have a valid architecture
:: package ffmpeg-1:4.2.2-6.0-i686 does not have a valid architecture
:: package ffms2-2.23.1-3.8-i686 does not have a valid architecture
:: package fftw-3.3.8-3.0-i686 does not have a valid architecture
:: package file-roller-3.36.2-1.0-i686 does not have a valid architecture
:: package firefox-77.0.1-1.1-i686 does not have a valid architecture
:: package flac-1.3.3-1.1-i686 does not have a valid architecture
:: package flashplugin-32.0.0.363-1.0-i686 does not have a valid architecture
:: package fluidsynth-2.1.2-1.0-i686 does not have a valid architecture
:: package fmt-6.2.1-3.0-i686 does not have a valid architecture
:: package fontconfig-2:2.13.91+24+g75eadca-2.1-i686 does not have a valid architecture
:: package foomatic-db-engine-4:20200206-1.0-i686 does not have a valid architecture
:: package freeglut-3.2.1-1.0-i686 does not have a valid architecture
:: package freetype2-2.10.2-1.0-i686 does not have a valid architecture
:: package fribidi-1.0.9-1.0-i686 does not have a valid architecture
:: package fs-uae-3.0.5-1.0-i686 does not have a valid architecture
:: package fuse-common-3.9.1-1.0-i686 does not have a valid architecture
:: package fuse2-2.9.9-4.0-i686 does not have a valid architecture
:: package fuse3-3.9.1-1.0-i686 does not have a valid architecture
:: package galculator-2.1.4-4.5-i686 does not have a valid architecture
:: package gcr-3.36-1.0-i686 does not have a valid architecture
:: package gd-2.3.0-1.0-i686 does not have a valid architecture
:: package gdk-pixbuf2-2.40.0-2.0-i686 does not have a valid architecture
:: package gedit-3.36.2-1.0-i686 does not have a valid architecture
:: package gegl-0.4.22-1.0-i686 does not have a valid architecture
:: package gendesk-1.0.5-2.0-i686 does not have a valid architecture
:: package geoclue-2.5.6-1.0-i686 does not have a valid architecture
:: package geocode-glib-3.26.2-1.0-i686 does not have a valid architecture
:: package geoip-1.6.12-2.0-i686 does not have a valid architecture
:: package gftp-2.0.19-10.2-i686 does not have a valid architecture
:: package ghostscript-9.52-1.4-i686 does not have a valid architecture
:: package giflib-5.2.1-1.2-i686 does not have a valid architecture
:: package gimp-2.10.18-6.0-i686 does not have a valid architecture
:: package git-2.27.0-1.0-i686 does not have a valid architecture
:: package glew-2.2.0-2.0-i686 does not have a valid architecture
:: package glib-networking-2.64.3-1.0-i686 does not have a valid architecture
:: package glib-perl-1.329-2.2-i686 does not have a valid architecture
:: package glibmm-2.64.2-1.0-i686 does not have a valid architecture
:: package glslang-8.13.3743-1.0-i686 does not have a valid architecture
:: package glu-9.0.1-2.0-i686 does not have a valid architecture
:: package gnome-desktop-1:3.36.2-1.0-i686 does not have a valid architecture
:: package gnome-screenshot-3.36.0-1.0-i686 does not have a valid architecture
:: package gobject-introspection-runtime-1.64.1-2.3-i686 does not have a valid architecture
:: package gparted-1.1.0-1.1-i686 does not have a valid architecture
:: package gpicview-0.2.5-4.5-i686 does not have a valid architecture
:: package gptfdisk-1.0.5-1.1-i686 does not have a valid architecture
:: package graphene-1.10.0-1.2-i686 does not have a valid architecture
:: package graphite-1:1.3.14-1.0-i686 does not have a valid architecture
:: package gsm-1.0.19-1.0-i686 does not have a valid architecture
:: package gsmartcontrol-1.1.3-2.7-i686 does not have a valid architecture
:: package gspell-1.8.3-1.1-i686 does not have a valid architecture
:: package gssdp-1.2.2-1.0-i686 does not have a valid architecture
:: package gst-libav-1.16.2-2.0-i686 does not have a valid architecture
:: package gst-plugin-gtk-1.16.2-3.0-i686 does not have a valid architecture
:: package gst-plugins-bad-1.16.2-8.0-i686 does not have a valid architecture
:: package gst-plugins-bad-libs-1.16.2-8.0-i686 does not have a valid architecture
:: package gst-plugins-base-1.16.2-2.0-i686 does not have a valid architecture
:: package gst-plugins-base-libs-1.16.2-2.0-i686 does not have a valid architecture
:: package gst-plugins-good-1.16.2-3.0-i686 does not have a valid architecture
:: package gst-plugins-ugly-1.16.2-3.0-i686 does not have a valid architecture
:: package gstreamer-1.16.2-2.0-i686 does not have a valid architecture
:: package gtk-engines-2.21.0-5.0-i686 does not have a valid architecture
:: package gtk-update-icon-cache-1:3.24.20-1.0-i686 does not have a valid architecture
:: package gtk2-2.24.32-2.0-i686 does not have a valid architecture
:: package gtk2-perl-1.24993-1.0-i686 does not have a valid architecture
:: package gtk3-1:3.24.20-1.0-i686 does not have a valid architecture
:: package gtkmm3-3.24.2-2.0-i686 does not have a valid architecture
:: package gtksourceview4-4.6.0-1.0-i686 does not have a valid architecture
:: package gtkspell3-3.0.10-2.0-i686 does not have a valid architecture
:: package gupnp-1.2.2-1.0-i686 does not have a valid architecture
:: package gupnp-igd-0.2.5+3+gedd78a6-3.0-i686 does not have a valid architecture
:: package gutenprint-5.3.3-2.0-i686 does not have a valid architecture
:: package gvfs-1.44.1-1.0-i686 does not have a valid architecture
:: package gvfs-mtp-1.44.1-1.0-i686 does not have a valid architecture
:: package harfbuzz-2.6.5-2.1-i686 does not have a valid architecture
:: package harfbuzz-icu-2.6.5-2.1-i686 does not have a valid architecture
:: package hexchat-2.14.3-1.0-i686 does not have a valid architecture
:: package hplip-1:3.20.5-2.0-i686 does not have a valid architecture
:: package hspell-1.4-3.0-i686 does not have a valid architecture
:: package hunspell-1.7.0-3.0-i686 does not have a valid architecture
:: package hwloc-2.2.0-1.0-i686 does not have a valid architecture
:: package hyphen-2.8.8-3.0-i686 does not have a valid architecture
:: package i3-gaps-4.18.1-2.0-i686 does not have a valid architecture
:: package i3blocks-1.5-3.0-i686 does not have a valid architecture
:: package i3lock-2.12-1.1-i686 does not have a valid architecture
:: package i3status-2.13-2.1-i686 does not have a valid architecture
:: package id3lib-3.8.3-18.0-i686 does not have a valid architecture
:: package ijs-0.35-3.0-i686 does not have a valid architecture
:: package imagemagick-7.0.10.11-3.0-i686 does not have a valid architecture
:: package imlib2-1.6.1-2.0-i686 does not have a valid architecture
:: package intel-tbb-2020.2-1.0-i686 does not have a valid architecture
:: package iscan-2.30.3.1-1-i686 does not have a valid architecture
:: package jack2-1.9.14-1.4-i686 does not have a valid architecture
:: package jansson-2.13.1-1.0-i686 does not have a valid architecture
:: package jasper-2.0.16-2.0-i686 does not have a valid architecture
:: package jbig2dec-0.18-1.0-i686 does not have a valid architecture
:: package jre10-openjdk-headless-10.0.2.u13-2.8-i686 does not have a valid architecture
:: package js60-60.9.0-2.1-i686 does not have a valid architecture
:: package jshon-20131105-3.2-i686 does not have a valid architecture
:: package json-glib-1.4.4-2.0-i686 does not have a valid architecture
:: package jsoncpp-1.9.2-1.1-i686 does not have a valid architecture
:: package k3b-1:20.04.1-1.0-i686 does not have a valid architecture
:: package karchive-5.70.0-1.0-i686 does not have a valid architecture
:: package kauth-5.70.0-1.0-i686 does not have a valid architecture
:: package kbookmarks-5.70.0-1.0-i686 does not have a valid architecture
:: package kcmutils-5.70.0-1.0-i686 does not have a valid architecture
:: package kcodecs-5.70.0-1.0-i686 does not have a valid architecture
:: package kcompletion-5.70.0-1.0-i686 does not have a valid architecture
:: package kconfig-5.70.0-1.0-i686 does not have a valid architecture
:: package kconfigwidgets-5.70.0-1.0-i686 does not have a valid architecture
:: package kcoreaddons-5.70.0-1.0-i686 does not have a valid architecture
:: package kcrash-5.70.0-1.0-i686 does not have a valid architecture
:: package kdbusaddons-5.70.0-1.0-i686 does not have a valid architecture
:: package kdeclarative-5.70.0-1.0-i686 does not have a valid architecture
:: package kded-5.70.0-1.0-i686 does not have a valid architecture
:: package kfilemetadata-5.70.0-1.0-i686 does not have a valid architecture
:: package kfloppy-20.04.1-1.0-i686 does not have a valid architecture
:: package kglobalaccel-5.70.0-1.0-i686 does not have a valid architecture
:: package kguiaddons-5.70.0-1.0-i686 does not have a valid architecture
:: package ki18n-5.70.0-1.0-i686 does not have a valid architecture
:: package kiconthemes-5.70.0-1.0-i686 does not have a valid architecture
:: package kio-5.70.1-1.0-i686 does not have a valid architecture
:: package kitemviews-5.70.0-1.0-i686 does not have a valid architecture
:: package kjobwidgets-5.70.0-1.0-i686 does not have a valid architecture
:: package knewstuff-5.70.0-1.0-i686 does not have a valid architecture
:: package knotifications-5.70.0-1.0-i686 does not have a valid architecture
:: package knotifyconfig-5.70.0-1.0-i686 does not have a valid architecture
:: package kpackage-5.70.0-1.0-i686 does not have a valid architecture
:: package kservice-5.70.0-1.0-i686 does not have a valid architecture
:: package ktextwidgets-5.70.0-1.0-i686 does not have a valid architecture
:: package kwallet-5.70.0-1.0-i686 does not have a valid architecture
:: package kwidgetsaddons-5.70.0-1.0-i686 does not have a valid architecture
:: package kwindowsystem-5.70.0-1.0-i686 does not have a valid architecture
:: package kxmlgui-5.70.0-1.0-i686 does not have a valid architecture
:: package l-smash-2.14.5-2.0-i686 does not have a valid architecture
:: package ladspa-1.15-1.0-i686 does not have a valid architecture
:: package lame-3.100-2.1-i686 does not have a valid architecture
:: package lapack-3.9.0-3.0-i686 does not have a valid architecture
:: package lcms2-2.10-2.0-i686 does not have a valid architecture
:: package ldb-1:2.1.2-1.0-i686 does not have a valid architecture
:: package leafpad-0.8.18.1-9.0-i686 does not have a valid architecture
:: package lensfun-0.3.95-2.0-i686 does not have a valid architecture
:: package libabw-0.1.3-2.0-i686 does not have a valid architecture
:: package libao-1.2.2-3.0-i686 does not have a valid architecture
:: package libass-0.14.0-1.10-i686 does not have a valid architecture
:: package libasyncns-0.8+3+g68cd5af-2.3-i686 does not have a valid architecture
:: package libatasmart-0.19-5.0-i686 does not have a valid architecture
:: package libatomic_ops-7.6.10-1.2-i686 does not have a valid architecture
:: package libavc1394-0.5.4-4.0-i686 does not have a valid architecture
:: package libblockdev-2.24-1.0-i686 does not have a valid architecture
:: package libbluray-1.2.0-3.0-i686 does not have a valid architecture
:: package libbs2b-3.1.0-6.10-i686 does not have a valid architecture
:: package libbsd-0.10.0-2.0-i686 does not have a valid architecture
:: package libburn-1.5.2-2.0-i686 does not have a valid architecture
:: package libbytesize-2.3-1.0-i686 does not have a valid architecture
:: package libcaca-0.99.beta19-3.0-i686 does not have a valid architecture
:: package libcanberra-0.30+2+gc0620e4-3.0-i686 does not have a valid architecture
:: package libcanberra-pulse-0.30+2+gc0620e4-3.0-i686 does not have a valid architecture
:: package libcddb-1.3.2-6.0-i686 does not have a valid architecture
:: package libcdio-2.1.0-1.0-i686 does not have a valid architecture
:: package libcdio-paranoia-10.2+2.0.1-2.0-i686 does not have a valid architecture
:: package libcdr-0.1.6-2.0-i686 does not have a valid architecture
:: package libcmis-0.5.2-4.0-i686 does not have a valid architecture
:: package libconfig-1.7.2-2.0-i686 does not have a valid architecture
:: package libcroco-0.6.13-1.3-i686 does not have a valid architecture
:: package libcups-2.3.3-1.0-i686 does not have a valid architecture
:: package libcurl-compat-7.70.0-1.0-i686 does not have a valid architecture
:: package libdaemon-0.14-5.0-i686 does not have a valid architecture
:: package libdatrie-0.2.12-2.0-i686 does not have a valid architecture
:: package libdbusmenu-qt5-0.9.3+16.04.20160218-4.6-i686 does not have a valid architecture
:: package libdc1394-2.2.6-1.0-i686 does not have a valid architecture
:: package libdca-0.0.7-1.0-i686 does not have a valid architecture
:: package libde265-1.0.5-1.0-i686 does not have a valid architecture
:: package libdrm-2.4.102-1.0-i686 does not have a valid architecture
:: package libdv-1.0.0-9.0-i686 does not have a valid architecture
:: package libdvbpsi-1:1.3.3-1.1-i686 does not have a valid architecture
:: package libdvdcss-1.4.2-2.0-i686 does not have a valid architecture
:: package libdvdnav-6.1.0-2.0-i686 does not have a valid architecture
:: package libdvdread-6.1.1-1.0-i686 does not have a valid architecture
:: package libe-book-0.1.3-7.0-i686 does not have a valid architecture
:: package libebml-1.3.10-2.0-i686 does not have a valid architecture
:: package libepoxy-1.5.4-2.0-i686 does not have a valid architecture
:: package libepubgen-0.1.1-2.0-i686 does not have a valid architecture
:: package libetonyek-0.1.9-2.0-i686 does not have a valid architecture
:: package libev-4.33-1.0-i686 does not have a valid architecture
:: package libevdev-1.9.0-1.0-i686 does not have a valid architecture
:: package libexif-0.6.21-3.5-i686 does not have a valid architecture
:: package libexttextcat-3.4.5-2.0-i686 does not have a valid architecture
:: package libfbclient-3.0.4.33054-2.0-i686 does not have a valid architecture
:: package libfdk-aac-2.0.1-1.0-i686 does not have a valid architecture
:: package libffado-2.4.2-3.4-i686 does not have a valid architecture
:: package libfm-1.3.1-1.5-i686 does not have a valid architecture
:: package libfm-extra-1.3.1-1.5-i686 does not have a valid architecture
:: package libfm-gtk2-1.3.1-1.5-i686 does not have a valid architecture
:: package libfontenc-1.1.4-2.0-i686 does not have a valid architecture
:: package libfreehand-0.1.2-3.0-i686 does not have a valid architecture
:: package libftdi-1.4-4.1-i686 does not have a valid architecture
:: package libgexiv2-0.12.1-1.0-i686 does not have a valid architecture
:: package libglade-2.6.4-7.0-i686 does not have a valid architecture
:: package libglvnd-1.3.1-1.0-i686 does not have a valid architecture
:: package libgme-0.6.3-1.0-i686 does not have a valid architecture
:: package libgphoto2-2.5.24-1.0-i686 does not have a valid architecture
:: package libgtop-2.40.0+2+g31db82ef-1.0-i686 does not have a valid architecture
:: package libgudev-233-1.2-i686 does not have a valid architecture
:: package libgusb-0.3.4-1.0-i686 does not have a valid architecture
:: package libgxps-0.3.1-2.0-i686 does not have a valid architecture
:: package libheif-1.7.0-1.0-i686 does not have a valid architecture
:: package libibus-1.5.22-1.0-i686 does not have a valid architecture
:: package libice-1.0.10-3.0-i686 does not have a valid architecture
:: package libid3tag-0.15.1b-11.0-i686 does not have a valid architecture
:: package libidn-1.35-3.0-i686 does not have a valid architecture
:: package libiec61883-1.2.0-6.0-i686 does not have a valid architecture
:: package libieee1284-0.2.11-9.0-i686 does not have a valid architecture
:: package libimobiledevice-1.2.0+87+g92c5462-7.0-i686 does not have a valid architecture
:: package libinput-1.15.5-1.0-i686 does not have a valid architecture
:: package libinstpatch-1.1.4-1.0-i686 does not have a valid architecture
:: package libixion-0.15.0-1.0-i686 does not have a valid architecture
:: package libjpeg-turbo-2.0.4-1.0-i686 does not have a valid architecture
:: package libkate-0.4.1-7.0-i686 does not have a valid architecture
:: package libkcddb-20.04.1-1.0-i686 does not have a valid architecture
:: package libkeybinder2-0.3.1-3.7-i686 does not have a valid architecture
:: package liblangtag-0.6.3-2.0-i686 does not have a valid architecture
:: package liblouis-3.13.0-1.0-i686 does not have a valid architecture
:: package liblqr-0.4.2-3.0-i686 does not have a valid architecture
:: package liblrdf-0.6.1-3.1-i686 does not have a valid architecture
:: package libmad-0.15.1b-9.0-i686 does not have a valid architecture
:: package libmatroska-1.5.2-1.6-i686 does not have a valid architecture
:: package libmfx-1.25-3.7-i686 does not have a valid architecture
:: package libmicrodns-0.1.2-1.0-i686 does not have a valid architecture
:: package libmikmod-3.3.11.1-4.1-i686 does not have a valid architecture
:: package libmm-glib-1.12.10-1.0-i686 does not have a valid architecture
:: package libmms-0.6.4-3.0-i686 does not have a valid architecture
:: package libmng-2.0.3-3.0-i686 does not have a valid architecture
:: package libmodplug-0.8.9.0-3.0-i686 does not have a valid architecture
:: package libmp4v2-4.1.3-1.0-i686 does not have a valid architecture
:: package libmpcdec-1:0.1+r475-3.0-i686 does not have a valid architecture
:: package libmpeg2-0.5.1-7.0-i686 does not have a valid architecture
:: package libmspub-0.1.4-7.0-i686 does not have a valid architecture
:: package libmtp-1.1.17-1.0-i686 does not have a valid architecture
:: package libmusicbrainz5-5.1.0-4.0-i686 does not have a valid architecture
:: package libmwaw-0.3.16-1.0-i686 does not have a valid architecture
:: package libmypaint-1.5.1-2.0-i686 does not have a valid architecture
:: package libnet-1:1.1.6-1.0-i686 does not have a valid architecture
:: package libnice-0.1.17-1.0-i686 does not have a valid architecture
:: package libnotify-0.7.9-1.0-i686 does not have a valid architecture
:: package libnumbertext-1.0.6-1.0-i686 does not have a valid architecture
:: package libodfgen-0.1.7-2.0-i686 does not have a valid architecture
:: package libofa-0.9.3-9.0-i686 does not have a valid architecture
:: package libogg-1.3.4-2.0-i686 does not have a valid architecture
:: package libomxil-bellagio-0.9.3-3.0-i686 does not have a valid architecture
:: package liborcus-0.15.4-1.0-i686 does not have a valid architecture
:: package libpagemaker-0.0.4-2.0-i686 does not have a valid architecture
:: package libpaper-1.1.28-1.1-i686 does not have a valid architecture
:: package libpciaccess-0.16-2.0-i686 does not have a valid architecture
:: package libpeas-1.26.0-1.0-i686 does not have a valid architecture
:: package libpipewire02-0.2.7-1.0-i686 does not have a valid architecture
:: package libplacebo-1.29.1-3.0-i686 does not have a valid architecture
:: package libplist-2.1.0-3.0-i686 does not have a valid architecture
:: package libpng-1.6.37-2.0-i686 does not have a valid architecture
:: package libproxy-0.4.15+33+g454a499-1.0-i686 does not have a valid architecture
:: package libpulse-13.0-3.1-i686 does not have a valid architecture
:: package libqxp-0.0.2-4.0-i686 does not have a valid architecture
:: package libraqm-0.7.0-1.0-i686 does not have a valid architecture
:: package libraw-0.19.5-2.1-i686 does not have a valid architecture
:: package libraw1394-2.1.2-3.0-i686 does not have a valid architecture
:: package libreoffice-fresh-6.4.4-1.0-i686 does not have a valid architecture
:: package librevenge-0.0.4-3.0-i686 does not have a valid architecture
:: package librsvg-2:2.48.7-1.0-i686 does not have a valid architecture
:: package libsamplerate-0.1.9-3.0-i686 does not have a valid architecture
:: package libshout-1:2.4.3-3.0-i686 does not have a valid architecture
:: package libsidplay-1.36.59-9.0-i686 does not have a valid architecture
:: package libsigc++-2.10.3-1.0-i686 does not have a valid architecture
:: package libsm-1.2.3-2.0-i686 does not have a valid architecture
:: package libsndfile-1.0.28-3.0-i686 does not have a valid architecture
:: package libsoup-2.70.0-1.0-i686 does not have a valid architecture
:: package libsoxr-0.1.3-2.0-i686 does not have a valid architecture
:: package libspectre-0.2.9-1.0-i686 does not have a valid architecture
:: package libspiro-1:20200505-1.0-i686 does not have a valid architecture
:: package libsrtp-1:2.3.0-1.0-i686 does not have a valid architecture
:: package libssh-0.9.4-1.0-i686 does not have a valid architecture
:: package libstaroffice-0.0.7-1.0-i686 does not have a valid architecture
:: package libstdc++5-3.3.6-7.0-i686 does not have a valid architecture
:: package libsynctex-2019.51075-10.0-i686 does not have a valid architecture
:: package libtar-1.2.20-5.0-i686 does not have a valid architecture
:: package libthai-0.1.28-2.0-i686 does not have a valid architecture
:: package libtheora-1.1.1-4.2-i686 does not have a valid architecture
:: package libtiff-4.1.0-2.0-i686 does not have a valid architecture
:: package libtommath-1.2.0-3.0-i686 does not have a valid architecture
:: package libunwind-1.3.1-2.0-i686 does not have a valid architecture
:: package libupnp-1.6.25-1.4-i686 does not have a valid architecture
:: package libusb-compat-0.1.7-1.1-i686 does not have a valid architecture
:: package libusbmuxd-2.0.1-1.0-i686 does not have a valid architecture
:: package libutempter-1.1.6-3.4-i686 does not have a valid architecture
:: package libutf8proc-2.4.0-1.0-i686 does not have a valid architecture
:: package libuv-1.38.0-1.0-i686 does not have a valid architecture
:: package libva-2.7.1-1.0-i686 does not have a valid architecture
:: package libva-mesa-driver-20.0.7-3.0-i686 does not have a valid architecture
:: package libvdpau-1.4-1.0-i686 does not have a valid architecture
:: package libvisio-0.1.7-3.0-i686 does not have a valid architecture
:: package libvisual-0.4.0-8.0-i686 does not have a valid architecture
:: package libvoikko-4.3-2.0-i686 does not have a valid architecture
:: package libvorbis-1.3.6-1.1-i686 does not have a valid architecture
:: package libvpx-1.8.2-2.0-i686 does not have a valid architecture
:: package libwacom-1.3-1.0-i686 does not have a valid architecture
:: package libwbclient-4.11.3-3.0-i686 does not have a valid architecture
:: package libwebp-1.1.0-1.1-i686 does not have a valid architecture
:: package libwmf-0.2.12-2.0-i686 does not have a valid architecture
:: package libwnck-2.31.0-3.0-i686 does not have a valid architecture
:: package libwpd-0.10.3-2.0-i686 does not have a valid architecture
:: package libwpe-1.6.0-1.0-i686 does not have a valid architecture
:: package libwpg-0.3.3-2.0-i686 does not have a valid architecture
:: package libwps-0.4.11-1.0-i686 does not have a valid architecture
:: package libx11-1.6.9-7.0-i686 does not have a valid architecture
:: package libxau-1.0.9-3.0-i686 does not have a valid architecture
:: package libxaw-1.0.13-3.0-i686 does not have a valid architecture
:: package libxcb-1.14-1.0-i686 does not have a valid architecture
:: package libxcomposite-0.4.5-3.0-i686 does not have a valid architecture
:: package libxcursor-1.2.0-2.0-i686 does not have a valid architecture
:: package libxdamage-1.1.5-3.0-i686 does not have a valid architecture
:: package libxdmcp-1.1.3-3.0-i686 does not have a valid architecture
:: package libxext-1.3.4-3.0-i686 does not have a valid architecture
:: package libxfixes-5.0.3-4.0-i686 does not have a valid architecture
:: package libxfont2-2.0.4-3.0-i686 does not have a valid architecture
:: package libxft-2.3.3-2.0-i686 does not have a valid architecture
:: package libxi-1.7.10-3.0-i686 does not have a valid architecture
:: package libxinerama-1.1.4-3.0-i686 does not have a valid architecture
:: package libxkbcommon-0.10.0-1.6-i686 does not have a valid architecture
:: package libxkbcommon-x11-0.10.0-1.6-i686 does not have a valid architecture
:: package libxkbfile-1.1.0-2.0-i686 does not have a valid architecture
:: package libxml++-3.2.0-1.0-i686 does not have a valid architecture
:: package libxml2-2.9.10-2.1-i686 does not have a valid architecture
:: package libxmu-1.1.3-2.0-i686 does not have a valid architecture
:: package libxnvctrl-440.82-1.0-i686 does not have a valid architecture
:: package libxpm-3.5.13-2.0-i686 does not have a valid architecture
:: package libxpresent-1.0.0-2.0-i686 does not have a valid architecture
:: package libxrandr-1.5.2-3.0-i686 does not have a valid architecture
:: package libxrender-0.9.10-4.0-i686 does not have a valid architecture
:: package libxres-1.2.0-2.0-i686 does not have a valid architecture
:: package libxshmfence-1.3-2.0-i686 does not have a valid architecture
:: package libxslt-1.1.34-3.0-i686 does not have a valid architecture
:: package libxss-1.2.3-3.0-i686 does not have a valid architecture
:: package libxt-1.2.0-2.0-i686 does not have a valid architecture
:: package libxtst-1.2.3-4.0-i686 does not have a valid architecture
:: package libxv-1.0.11-4.0-i686 does not have a valid architecture
:: package libxvmc-1.0.12-2.2-i686 does not have a valid architecture
:: package libxxf86vm-1.1.4-4.0-i686 does not have a valid architecture
:: package libyaml-0.2.5-1.0-i686 does not have a valid architecture
:: package libzip-1.6.1-1.0-i686 does not have a valid architecture
:: package libzmf-0.0.2-8.0-i686 does not have a valid architecture
:: package lilv-0.24.8-1.0-i686 does not have a valid architecture
:: package lirc-1:0.10.1-6.0-i686 does not have a valid architecture
:: package llvm-libs-10.0.0-1.0-i686 does not have a valid architecture
:: package lm_sensors-3.6.0-2.0-i686 does not have a valid architecture
:: package lmdb-0.9.25-1.0-i686 does not have a valid architecture
:: package lpsolve-5.5.2.5-4.0-i686 does not have a valid architecture
:: package lsdvd-0.17-4.0-i686 does not have a valid architecture
:: package lua-5.3.5-3.0-i686 does not have a valid architecture
:: package lua52-5.2.4-5.0-i686 does not have a valid architecture
:: package luajit-2.0.5-3.0-i686 does not have a valid architecture
:: package lv2-1.18.0-1.0-i686 does not have a valid architecture
:: package lxappearance-0.6.3-2.4-i686 does not have a valid architecture
:: package lxappearance-obconf-0.2.3-2.6-i686 does not have a valid architecture
:: package lxdm-0.5.3-7.0-i686 does not have a valid architecture
:: package lxhotkey-0.1.0-2.5-i686 does not have a valid architecture
:: package lxinput-0.3.5-2.4-i686 does not have a valid architecture
:: package lxlauncher-0.2.5-4.0-i686 does not have a valid architecture
:: package lxpanel-0.10.0-1.2-i686 does not have a valid architecture
:: package lxrandr-0.3.2-1.4-i686 does not have a valid architecture
:: package lxsession-1:0.5.5-1.0-i686 does not have a valid architecture
:: package lxtask-0.1.9-1.4-i686 does not have a valid architecture
:: package marco-1.24.0-1.0-i686 does not have a valid architecture
:: package mate-desktop-1.24.0-1.0-i686 does not have a valid architecture
:: package mbedtls-2.16.5-1.0-i686 does not have a valid architecture
:: package md4c-0.4.4-1.0-i686 does not have a valid architecture
:: package memtester-4.3.0-4.4-i686 does not have a valid architecture
:: package mencoder-38157-2.0-i686 does not have a valid architecture
:: package menu-cache-1.1.0-2.0-i686 does not have a valid architecture
:: package mesa-20.0.7-3.0-i686 does not have a valid architecture
:: package mesa-demos-8.4.0-4.0-i686 does not have a valid architecture
:: package metacity-3.36.1-1.0-i686 does not have a valid architecture
:: package metis-5.1.0.p8-1.0-i686 does not have a valid architecture
:: package miniupnpc-2.1.20190408-1.0-i686 does not have a valid architecture
:: package mjpegtools-2.1.0-5.0-i686 does not have a valid architecture
:: package mkvtoolnix-cli-46.0.0-1.0-i686 does not have a valid architecture
:: package mkvtoolnix-gui-46.0.0-1.0-i686 does not have a valid architecture
:: package mpg123-1.25.13-2.0-i686 does not have a valid architecture
:: package mplayer-38157-2.0-i686 does not have a valid architecture
:: package mpv-1:0.32.0-3.0-i686 does not have a valid architecture
:: package mtdev-1.1.6-1.1-i686 does not have a valid architecture
:: package mujs-1.0.7-1.0-i686 does not have a valid architecture
:: package ndctl-68-2.0-i686 does not have a valid architecture
:: package neon-0.31.1-1.0-i686 does not have a valid architecture
:: package net-snmp-5.8-5.0-i686 does not have a valid architecture
:: package ninja-1.10.0-1.1-i686 does not have a valid architecture
:: package nmap-7.80-2.0-i686 does not have a valid architecture
:: package nomacs-3.14.2-2.0-i686 does not have a valid architecture
:: package ntfs-3g-2017.3.23-4.0-i686 does not have a valid architecture
:: package ntp-4.2.8.p14-1.0-i686 does not have a valid architecture
:: package obconf-2.0.4-6.5-i686 does not have a valid architecture
:: package ocl-icd-2.2.12-4.0-i686 does not have a valid architecture
:: package openal-1.20.1-2.0-i686 does not have a valid architecture
:: package openbox-3.6.1-7.0-i686 does not have a valid architecture
:: package opencore-amr-0.1.5-4.0-i686 does not have a valid architecture
:: package opencv-4.3.0-5.0-i686 does not have a valid architecture
:: package openexr-2.4.1-2.0-i686 does not have a valid architecture
:: package openjpeg2-2.3.1-2.0-i686 does not have a valid architecture
:: package openmpi-4.0.3-1.0-i686 does not have a valid architecture
:: package opus-1.3.1-1.3-i686 does not have a valid architecture
:: package opusfile-0.11-2.0-i686 does not have a valid architecture
:: package orc-0.4.31-2.0-i686 does not have a valid architecture
:: package os-prober-1.77-1.0-i686 does not have a valid architecture
:: package p7zip-16.02-6.0-i686 does not have a valid architecture
:: package pango-1:1.44.7+11+g73b46b04-1.0-i686 does not have a valid architecture
:: package pango-perl-1.227-11.3-i686 does not have a valid architecture
:: package pangomm-2.42.1-2.0-i686 does not have a valid architecture
:: package pangox-compat-0.0.2+2+gedb9e09-3.1-i686 does not have a valid architecture
:: package parcellite-1.2.1-3.1-i686 does not have a valid architecture
:: package parted-3.3-1.0-i686 does not have a valid architecture
:: package pavucontrol-1:4.0-1.5-i686 does not have a valid architecture
:: package pcmanfm-1.3.1-2.0-i686 does not have a valid architecture
:: package pepper-flash-32.0.0.363-1.0-i686 does not have a valid architecture
:: package perl-clone-0.45-1.0-i686 does not have a valid architecture
:: package perl-dbi-1.643-1.0-i686 does not have a valid architecture
:: package perl-html-parser-3.72-8.0-i686 does not have a valid architecture
:: package perl-xml-libxml-2.0205-1.0-i686 does not have a valid architecture
:: package perl-xml-parser-2.46-1.0-i686 does not have a valid architecture
:: package phonon-qt5-4.11.1-2.0-i686 does not have a valid architecture
:: package phonon-qt5-gstreamer-4.10.0-2.0-i686 does not have a valid architecture
:: package pipewire-0.3.4-1.0-i686 does not have a valid architecture
:: package pixman-0.40.0-1.0-i686 does not have a valid architecture
:: package pkgfile-21-1.0-i686 does not have a valid architecture
:: package polkit-0.116-5.1-i686 does not have a valid architecture
:: package polkit-qt5-0.113.0-2.0-i686 does not have a valid architecture
:: package poppler-0.88.0-1.0-i686 does not have a valid architecture
:: package poppler-glib-0.88.0-1.0-i686 does not have a valid architecture
:: package poppler-qt5-0.88.0-1.0-i686 does not have a valid architecture
:: package portaudio-1:19.6.0-6.1-i686 does not have a valid architecture
:: package portsmf-234-2.0-i686 does not have a valid architecture
:: package protobuf-3.11.4-1.1-i686 does not have a valid architecture
:: package pulseaudio-13.0-3.1-i686 does not have a valid architecture
:: package pyalpm-0.9.1-2.2-i686 does not have a valid architecture
:: package pygobject-devel-3.36.1-1.0-i686 does not have a valid architecture
:: package pygtk-2.24.0-8.5-i686 does not have a valid architecture
:: package python-3.8.3-1.0-i686 does not have a valid architecture
:: package python-cairo-1.19.1-1.1-i686 does not have a valid architecture
:: package python-dbus-1.2.16-1.0-i686 does not have a valid architecture
:: package python-dbus-common-1.2.16-1.0-i686 does not have a valid architecture
:: package python-dulwich-0.20.2-1.0-i686 does not have a valid architecture
:: package python-gobject-3.36.1-1.0-i686 does not have a valid architecture
:: package python-lhafile-0.2.2-3.1-i686 does not have a valid architecture
:: package python-lxml-4.5.1-1.0-i686 does not have a valid architecture
:: package python-pycups-2.0.1-1.0-i686 does not have a valid architecture
:: package python-pycurl-7.43.0.5-1.1-i686 does not have a valid architecture
:: package python-regex-2020.5.14-1.0-i686 does not have a valid architecture
:: package python2-2.7.18-1.0-i686 does not have a valid architecture
:: package python2-cairo-1.18.2-4.2-i686 does not have a valid architecture
:: package python2-gobject2-2.28.7-5.0-i686 does not have a valid architecture
:: package python2-numpy-1.16.6-1.0-i686 does not have a valid architecture
:: package qpdf-10.0.1-1.0-i686 does not have a valid architecture
:: package qt5-base-5.15.0-2.0-i686 does not have a valid architecture
:: package qt5-charts-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-declarative-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-imageformats-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-location-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-multimedia-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-script-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-sensors-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-speech-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-svg-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-tools-5.14.2-2.1-i686 does not have a valid architecture
:: package qt5-webchannel-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-webengine-5.15.0-1.1-i686 does not have a valid architecture
:: package qt5-webkit-5.212.0alpha4-6.0-i686 does not have a valid architecture
:: package qt5-x11extras-5.15.0-1.0-i686 does not have a valid architecture
:: package qt5-xmlpatterns-5.15.0-1.0-i686 does not have a valid architecture
:: package quazip-0.9.1-1.0-i686 does not have a valid architecture
:: package raptor-2.0.15-13.0-i686 does not have a valid architecture
:: package rasqal-1:0.9.33-3.0-i686 does not have a valid architecture
:: package re2-1:20200601-1.0-i686 does not have a valid architecture
:: package recode-3.7.6-2.0-i686 does not have a valid architecture
:: package redland-1:1.0.17-7.4-i686 does not have a valid architecture
:: package rest-0.8.1-3.0-i686 does not have a valid architecture
:: package retroarch-1.8.5-1.0-i686 does not have a valid architecture
:: package rhash-1.3.9-1.0-i686 does not have a valid architecture
:: package rsync-3.1.3-3.0-i686 does not have a valid architecture
:: package rtkit-0.13-1.0-i686 does not have a valid architecture
:: package rtmpdump-1:2.4.r96.fa8646d-5.3-i686 does not have a valid architecture
:: package rubberband-1.8.2-3.3-i686 does not have a valid architecture
:: package sane-1.0.30-1.0-i686 does not have a valid architecture
:: package sbc-1.4-1.3-i686 does not have a valid architecture
:: package scantailor-0.9.12.2-4.5-i686 does not have a valid architecture
:: package scummvm-2.1.2-1.0-i686 does not have a valid architecture
:: package sdl-1.2.15-14.0-i686 does not have a valid architecture
:: package sdl2-2.0.12-1.0-i686 does not have a valid architecture
:: package sdl2_net-1:2.0.1-3.0-i686 does not have a valid architecture
:: package sdl_net-1.2.8-5.0-i686 does not have a valid architecture
:: package sdl_sound-1.0.3-7.0-i686 does not have a valid architecture
:: package serd-0.30.4-1.0-i686 does not have a valid architecture
:: package serf-1.3.9-3.0-i686 does not have a valid architecture
:: package shaderc-2020.0-1.0-i686 does not have a valid architecture
:: package shared-mime-info-2.0+1+g6bf9e4f-2.0-i686 does not have a valid architecture
:: package sigil-1.2.1-1.1-i686 does not have a valid architecture
:: package simplescreenrecorder-0.4.2-1.0-i686 does not have a valid architecture
:: package smartmontools-7.1-1.0-i686 does not have a valid architecture
:: package smbclient-4.11.3-3.0-i686 does not have a valid architecture
:: package smpeg-0.4.5-4.0-i686 does not have a valid architecture
:: package smplayer-20.4.2-1.0-i686 does not have a valid architecture
:: package smtube-20.1.0-1.1-i686 does not have a valid architecture
:: package snappy-1.1.8-1.0-i686 does not have a valid architecture
:: package solid-5.70.0-1.0-i686 does not have a valid architecture
:: package sonnet-5.70.0-1.0-i686 does not have a valid architecture
:: package sord-0.16.4-1.3-i686 does not have a valid architecture
:: package soundtouch-2.1.2-2.0-i686 does not have a valid architecture
:: package spandsp-0.0.6-3.0-i686 does not have a valid architecture
:: package speex-1.2.0-2.0-i686 does not have a valid architecture
:: package speexdsp-1.2.0-2.0-i686 does not have a valid architecture
:: package spirv-tools-2020.2-1.0-i686 does not have a valid architecture
:: package sratom-0.6.4-1.3-i686 does not have a valid architecture
:: package srt-1.4.1-1.0-i686 does not have a valid architecture
:: package startup-notification-0.12-6.0-i686 does not have a valid architecture
:: package subversion-1.14.0-1.0-i686 does not have a valid architecture
:: package suil-0.10.6-2.0-i686 does not have a valid architecture
:: package suitesparse-5.7.2-1.0-i686 does not have a valid architecture
:: package system-config-printer-1.5.12+33+g23b454ef-1.0-i686 does not have a valid architecture
:: package t1lib-5.1.2-7.0-i686 does not have a valid architecture
:: package taglib-1.11.1-4.0-i686 does not have a valid architecture
:: package talloc-2.3.1-1.0-i686 does not have a valid architecture
:: package tdb-1.4.3-2.0-i686 does not have a valid architecture
:: package telegram-desktop-2.1.7-1.0-i686 does not have a valid architecture
:: package tepl-4.4.0-1.0-i686 does not have a valid architecture
:: package tevent-1:0.10.2-1.0-i686 does not have a valid architecture
:: package tree-1.8.0-2.0-i686 does not have a valid architecture
:: package tslib-1.21-2.0-i686 does not have a valid architecture
:: package tvtime-1.0.11-3.2-i686 does not have a valid architecture
:: package twolame-0.4.0-2.3-i686 does not have a valid architecture
:: package uchardet-0.0.7-1.0-i686 does not have a valid architecture
:: package udisks2-2.9.0-1.0-i686 does not have a valid architecture
:: package unrar-1:5.9.3-2.0-i686 does not have a valid architecture
:: package unzip-6.0-14.0-i686 does not have a valid architecture
:: package upower-0.99.11-2.0-i686 does not have a valid architecture
:: package usbmuxd-1.1.0+69+g8a69f1a-1.1-i686 does not have a valid architecture
:: package v4l-utils-1.20.0-1.0-i686 does not have a valid architecture
:: package vamp-plugin-sdk-2.10.0-1.0-i686 does not have a valid architecture
:: package vice-3.4-2.1-i686 does not have a valid architecture
:: package vid.stab-1.1-2.4-i686 does not have a valid architecture
:: package vlc-3.0.10-1.0-i686 does not have a valid architecture
:: package volume_key-0.3.12-2.0-i686 does not have a valid architecture
:: package vte-common-0.60.3-1.0-i686 does not have a valid architecture
:: package vte3-0.60.3-1.0-i686 does not have a valid architecture
:: package vulkan-icd-loader-1.2.141-1.0-i686 does not have a valid architecture
:: package wavpack-5.3.0-1.0-i686 does not have a valid architecture
:: package wayland-1.18.0-2.3-i686 does not have a valid architecture
:: package webkit2gtk-2.28.2-2.0-i686 does not have a valid architecture
:: package webrtc-audio-processing-0.3.1-1.2-i686 does not have a valid architecture
:: package weston-8.0.0-2.0-i686 does not have a valid architecture
:: package wget-1.20.3-2.2-i686 does not have a valid architecture
:: package wildmidi-0.4.3-1.0-i686 does not have a valid architecture
:: package wine-5.9-1.0-i686 does not have a valid architecture
:: package winetricks-20200412-1.0-i686 does not have a valid architecture
:: package woff2-1.0.2-3.0-i686 does not have a valid architecture
:: package wpebackend-fdo-1.6.0-1.0-i686 does not have a valid architecture
:: package wxgtk-common-3.0.5.1-1.0-i686 does not have a valid architecture
:: package wxgtk2-3.0.5.1-1.0-i686 does not have a valid architecture
:: package wxgtk3-3.0.5.1-1.0-i686 does not have a valid architecture
:: package x264-3:0.159.r2999.296494a-1.0-i686 does not have a valid architecture
:: package x265-3.3-1.0-i686 does not have a valid architecture
:: package xcb-util-0.4.0-3.0-i686 does not have a valid architecture
:: package xcb-util-cursor-0.1.3-3.0-i686 does not have a valid architecture
:: package xcb-util-image-0.4.0-3.0-i686 does not have a valid architecture
:: package xcb-util-keysyms-0.4.0-3.0-i686 does not have a valid architecture
:: package xcb-util-renderutil-0.3.9-3.0-i686 does not have a valid architecture
:: package xcb-util-wm-0.4.1-3.0-i686 does not have a valid architecture
:: package xcb-util-xrm-1.3-2.0-i686 does not have a valid architecture
:: package xdg-dbus-proxy-0.1.2-2.0-i686 does not have a valid architecture
:: package xdotool-3.20160805.1-2.0-i686 does not have a valid architecture
:: package xf86-input-libinput-0.30.0-1.0-i686 does not have a valid architecture
:: package xf86-video-ati-1:19.1.0-1.1-i686 does not have a valid architecture
:: package xf86-video-fbdev-0.5.0-1.6-i686 does not have a valid architecture
:: package xf86-video-nouveau-1.0.16-1.3-i686 does not have a valid architecture
:: package xf86-video-vesa-2.4.0-3.0-i686 does not have a valid architecture
:: package xmlsec-1.2.30-2.0-i686 does not have a valid architecture
:: package xorg-bdftopcf-1.1-2.0-i686 does not have a valid architecture
:: package xorg-font-util-1.3.2-1.0-i686 does not have a valid architecture
:: package xorg-luit-1.1.1-3.2-i686 does not have a valid architecture
:: package xorg-mkfontscale-1.2.1-2.1-i686 does not have a valid architecture
:: package xorg-server-1.20.8-1.0-i686 does not have a valid architecture
:: package xorg-server-common-1.20.8-1.0-i686 does not have a valid architecture
:: package xorg-server-devel-1.20.8-1.0-i686 does not have a valid architecture
:: package xorg-setxkbmap-1.3.2-1.0-i686 does not have a valid architecture
:: package xorg-twm-1.0.10-2.0-i686 does not have a valid architecture
:: package xorg-xauth-1.1-1.0-i686 does not have a valid architecture
:: package xorg-xdriinfo-1.0.6-2.0-i686 does not have a valid architecture
:: package xorg-xinit-1.4.1-1.1-i686 does not have a valid architecture
:: package xorg-xkbcomp-1.4.3-1.0-i686 does not have a valid architecture
:: package xorg-xlsfonts-1.0.6-2.0-i686 does not have a valid architecture
:: package xorg-xmessage-1.0.5-2.0-i686 does not have a valid architecture
:: package xorg-xmodmap-1.0.10-1.0-i686 does not have a valid architecture
:: package xorg-xprop-1.2.4-1.0-i686 does not have a valid architecture
:: package xorg-xrandr-1.5.1-1.0-i686 does not have a valid architecture
:: package xorg-xrdb-1.2.0-1.0-i686 does not have a valid architecture
:: package xorg-xset-1.2.4-2.0-i686 does not have a valid architecture
:: package xsane-0.999-5.0-i686 does not have a valid architecture
:: package xsane-gimp-0.999-5.0-i686 does not have a valid architecture
:: package xterm-356-1.0-i686 does not have a valid architecture
:: package xvidcore-1.3.7-1.0-i686 does not have a valid architecture
:: package xxhash-0.7.3-1.0-i686 does not have a valid architecture
:: package yajl-2.1.0-2.3-i686 does not have a valid architecture
:: package zbar-0.23.1-1.0-i686 does not have a valid architecture
:: package zenity-3.32.0+17+gfb0938f-2.0-i686 does not have a valid architecture
:: package zip-3.0-9.0-i686 does not have a valid architecture
:: package zsnes-1.51-20.5-i686 does not have a valid architecture
:: package zvbi-0.2.35-4.0-i686 does not have a valid architecture
$ cat /etc/pacman.conf
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   = chromium, pepper-flash
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
#SigLevel    = Required DatabaseOptional
SigLevel = Never
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required
#RemoteFileSigLevel = Never

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
#[catalyst-hd234k]
#Server = https://mirror.hactar.xyz/Vi0L0/catalyst-hd234k/$arch
#SigLevel = Never

Last edited by anabasis (2020-06-10 17:25:37)

Offline

#9 2020-06-10 23:02:40

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 618

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

Sorry, that command I posted was untested.  It works if you add a space and a hyphen to it to tell the second pacman invocation to input it's list of packages from STDIN.

I'm not sure why you're getting invalid architecture errors.  I'm also not sure why you felt the need to set your siglevel to never, but I don't think that should cause this problem.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#10 2020-06-11 05:41:41

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 488

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

Both commands should work, but you will need to pull a fresh database after the architecture change, too:

pacman -Sy

or all in one step:

pacman -Qqn | pacman -Sy -

Also mind, that you currently run a broken system, because you have i686 and pentium4 packages installed in parallel (which may work, but may also fail in ways we never tested).

regards,
deep42thought

Offline

#11 2020-06-11 11:19:11

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

deep42thought wrote:
pacman -Qqn | pacman -Sy -

it says same errors of "pacman -S $(pacman -Qqn)".
with arch "auto" on pacman.conf every package i try to install it says "invalid architecture", i also tried to set "Architecture = pentium4" but it doesn't solve:

$ sudo pacman -Sy firefox
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
warning: firefox-77.0.1-1.1 is up to date -- reinstalling
error: failed to prepare transaction (package architecture is not valid)
:: package firefox-77.0.1-1.1-i686 does not have a valid architecture

only with "Architecture = i686" pacman is able to install packages.

maybe i should follow this wiki (but it's for migration from 32bit to 64bit):
https://wiki.archlinux.org/index.php/Mi … hitectures


EDIT:
i solved running "pacman -Syy"

Last edited by anabasis (2020-06-11 11:33:27)

Offline

#12 2020-06-11 11:32:06

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 488

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

anabasis wrote:
deep42thought wrote:
pacman -Qqn | pacman -Sy -

it says same errors of "pacman -S $(pacman -Qqn)".
with arch "auto" on pacman.conf every package i try to install it says "invalid architecture", i also tried to set "Architecture = pentium4" but it doesn't solve:

$ sudo pacman -Sy firefox
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
warning: firefox-77.0.1-1.1 is up to date -- reinstalling
error: failed to prepare transaction (package architecture is not valid)
:: package firefox-77.0.1-1.1-i686 does not have a valid architecture

only with "Architecture = i686" pacman is able to install packages.

No idea, why the old instructions do not work (anymore), but I can confirm, that it currently fails this way. But it works if you force the database-update with an additional -y:

pacman -Syy $(pacman -Qqn)

or

pacman -Qqn | pacman -Syy -
anabasis wrote:

nah, that would be overkill - e.g. the old kernel is really compatible with the new binaries (which is different for switching between i686 and x86_64)

regards,
deep42thought

Offline

#13 2020-06-11 11:35:05

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

with "pacman -Syy" seems to work, now it's downloading new packages, see what happens...

Offline

#14 2020-06-11 12:28:06

anabasis
Member
Registered: 2020-06-09
Posts: 8

Re: [SOLVED] chromium74.i686 doesn't run + migration i686 to pentium4

installation finished. i have reboot and seems all right, thank you!

Last edited by anabasis (2020-06-11 12:28:50)

Offline

Board footer

Powered by FluxBB