You are not logged in.

#1 2020-06-26 06:25:01

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 143
Website

perl 5.32 update breaks a lot of packages

irssi: error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory
WARNING: '/usr/lib/perl5/5.30' contains data from at least 6 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
error: No package owns /usr/lib/perl5/site_perl
[root@machine]# pacman -Qqo '/usr/lib/perl5/5.30'
graphviz
imagemagick
irssi
libproxy
perl-clone
perl-html-parser

Offline

#2 2020-06-26 08:04:50

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 618

Re: perl 5.32 update breaks a lot of packages

Yes, I get the same on my 32-bit machines (imagemagick, libproxy and perl-html-parser only installed here at present, and of the others I only have perl-clone installed). My 64-bit machine only moaned about an old AUR project I needed to rebuild.

graphviz is ver -4 on 32-bit Arch but -5 on 64-bit machines. Maybe a simple rebuild will fix this.
imagemagic is a bit further behind on my 32-bit machine, being at version 7.0.10.19-1.0 here, and 7.0.10.21-1.0 on Arch 64.
irssi actually has a higher version number on Arch32; 1.2.2-3.2 but arch64 is on 1.2.2-3 so the only difference is the build number.
libproxy is ver -1 on Arch32 but -2 on Arch64.
perl-clone version in testing looks good from a site-perl aspect at least on my system, but the version in extra is apparently broken.  All dependendies map back to perl-libwww after a slightly bifuricated dependency graph.
perl-html-parser is -9 on Arch32 but -10 on Arch64.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2020-06-26 15:59:22

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 488

Re: perl 5.32 update breaks a lot of packages

I see a lot of packages still depending on perl 5.30 in the database: apparmor backuppc biber cairo-perl cddb_get collectd dnssec-tools frozen-bubble gdal glib-perl graphicsmagick gtk2-perl hamlib hivex imvirt innotop irssi liboping libproxy ls++ net-snmp openipmi pango-perl pcp pcsc-perl perl-acme-alien-dontpanic perl-algorithm-annotate perl-algorithm-diff perl-alien-base-modulebuild perl-alien-cmake3 perl-alien-sdl perl-anyevent-i3 perl-app-borgrestore perl-app-cli perl-archive-cpio perl-archive-extract perl-async-interrupt perl-authen-sasl perl-autovivification perl-b-hooks-endofscope perl-b-keywords perl-berkeleydb perl-bit-vector perl-cairo-gobject perl-canary-stability perl-cgi perl-cgi-fast perl-cgi-formbuilder perl-cgi-session perl-class-load-xs perl-class-method-modifiers perl-class-methodmaker perl-class-tiny perl-clone perl-color-calc perl-compress-bzip2 perl-config-grammar perl-convert-asn1 perl-convert-tnef perl-convert-uulib perl-cpan-meta-check perl-cpan-perl-releases perl-cpanplus perl-cpanplus-dist-arch perl-crypt-blowfish perl-crypt-des perl-crypt-openssl-bignum perl-crypt-openssl-dsa perl-crypt-openssl-random perl-crypt-openssl-rsa perl-crypt-simple perl-crypt-smbhash perl-crypt-ssleay perl-curses perl-curses-ui perl-cwd-guard perl-danga-socket perl-data-dump perl-data-hierarchy perl-data-messagepack perl-data-munge perl-data-optlist perl-data-perl perl-data-random perl-data-section perl-data-structure-util perl-data-uuid perl-data-validate-ip perl-date-simple perl-datetime perl-datetime-calendar-julian perl-datetime-cron-simple perl-datetime-event-ical perl-datetime-event-recurrence perl-datetime-format-ical perl-datetime-format-strptime perl-dbd-mysql perl-dbd-pg perl-dbd-sqlite perl-dbi perl-dbi-shell perl-devel-checkbin perl-devel-checkcompiler perl-devel-checklib perl-devel-globaldestruction perl-devel-patchperl perl-devel-stacktrace perl-digest-bubblebabble perl-digest-nilsimsa perl-digest-sha1 perl-dir-self perl-dist-checkconflicts perl-djabberd perl-djabberd-rosterstorage-sqlite perl-email-address-xs perl-email-sender perl-env-shellwords perl-ev perl-eval-closure perl-exception-class perl-extutils-config perl-extutils-cppguess perl-extutils-helpers perl-extutils-installpaths perl-fcgi perl-file-copy-recursive-reduced perl-file-find-rule-perl perl-file-homedir perl-file-next perl-file-path-expand perl-file-path-tiny perl-file-pushd perl-file-rsyncp perl-file-sharedir-install perl-file-sharedir-projectdistdir perl-file-slurp-tiny perl-file-tail perl-file-type perl-filesys-df perl-finance-quote perl-font-afm perl-function-parameters perl-fuse perl-gd perl-glib-object-introspection perl-gnupg-interface perl-graphics-colornames-www perl-graphviz perl-gssapi perl-gtk2-trayicon perl-guard perl-hook-lexwrap perl-html-element-extended perl-html-form perl-html-formatter perl-html-highlight perl-html-scrubber perl-html-strip perl-html-tableextract perl-html-tagfilter perl-html-template-expr perl-ical-parser perl-image-info perl-image-sane perl-import-into perl-importer perl-inline-c perl-inline-cpp perl-inline-filters perl-inline-java perl-io-all perl-io-bufferedselect perl-io-captureoutput perl-io-digest perl-io-dirent perl-io-multiplex perl-io-pager perl-io-tee perl-io-tty perl-ipc-shareable perl-json-parse perl-json-xs perl-lchown perl-ldap perl-lingua-en-inflect perl-linux-pid perl-list-allutils perl-list-someutils perl-list-utilsby perl-local-lib perl-locale-codes perl-locale-po perl-log-any perl-log-any-adapter-log4perl perl-log-any-adapter-tap perl-log-message perl-log-message-simple perl-mail-box-parser-c perl-mail-message perl-mail-sendmail perl-mail-spf-query perl-mail-transport-dbx perl-marisa perl-math-base85 perl-math-random-isaac perl-mime-base32 perl-mime-tools perl-module-build-tiny perl-module-build-xsutil perl-module-find perl-module-implementation perl-module-install perl-module-pluggable perl-module-scandeps perl-moo perl-moox-handlesvia perl-moox-late perl-moox-types-mooselike perl-mouse perl-mro-compat perl-namespace-autoclean perl-namespace-clean perl-net-dropbox-api perl-net-idn-encode perl-net-ip-minimal perl-net-ipv4addr perl-net-ipv6addr perl-net-jabber perl-net-ldap-server perl-net-oauth perl-net-openssh perl-net-snmp perl-net-ssleay perl-net-telnet perl-net-xmpp perl-netaddr-ip perl-number-bytes-human perl-number-misc perl-object-accessor perl-object-event perl-object-multitype perl-object-realize-later perl-package-constants perl-package-deprecationmanager perl-package-stash perl-par-dist perl-parallel-forkmanager perl-params-validationcompiler perl-parse-yapp perl-path-class perl-path-finddev perl-path-isdev perl-path-tiny perl-pegex perl-perl-critic perl-perl-minimumversion perl-perlio-utf8-strict perl-pkgconfig perl-pod-spell perl-poe-component-client-dns perl-poe-component-client-http perl-poe-component-client-keepalive perl-poe-component-ikc perl-poe-component-resolver perl-ppi perl-ppix-quotelike perl-ppix-regexp perl-ppix-utilities perl-probe-perl perl-proc-simple perl-regexp-common perl-regexp-shellish perl-rename perl-return-multilevel perl-role-tiny perl-scope-guard perl-sdl perl-sgmls perl-shell-config-generate perl-shell-guess perl-soap-lite perl-socket6 perl-software-license perl-sort-key perl-sort-naturally perl-sort-versions perl-statistics-descriptive perl-strictures perl-string-crc32 perl-string-format perl-string-util perl-sub-exporter perl-sub-exporter-progressive perl-sub-identify perl-sub-info perl-sub-install perl-sub-name perl-sub-override perl-sub-quote perl-super perl-switch perl-sys-syscall perl-sys-virt perl-task-weaken perl-template-toolkit perl-term-animation perl-term-extendedcolor perl-term-progressbar perl-term-read-password perl-term-readkey perl-term-readline-gnu perl-term-table perl-term-ui perl-test-differences perl-test-exception perl-test-exit perl-test-failwarnings perl-test-fatal perl-test-file perl-test-inter perl-test-minimumversion perl-test-mockmodule perl-test-mocktime perl-test-more-utf8 perl-test-needs perl-test-number-delta perl-test-object perl-test-output perl-test-requires perl-test-requiresinternet perl-test-script perl-test-simple perl-test-spec perl-test-subcalls perl-test-trap perl-test-utf8 perl-test-warnings perl-test-without-module perl-test-yaml perl-test2-suite perl-text-bibtex perl-text-charwidth perl-text-iconv perl-text-kakasi perl-text-markdown perl-text-soundex perl-text-template perl-text-vfile-asdata perl-throwable perl-tie-cphash perl-tie-hash-indexed perl-time-format perl-time-human perl-time-modules perl-tk perl-tk-tablematrix perl-type-tiny perl-types-serialiser perl-unicode-linebreak perl-unicode-stringprep perl-unix-syslog perl-user-identity perl-variable-magic perl-version-compare perl-www-curl perl-www-sms perl-x11-protocol perl-x11-protocol-other perl-xml-libxml perl-xml-libxml-prettyprint perl-xml-libxml-simple perl-xml-libxslt perl-xml-parser perl-xml-rss perl-xml-smart perl-xml-stream perl-xml-writer perl-xml-xpath perl-yaml-syck perl-yaml-tiny perlbrew perlio-via-dynamic pppusage razor rrdtool spamassassin subversion x2goserver xmms2

I think, I will reschedule them.

Offline

#4 2020-06-26 16:02:33

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 488

Re: perl 5.32 update breaks a lot of packages

On second thought: some of those might simply need a db-update to be superseeded by a newer version. hmmm ...

Offline

#5 2020-06-26 21:28:33

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 618

Re: perl 5.32 update breaks a lot of packages

Repository      : extra
Name            : subversion
Version         : 1.14.0-2.0
Depends On      : file  libutf8proc  serf  sqlite  systemd
Optional Deps   : libgnome-keyring: for GNOME Keyring for auth credentials
                  kwallet: for KWallet for auth credentials
                  bash-completion: for svn bash completion
                  python: for some hook scripts
                  java-environment: for Java support
                  ruby: for some hook scripts

Yeah, I can't quite see how that depends on any version of perl.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#6 2020-06-26 21:35:10

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 488

Re: perl 5.32 update breaks a lot of packages

The buildmaster's database has more dependencies than what you see with pacman. But still, some packages are linked against the wrong perl version.

Offline

#7 2020-06-26 22:04:31

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 618

Re: perl 5.32 update breaks a lot of packages

Ah, they're build dependencies rather than install dependencies I take it.  Fair enough, as I posted in the other thread, hivex is the only package I can find that defines it needs an old version of perl to run.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB