You are not logged in.

#1 2020-09-29 13:20:48

hayao
Member
From: Japanese
Registered: 2020-04-30
Posts: 6
Website

Conflict between libwbclient and smbclient

There are some file conflicts between libwbclient and smbclient. The Arch Linux official has already removed libwbclient.


/usr/include/samba-4.0/wbclient.h exists in both 'libwbclient' and 'smbclient'
/usr/lib/libwbclient.so exists in both 'libwbclient' and 'smbclient'
/usr/lib/libwbclient.so.0 exists in both 'libwbclient' and 'smbclient'
/airootfs/usr/lib/libwbclient.so.0.15 exists in both 'libwbclient' and 'smbclient'
/usr/lib/pkgconfig/wbclient.pc exists in both 'libwbclient' and 'smbclient'
/usr/lib/samba/libreplace-samba4.so exists in both 'libwbclient' and 'smbclient'
/usr/lib/samba/libwinbind-client-samba4.so exists in both 'libwbclient' and 'smbclient'
Errors occurred, no packages were upgraded.

Offline

#2 2020-09-29 14:06:03

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 690

Re: Conflict between libwbclient and smbclient

Okay, seems an easy enough fix.

Ideally this is the sort of thing best raised directly as a bug, but I can't really insist on that because I'm guilty of more or less the same.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2020-09-29 14:11:46

hayao
Member
From: Japanese
Registered: 2020-04-30
Posts: 6
Website

Re: Conflict between libwbclient and smbclient

When I saw it a few days ago, libwbclient was scheduled to be removed.But now that is not.
Is this an upstream (libwdclient) issue? Or is it an ArchLinux32 issue?

Offline

#4 2020-09-29 14:25:41

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 690

Re: Conflict between libwbclient and smbclient

I can't even find libwbclient on arch64 any more, I suspect it's been removed already.  I note that smbclient claims to provide libwbclient functionality however.  It's an arch32 issue if we still have the removed package, although you can always resolve it locally first by removing libwbclient and ensuring you have smbclient installed.  If you have smbclient it should have uninstalled libwbclient automatically when you upgraded it recently I assume, because even under arch32 it lists that it replaces libwbclient.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2020-09-29 14:39:35

hayao
Member
From: Japanese
Registered: 2020-04-30
Posts: 6
Website

Re: Conflict between libwbclient and smbclient

smbclient depends on cifs-utils and cifs-utils depends on libwbclient.
I am modifying Archiso to create my own customized ISO.
I'm trying to install the following packages with pacstrap.
This may be my problem, so I'll do some more research on my own.
However, it is true that there is a problem with the Arch Linux 32 libwbclient.


adapta-gtk-theme
adobe-source-code-pro-fonts
amd-ucode
arch-install-scripts
arj
b43-fwcutter
baobab
base-devel
bash
bash-completion
binutils
blueman
bluez
bluez-utils
broadcom-wl-dkms
btrfs-progs
bzip2
clonezilla
cpio
crda
cups
cups-pdf
darkhttpd
ddrescue
dhclient
dhcpcd
dmraid
dnsmasq
dnsutils
dosfstools
edk2-shell
efibootmgr
ethtool
exfat-utils
f2fs-tools
firefox
firewalld
fsarchiver
git
gnome-disk-utility
gnome-screenshot
gnu-netcat
gparted
gpm
gptfdisk
grub
grub-customizer
grub-theme-vimix
gvfs
gvfs-mtp
gvfs-smb
gzip
haveged
hdparm
htop
intel-ucode
ipad_charge
ipw2100-fw
ipw2200-fw
irssi
iwd
jfsutils
lha
libpwquality
lightdm
lightdm-settings
lightdm-slick-greeter
linux-atm
linux-firmware
linux-zen
linux-zen-headers
lrzip
lsd
lsd-control
lsscsi
lvm2
lxappearance
lxappearance-obconf
lxde-common
lxde-icon-theme
lxhotkey
lxinput
lxlauncher
lxpanel
lxrandr
lxsession
lxtask
lxterminal
lz4
lzip
lzop
man-db
man-db
man-pages
man-pages
mc
mdadm
medit
mkinitcpio-nfs-utils
mtools
mtpfs
nano
nbd
ndisc6
nerd-fonts-source-code-pro
networkmanager
network-manager-applet
nfs-utils
nilfs-utils
noto-fonts
noto-fonts-cjk
noto-fonts-emoji
ntfs-3g
nvme-cli
openbox
openconnect
openssh
openvpn
os-prober
p7zip
pamac-aur
papirus-icon-theme
partclone
parted
partimage
pavucontrol
pcmanfm
powerline-go
ppp
pptpclient
pulseaudio
pulseaudio-modules-bt
qt5ct
qt5-styleplugins
reflector
reiserfsprogs
rp-pppoe
rsync
sdparm
sg3_utils
smartmontools
sudo
system-config-printer
tar
tcpdump
testdisk
tlp
tlpui
ufw
unarj
unrar
unzip-iconv
usb_modeswitch
usbutils
viewnior
vim
vlc
vpnc
wget
wireless-regdb
wireless_tools
wpa_supplicant
wvdial
xarchiver
xdg-user-dirs
xf86-input-elographics
xf86-input-evdev
xf86-input-libinput
xf86-input-synaptics
xf86-input-vmmouse
xf86-input-void
xf86-input-wacom
xf86-video-amdgpu
xf86-video-ati
xf86-video-dummy
xf86-video-fbdev
xf86-video-intel
xf86-video-nouveau
xf86-video-openchrome
xf86-video-sisusb
xf86-video-vesa
xf86-video-vmware
xf86-video-voodoo
xfsprogs
xl2tpd
xorg-server
xorg-xinit
xz
yay
zip
zsh
zsh-autosuggestions
zsh-completions
zsh-history-substring-search
zsh-syntax-highlighting
zstd

Offline

#6 2020-09-29 14:44:19

hayao
Member
From: Japanese
Registered: 2020-04-30
Posts: 6
Website

Re: Conflict between libwbclient and smbclient

Add information. I removed gvfs-smb from the package list and it worked.

Offline

#7 2020-09-29 21:02:52

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 690

Re: Conflict between libwbclient and smbclient

Under arch64, as on arch32, cifs-utils depends on libwbclient, but that's provided by smbclient, so the final dependency should still be met even without the libwbclient package still being present.

Indeed, what I'd not noticed before that if I do a pacman -Qi for libwbclient it actually gives me info for smblcient, because that's the package that provides that functionality.  Turns out I don't actually have libwbclient installed, which is why I've not hit this issue myself yet, I assume.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#8 2020-09-30 10:57:38

hayao
Member
From: Japanese
Registered: 2020-04-30
Posts: 6
Website

Re: Conflict between libwbclient and smbclient

I solved it by specifying smbclient in the package list.
But does it make sense to leave the libwbclient package on ArchLinux32?

Offline

#9 2020-09-30 16:13:43

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 690

Re: Conflict between libwbclient and smbclient

Yes, I believe that leaving libwbclient on arch32 is an oversight, but I'm of the opinion that if you're using it and you upgrade it should offer to upgrade to smbclient at the very least. But if you're regularly rebuilding your system from package lists you'll need to be aware that libwbclient has been superceded these days.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB