You are not logged in.

#1 2020-12-11 13:22:53

cx
Member
Registered: 2019-08-17
Posts: 93

[SOLVED] Outdated sane prevents full system update (pentium4)

Since over a month I can't do full system updates anymore without ignoring package libjpeg-turbo, FYI:

$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libjpeg-turbo (2.0.6-1.1) breaks dependency 'libjpeg>=8' required by sane

I guess this is caused by changed deps for sane as seen at Arch64.

Regards

Last edited by cx (2020-12-12 23:15:34)

Offline

#2 2020-12-11 18:38:37

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED] Outdated sane prevents full system update (pentium4)

Yes, that patch would probably help.  It drops the dependency on libjpeg and adds one for jpeg-turbo instead.  I don't know what the arch64 process is for taking diffs like that and putting them in packages that are built, so I don't know if this is already patched in arch64.  I'll point out there's a build of 1.0.31 in testing whereas stable extra has 1.0.30, which might help you; perhaps that should be promoted to stable?


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2020-12-12 00:51:15

cx
Member
Registered: 2019-08-17
Posts: 93

Re: [SOLVED] Outdated sane prevents full system update (pentium4)

Well, I don't know what version numbers you're talking about, as libjpeg-turbo on Arch32 is v. 2.0.5-3.0, and on Arch64 v. 2.0.6-1. But at least that mentioned "patch" was the latest official update of the latter. – But if you mean the ((sane)) update for Arch32 is in progress, sure, go ahead. ^^

Last edited by cx (2020-12-12 10:51:56)

Offline

#4 2020-12-12 07:24:36

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED] Outdated sane prevents full system update (pentium4)

Now that I check, the sane in testing has a dependency on libjpeg-turbo which is probably what you want.  It's only the sane in extra that still depends on libjpeg>=8.  So it seems we're well on the way to fixing this, it just needs sane to be promoted from testing and this should be fixed for you, assuming that's the only problem you're having.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2020-12-12 10:48:58

cx
Member
Registered: 2019-08-17
Posts: 93

Re: [SOLVED] Outdated sane prevents full system update (pentium4)

D'oh!
Sorry, it was late, and fatigue and multitasking will never be good friends – of course it's the sane packages what makes me insane~

But yes, as far as I understand, libjpeg-turbo now (conflicts and) provides libjpeg; when I let pacman query for "libjpeg", it turns out "libjpeg-turbo". – So I am looking forward to your sane update to v. 1.0.31, linking against libjpeg-turbo.

Offline

#6 2020-12-12 20:45:14

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 601

Re: [SOLVED] Outdated sane prevents full system update (pentium4)

I'll move sane from testing to extra - please let me know, if this makes sane work for you

regards,
deep42thought

Offline

#7 2020-12-12 23:15:02

cx
Member
Registered: 2019-08-17
Posts: 93

Re: [SOLVED] Outdated sane prevents full system update (pentium4)

-- At least it made work my system becoming fully updated again. Thank you very much!

Offline

Board footer

Powered by FluxBB