You are not logged in.

#1 2021-01-06 16:10:02

rossboulet
Member
Registered: 2017-12-13
Posts: 42

Postfix broken by icu upgrade

I recently ran an upgrade on a remote system I had not updated since September 2020. After the upgrade, I notice mail from that system (pentium4 architecture) had ceased flowing. When I ran mailq, it complained about a missing library libicui18n.so.67.

From the pacman logs, I see icu was upgraded from v67 to v68. The postfix package lists a dependency for icu, but also dependencies for several libicu*.67 files.

A package search turned up a separate package called icu67 and installing it seems to have fixed the issue, but I'm not sure that is the correct solution.

Suggestions?

Offline

#2 2021-01-06 17:44:59

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 246
Website

Re: Postfix broken by icu upgrade

postfix should have been rebuilt against icu 58, in the meantime you can use the icu67 shim package to keep postfix
running.

Offline

Board footer

Powered by FluxBB