You are not logged in.

#1 2020-12-10 15:18:01

cx
Member
Registered: 2019-08-17
Posts: 84

xscreensaver troubles (pentium4)

Hi guys –

since a couple of days I'm not able to run xscreensaver anymore, e.g.:

$ xscreensaver-demo &

(xscreensaver-demo:1971): libglade-WARNING **: 15:00:45.627: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory

Everything is simply grayed out.

Tried this with xscreensaver and xscreensaver-arch-logo-nogdm; building xscreensaver-arch-logo is not possible, since there's no pkg "gdk-pixbuf-xlib" for pentium4 or an AUR-pkgbuild.

My system is up-to-date; updating almost daily.

If that is of importance, glx stuff seems to run normal.
Maybe it's just because the current version 5.44-1.1 vs. 5.44-3+ for arch64 or in the AUR?

Offline

#2 2020-12-10 21:08:34

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

Yes, it does break sometimes.  I recall I had to turn off screen locking for a while after an update a few months ago broke it and wouldn't let me back into my system once it had locked.

FWIW, on my system (which isn't gnome based) 'screensaver-demo' reports the same error, then opens the preferences.  But at the moment, screen blanking and locking is working for me, but I've not updated this system for a couple weeks now I think.  I'll try updating later today, after I've got my latest podcasts off my USB stick.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#3 2020-12-10 22:24:54

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

All right then, that's good to know. Thanks, and take your time!

Offline

#4 2020-12-11 08:04:29

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

Seems to still be working for me.  Tested at least using 'xscreensaver-command -activate'.

I apparently was confused by the name. From reading the docs I learned that xscreensaver-demo is meant to open the preferences.  Most of the window is greyed out for me as well (apart from the timings in the bottom left), but that's because my choice of screensaver is 'blank screen only'.  If I use the drop down and change that to either 'only one screensaver' or 'random screensaver' then the rest of the window unlocks.

You can't really compare the bit after the - in version numbers.  Yes, arch64 contains xscreensaver 5.44-3 while we're on 5.44-1.1 but all that means is that it took them three attempts to get it just right, while for us it took just two wink


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#5 2020-12-11 13:16:14

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

-- Does not for me though.

Though I still have got "random screensaver" selected and each preview works in demo mode, when activating the screen just goes black.

Offline

#6 2020-12-11 20:28:30

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

What do you mean specifically by 'activating the screen'.  I just tried choosing gleidoscope as my only screen saver and hitting 'preview' in the settings app or issuing a 'xscreensaver-command -activate' from a terminal displayed it for me.  I also tried choosing 'random screen saver' and issusing 'xscreensaver-command -activate' and that displayed a different animation to show me.

Check your display power management settings on the advanced tab in the demo settings app.  If those are the same timings as your screensaver timeout, and your method of activating the screensaver is to wait until it shows up then it might be that the power to the screen is turned off at the same time.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#7 2020-12-12 00:35:16

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

levi wrote:

What do you mean specifically by 'activating the screen'

Sorry, typo, missing a comma! I meant:

When activating, the screen just goes black.

... or say "blank". – All my settings are fine and haven't changed for years. It's just: all demos and previews work, but screensaver activation does not!

Offline

#8 2020-12-12 07:33:47

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

I'm curious still if it's DPMS racing to blank your screen at the same time.  As I say, check the power management settings on the advanced tab inside the preferences, that has the timings for all of the DPMS modes.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#9 2020-12-12 11:10:40

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

No, I also mean manual activation:

$ xscreensaver-command --activate

And the power management items are all unchecked; so it's not DMPS.

Again, my xscreensaver settings haven't changed for years, and I always run random screensavers. But every time spawning "xscreensaver-comand --demo" now, these are disabled; it always defaults to "Blank screen only". Though I can change that once to "random", all previews work fine, but they don't run when activating xscreensaver.

Everything worked fine until a couple of days, when the above warning appeared. And if it was an error, the xscreensaver demo could not be even be started, I guess.

Last edited by cx (2020-12-12 11:28:18)

Offline

#10 2020-12-12 11:43:19

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

Regard that warning:

$ xscreensaver-demo &

(xscreensaver-demo:1971): libglade-WARNING **: 15:00:45.627: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory

I just found out, locating "gnome.so" on Arch32 returns e.g.

...
/usr/lib/libopenrawgnome.so.7
...

while on Arch64, it's

...
/usr/lib/libopenrawgnome.so.8
...

Maybe that's why ...

Offline

#11 2020-12-12 17:23:05

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

As I say, my system hasn't ever seen hide nor hair of gnome since gnome2 stopped being a thing.  The only *gnome* things in my /usr/lib folder are from libgnome-keyring, libsoup, libcanberra and at-spi2-atk.

I wonder now what's in your ~/.xscreensaver file?  Near the top are the user settings that correspond to things in that preferences panel.  Maybe it's been set non-user-write also which could give the preferences panel problems in updating it, and it remains set to 'blank only'?


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#12 2020-12-12 23:08:26

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

levi wrote:

As I say, my system hasn't ever seen hide nor hair of gnome since gnome2 stopped being a thing.  The only *gnome* things in my /usr/lib folder are from libgnome-keyring, libsoup, libcanberra and at-spi2-atk.

Leaving aside all of your gtk+ and gdk stuff etc... ;-)

Nobody is talking about using Gnome; I never had. – But as I said, xscreensaver depends on glade, which uses rather a library of it, namely libgnome.so which itself is provided by libopenrawgnome.so, right?


levi wrote:

I wonder now what's in your ~/.xscreensaver file?  Near the top are the user settings that correspond to things in that preferences panel.  Maybe it's been set non-user-write also which could give the preferences panel problems in updating it, and it remains set to 'blank only'?

No. My ~/.xscreensaver is fine as ever, with "mode" still set to "random".

Offline

#13 2020-12-12 23:14:40

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

No, xscreensaver depends on libglade, which has rather a smaller set of dependencies.  I don't have glade installed on my system currently.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#14 2020-12-12 23:17:29

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

Sure, I meant "libglade", too, see my initial post.

Offline

#15 2020-12-12 23:23:06

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

Well, in any case, my system reported that error, but it doesn't stop the tool and the screensaver working.  I suspect it's a red herring and there's something else stopping your settings persisting.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#16 2020-12-12 23:57:55

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

cx wrote:

... on Arch32 ....

...
/usr/lib/libopenrawgnome.so.7
...

while on Arch64, it's

...
/usr/lib/libopenrawgnome.so.8
...

I am still suspecting this one, as libglade is the same version 2.6.4-7(.0) in Arch32 and 64.

And IMO if your "error" is really an error and not a warning like for me, your xscreensaver also won't even start either; so you might rather call yourself lucky it still does.


Or, it's something else unhealthy in the latest updates, getting miraculously cured by an upcoming one. Wouldn't be the first time, so in that case it's just a question of patience...

So anyway thanks guys for your awesome work providing Arch32!

Last edited by cx (2020-12-14 09:47:44)

Offline

#17 2020-12-13 00:04:44

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

True, I am using the testing repos.  Reportedly deep42thought is currently transitioning all testing packages to stable and all staging packages to testing, because apparently there was a bit of a backlog.  So it might happen sooner than you expected (and things might break for me, but that's why I test things).


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#18 2020-12-14 09:50:54

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

Glad you do! ^^

Yeah, and not to forget: More or less it's just a screensaver.

Offline

#19 2020-12-14 18:21:03

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

Yeah, but it's also the only way my computer locks when I walk away without remebering to lock it.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#20 2020-12-15 10:39:08

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

OT: Regarding patience – here's another one: Since yesterday my polybar is out of order, because since the last major update a couple of days ago, jsoncpp is to new for it. Hence I can't rebuild polybar from AUR anymore, because python v3.9.1 is necessary for this (very likely required by that mentioned "xcbgen" thingy, due to the build error) – which itself is currently still in testing even for Arch64!

But I don't mind and apply a plaster on that bleeding edge for now – as I know it's going to work again sooner or later. ^^

Besides, I realized I posted this topic in a wrong sub-forum; though there's nothing like Apps & DEs as in Arch64, it would fit better into System Administration, I guess.

Offline

#21 2020-12-15 17:15:09

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 812

Re: xscreensaver troubles (pentium4)

Meh, the post categories don't matter to me, since I monitor the forum via the new posts.  I had a plan once upon a time to rejig the categories, but it proved non straightfoward when I looked at it, and so I parked if and forgot about it.

Polybar has broken for me for months now.  I guess it breaks every time I do a system upgrade more or less, and I've not spent the time to fix it.  It's on a box that most of the time I'm using headless over ssh and tmux anyway, so it's only worth it for the few times a week I actually start that box and run x on it.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#22 2021-01-07 14:05:36

cx
Member
Registered: 2019-08-17
Posts: 84

Re: xscreensaver troubles (pentium4)

For the record: Installation of the recent icu67 package does not resolve my xscreensaver issue.

Also note, this has nothing to do with my/any ~/.xscreensaver config. – Xscreensaver still refuses to work properly even if there is no such file, which then gets newly created by the program.

I might select "random screensavers" and configure other things, which would be saved again. Yet all is ignored and despite ~/.xscreensaver, it's set to blank screen only. And though the previews work, I can't even run a single selected screensaver; no idea why and where it's stuck...

Offline

#23 2021-01-15 07:06:10

mistersmee
Member
From: India
Registered: 2020-12-24
Posts: 20

Re: xscreensaver troubles (pentium4)

cx wrote:

OT: Regarding patience – here's another one: Since yesterday my polybar is out of order, because since the last major update a couple of days ago, jsoncpp is to new for it. Hence I can't rebuild polybar from AUR anymore, because python v3.9.1 is necessary for this (very likely required by that mentioned "xcbgen" thingy, due to the build error) – which itself is currently still in testing even for Arch64!

But I don't mind and apply a plaster on that bleeding edge for now – as I know it's going to work again sooner or later. ^^

Besides, I realized I posted this topic in a wrong sub-forum; though there's nothing like Apps & DEs as in Arch64, it would fit better into System Administration, I guess.

If you really need polybar, you could grab the PKGBUILD for xcb-proto and build it yourself. That is the only thing that is failing while compiling polybar for you, I think. It starts to compile and when checking for dependencies it can't find xcbgen libraries, right? Since you are on python-3.9, doing this will rebuild xcb-proto against python3.9 rather than 3.8, thus providing the xcbgen libraries that polybar says are missing while compiling. IIRC, jsoncpp does not pose a problem. And python v3.9.1 is not the problem here, that has nothing to do with it. It doesn't matter what the point release is, the libraries are still under /usr/lib/python3.9/site-packages regardless of whether it is 3.9.1 or 3.9.0. The problem is that some packages are still under python3.8 and not under 3.9. Doing this solved the very same issue for me a month ago, but since then, I've moved on from polybar.

Offline

Board footer

Powered by FluxBB