You are not logged in.

#1 2021-01-17 21:26:44

iran
Member
Registered: 2021-01-17
Posts: 4

[SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

pentium4
pacman -S weston
Requires libx11-1.7.0-2.1 package
This package is not in the repository
There is a package libx11-1.7.0-3.0
Which doesn't fit

Last edited by levi (2021-01-19 23:30:22)

Offline

#2 2021-01-17 22:36:09

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

Hmm, as I read it weston doesn't depend on any specific version of libx11.

Now I check, I have weston installed and libx11=1.7.0-3.0 (from testing).  It works for me when I just started it.  extra still has the libx11-1.7.0-2.1 if you really need it.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2021-01-18 18:58:16

iran
Member
Registered: 2021-01-17
Posts: 4

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

Thanks for your quick answer.
I really appreciate your work.
I didn't find libx11-1.7.0-2.1 in extra.
Searched here -
https://mirror.archlinux32.org/pentium4/extra/

Packages requested by Weston:
  alsa-lib-1.2.4-3.0  alsa-topology-conf-1.2.4-2.0  alsa-ucm-conf-1.2.4-2.0  cairo-1.17.4-3.2  colord-1.4.5-1.0
  dconf-0.38.0-1.0  fribidi-1.0.10-1.0  giflib-5.2.1-2.0  js78-78.3.1-1.0  lcms2-2.11-2.0  libdatrie-0.2.12-2.0
  libdrm-2.4.103-2.0  libevdev-1.10.0-2.0  libglvnd-1.3.2-1.0  libgudev-233-2.0  libgusb-0.3.5-1.0
  libinput-1.16.4-1.0  libomxil-bellagio-0.9.3-3.0  libpciaccess-0.16-2.0  libpipewire02-0.2.7-1.0
  libthai-0.1.28-2.0  libtiff-4.1.0-2.0  libunwind-1.3.1-2.0  libva-2.9.1-1.0  libwacom-1.6-1.0  libwebp-1.1.0-1.1
  libx11-1.7.0-2.1  libxau-1.0.9-3.0  libxcb-1.14-1.0  libxcursor-1.2.0-2.0  libxdamage-1.1.5-3.0
  libxdmcp-1.1.3-3.0  libxext-1.3.4-3.0  libxfixes-5.0.3-4.0  libxft-2.3.3-2.0  libxkbcommon-0.10.0-1.6
  libxrender-0.9.10-4.0  libxshmfence-1.3-2.0  libxxf86vm-1.1.4-4.0  llvm-libs-11.0.0-3.0
  lm_sensors-3.6.0-2.0  mesa-20.2.1-1.1  mtdev-1.1.6-1.1  pango-1:1.48.0-1.0  pixman-0.40.0-1.0
  polkit-0.118-1.0  shared-mime-info-2.0+57+gc1d1c70-1.0  vulkan-icd-loader-1.2.162-1.0  xcb-proto-1.14.1-3.1
  xkeyboard-config-2.31-1.0  xorgproto-2020.1-1.0  weston-9.0.0-1.0

Offline

#4 2021-01-18 22:22:22

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

Yes, looks like libx11 1.7.0-3.0 has been promoted to extra overnight, so 1.7.0-2.1 is no longer available from the repos.

As I read the report from pacman -Qi weston, it depends on:

glibc  wayland  libxkbcommon  libinput  libunwind  pixman libdrm  pam  systemd-libs  cairo  libpng  libjpeg-turbo libwebp  mesa  libegl  libgles  glib2  pango  lcms2  mtdev libx11  libxcb  dbus  libva  libxcursor  colord  libpipewire02

i.e, in other words at install time there should be no version checks.  I haven't cascaded all of those dependencies to be sure they don't depend on some version that isn't available.

Sorry, I still don't seem to be able to understand exactly what your problem is.  What command are you running that's failing?  Perhaps you're doing a 'pacman -S weston' but your repo indices are out of date so you need to actually do a 'pacman -Sy weston'.

Edit: Yes, as per the OP you are doing a 'pacman -S weston'.  Only problem is as I read it the old version of libx11 was in extra yesterday, but it certainly isn't available any more.  Perhaps the server I checked yesterday was slightly behind the server you were using.  That's always possible I guess.

So yes, you need to do add a 'y' to your pacman options.  Your indices are out of date, so this kind of thing happens.

Last edited by levi (2021-01-18 22:27:04)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2021-01-19 08:16:51

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 601

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

You need to run

pacman -Syu

before doing any

pacman -S ...

(you can do this in one command, though:

pacman -Syu weston

)

Offline

#6 2021-01-19 20:19:42

iran
Member
Registered: 2021-01-17
Posts: 4

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

For: levi
Pacman -Syyy !!!
weston, it depends on: ... mesa
masa, it depends on: ...libglvnd
libglvnd, it depends on: ...libx11-1.7.0-2.1


For: deep42thought

My old laptop has no internet connection. I copy the packages to a USB stick and then transfer them to my laptop.

pacman -Syu
When upgrading, the system asks for libnewt-0.52.21-5.0-pentium4.pkg.tar.zst
There is no such package in the repository.

The repository contains libnewt-0.52.21-5.1-pentium4.pkg.tar.zst
The system with this package is not updated.

There are more than a dozen such packages.

Offline

#7 2021-01-19 20:28:49

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 601

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

The problem is, that the package database is outdated, when you download the packages. The time between "download the database" and "download the required packages" is usually pretty short, but in your case (due to the ethernet-over-usb-stick latency), some packages as noted in the database got updated in the meantime and do not exist on the mirror anymore.

Either you need to be faster with the usb stick, run some sort of local mirror (which you do not sync during your "install routine") or download the packages with some heuristic (e.g. download the latest available version of each to-be-downloaded package plus a recent version of the databases and feed this into pacman on the offline computer).

P.S.: This is actually a pretty interesting general problem: How to transfer data, if the latency is really big (I was thinking about rsync over *huge* latency network some time ago - think of carrying the to-be-transferred data on an external usb drive from one town to another).

Offline

#8 2021-01-19 20:34:09

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

libnewt is in the community repository, according to my pacman, although it reportedly is at version 1.3.2-1.1

If you're not connected to the internet, you need to transfer all the files in /var/lib/pacman/sync, to do the equlvalent of a pacman -Sy.  I think those files can be downloaded from a mirror, if you don't have another archlinux32 machine to hand, but I've not looked into that yet.

Edit: Yeah, if these machines are on different sites there'll likely always be problems due to latency.  It seems to me that if the target machine is not connected to the internet, you only need to update so that you can fulfil dependencies then leave the machine forevermore.  Updates aren't so important unless you want to connect something new to a USB port, since you don't need to be concerned with network opposition.

Last edited by levi (2021-01-19 20:39:41)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#9 2021-01-19 21:41:21

iran
Member
Registered: 2021-01-17
Posts: 4

Re: [SOLVED]pentium4 error installing "weston" no package libx11-1.7.0-2.1

Dear deep42thought and levi.
Thank you for your heartless hearts.
The problem has been resolved.

mirrorlist > server = file: /// db / $ repo / os / $ arch
pacman -Syu
If the update doesn't want to install package libnewt-0.52.21-5.0.
pacman -U libnewt-0.52.21-5.0
pacman -Syu
Made!

pacman -U libx11-1.7.0-2.1
pacman -S weston
Made!

Offline

Board footer

Powered by FluxBB