You are not logged in.

#1 2020-11-28 15:27:48

phunsoft
Member
From: Mettmenstetten / Switzerland
Registered: 2020-11-27
Posts: 4

[SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

Fresh install of Archlinux32 on my elder T43p. I cannot get the desired console keyboard to be loaded at boot time. I found these threads:

[Solved] Trouble setting the propper keymap layout
Several Issues along the install process

The latter suggests to add keymap to the HOOKs in /etc/mkinitcpio.conf. So my mkinitcpio.conf file now has the follwing HOOKs line:

HOOKS=(base dev autodetect modconf block filesystems keyboard fsck keymap)

However, this doesn‘t work as desired; the cosole keyboard layout is still the default (en_US I guess).

I‘ve read the man pages for mkinitcpio, and did not detect any action which is required after changing the conf file, except from rebooting, of course.

What am I missing?

Last edited by levi (2021-02-04 08:42:39)

Offline

#2 2020-11-28 16:57:52

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

After editing your /etc/mkinitcpio.conf you need to regenerate your mkinitcpio images, which you can do from memory by incanting

# mkinitcpio -p linux

Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#3 2020-11-28 21:05:52

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 360
Website

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

Maybe that old bug hits again (still) https://bbs.archlinux32.org/viewtopic.php?id=2953 ?

Offline

#4 2020-11-28 21:08:37

phunsoft
Member
From: Mettmenstetten / Switzerland
Registered: 2020-11-27
Posts: 4

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

levi wrote:

After editing your /etc/mkinitcpio.conf you need to regenerate your mkinitcpio images, which you can do from memory by incanting

# mkinitcpio -p linux

Thanks, this worked. However the command is incomplete as shown; it is running in dry mode only. The full command is:

# mkinitcpio -p linux -g linux

Offline

#5 2021-02-03 18:25:24

esuhl
Member
Registered: 2018-09-07
Posts: 16

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

phunsoft wrote:

Thanks, this worked. However the command is incomplete as shown; it is running in dry mode only. The full command is:

# mkinitcpio -p linux -g linux

Huh.  I'm a bit confused by that.  The man mkinitcpio(8) page does say that -g is necessary to generate the image file:

-g, --generate filename
Generate a CPIO image as filename. Default: no; this means nothing will be written to the filesystem unless this option is specified.

Yet, the mkinitcpio: Manual Generation wiki section shows images being created without that option.

If I run mkinitcpio -p linux, the output shows that the -g option gets set by default:

==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img

Since this relates to up-stream Arch, I've posted a question on their forums about this:

https://bbs.archlinux.org/viewtopic.php?pid=1953720

Last edited by esuhl (2021-02-03 18:25:59)

Offline

#6 2021-02-03 20:14:11

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

Yeah, not sure if something's changed wrt that.  I certainly don't remember doing the -g option when I last did that though that's probably a couple of years ago at the earliest, so it's possible the behaviour switched round there.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#7 2021-02-04 08:27:02

mistersmee
Member
From: India
Registered: 2020-12-24
Posts: 65

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

No, it hasn't. I reinstalled Arch32 a few days ago, (Don't ask. Messed up my fontconfig.) and `mkcpinitio -p linux` still works. Like @esuhl said, the -g flag is added in the 'default' preset.

Last edited by mistersmee (2021-02-04 08:30:00)

Offline

#8 2021-02-04 08:42:03

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

Yes, the link to the upstream bbs is illuminating.  Seems to me that the docs ought to specify that doing a -p automatically switches -g on, but that's just my opinion, and I'm not willing to argue it too hard.  I'm not sure what behaviour phunsoft experienced now though, of if he was just reading the docs and getting mislead.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Online

#9 2021-02-04 08:57:59

mistersmee
Member
From: India
Registered: 2020-12-24
Posts: 65

Re: [SOLVED] Keyboard layout not loaded - keymap hook added to mkinitcpio

Maybe he read somewhere that -g is required, or has been using it with -g every time?

Offline

Board footer

Powered by FluxBB