You are not logged in.

#1 2021-02-16 02:53:34

Zohnsaxen
Member
From: Germany
Registered: 2020-12-24
Posts: 11

[SOLVED] Cannot resolve multiple dependencies of "mpv"

Hi,

I've been having this issue for over a month.  I try to update each week hoping it might be resolved, but I'm starting to wonder if it's just me.

sudo pacman -Syu
[sudo] password for username:
:: Synchronizing package databases...
core                                              149.9 KiB   280 KiB/s 00:01 [############################################] 100%
extra                                            1950.4 KiB   593 KiB/s 00:03 [############################################] 100%
community-testing                                1033.5 KiB   408 KiB/s 00:03 [############################################] 100%
community                                           5.0 MiB   313 KiB/s 00:16 [############################################] 100%
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "libplacebo.so=72-32", a dependency of "mpv"
warning: cannot resolve "libxkbcommon.so=0-32", a dependency of "mpv"
:: The following package cannot be upgraded due to unresolvable dependencies:
      mpv

Is anyone else seeing this or is it just me?

Here's my version of mpv:

pacman -Qo $(which mpv)
/usr/bin/mpv is owned by mpv 1:0.32.0-4.1

mpv -V
mpv 0.32.0 Copyright © 2000-2020 mpv/MPlayer/mplayer2 projects
built on UNKNOWN
ffmpeg library versions:
   libavutil       56.51.100
   libavcodec      58.91.100
   libavformat     58.45.100
   libswscale      5.7.100
   libavfilter     7.85.100
   libswresample   3.7.100
ffmpeg version: n4.3.1

Any suggestions for how to resolve this?

Last edited by Zohnsaxen (2021-02-16 04:48:58)

Offline

#2 2021-02-16 04:30:17

jetfrog28
Member
Registered: 2018-08-25
Posts: 17

Re: [SOLVED] Cannot resolve multiple dependencies of "mpv"

Which architecture are you using?  Are you using the testing repos?

On my pentium4 system with testing repos, those .so's are provided by libplacebo 2.72.2-1.0 and libxkbcommon 1.0.3-1.0.  Those packages are both in the testing repos for pentium4 according to the web interface.  That libxkbcommon version is also in the testing repos for i686, but it looks like that libplacebo version is only in pentium4/testing.  I don't know enough to say why that would be though.

Last edited by jetfrog28 (2021-02-16 04:31:24)

Offline

#3 2021-02-16 04:32:06

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,009

Re: [SOLVED] Cannot resolve multiple dependencies of "mpv"

You're likely to have troubles like this if you enable the community-testing repo but not the main testing repo (which covers projects in core and extra I think).  The versions of packages you are looking for are in the testing repo.  Either deselect the community-testing repo or add the testing repo, it's up to you but this half-way-house isn't supported.  If you deselect the community-testing repo you'll need to reinstall your package base at the very least, it's probably simpler to add the testing repo and then just do an upgrade.  But you'll be supported here in any efforts you put towards getting your install back to a supported state.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#4 2021-02-16 04:47:52

Zohnsaxen
Member
From: Germany
Registered: 2020-12-24
Posts: 11

Re: [SOLVED] Cannot resolve multiple dependencies of "mpv"

Thanks jetfrog28 & levi, you guys were spot on.  I had enabled community-testing but not the main testing repo.  Once I added this to my /etc/pacman.conf I was able to upgrade the mpv dependencies and everything is working well.

[testing]
Include = /etc/pacman.d/mirrorlist

Offline

Board footer

Powered by FluxBB