You are not logged in.

#1 2021-05-02 19:11:58

nintenloup
Member
Registered: 2021-01-14
Posts: 13

[solved] i810 graphics give me garbled text

So I've been installing archlinux32 on some old hardware with intel 810 chipsets and I always get unreadable text. I tried using nomodeset as an option but to no success.

I've been able to boot linux in text mode, which solves the problem, but I can say bye bye to some things in that mode. Does any of you know how to solve that issue ? I'd really like that linux used the framebuffer.

I do know that if I put an ATI rage XL in PCI, linux can show itself properly in FB mode, but I'd really like to be able to use the integrated graphics from intel instead.

Last edited by nintenloup (2021-05-06 18:14:05)

Offline

#2 2021-05-02 19:47:40

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 907

Re: [solved] i810 graphics give me garbled text

Can you link to a graphic rip that shows the garbled text?  Maybe you'll have to put a camera to your LCD to show it.  The way it's specifically garbled might have a hint to us what's going wrong, which might result in a workaround for you.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2021-05-02 20:01:02

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

Re: [solved] i810 graphics give me garbled text

Did you try with xf86-video-intel?

Offline

#4 2021-05-02 20:36:34

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

abaumann wrote:

Did you try with xf86-video-intel?


Isn't that for X ?

So, for some reason, I cannot get the computer to boot back into framebuffer mode. It only wants to boot in text mode 80x25. Even my second i810 chipset does the same thing. Did the kernel changed since the previous version ?

Here is the /etc/default/grub file :

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="fb loglevel=3 quiet"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=800x600

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=800x600

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

Last edited by nintenloup (2021-05-02 20:39:01)

Offline

#5 2021-05-03 11:01:13

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

Re: [solved] i810 graphics give me garbled text

Mmh. https://01.org/linuxgraphics/gfx-docs/d … el810.html

maybe 'video=i810fb' in the kernel boot line helps..

Offline

#6 2021-05-03 20:28:59

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

Nothing happens. It stays in 80x25 text mode.

Last edited by nintenloup (2021-05-03 20:29:14)

Offline

#7 2021-05-04 04:32:44

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

So, I reinstalled the OS and I now get again the garble text here is an example of what I get :

garbletext

Offline

#8 2021-05-04 22:55:09

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

So, there is some sort of progress.

I was able to successfully load the module with modprobe i810fb.

To make it do it at boot, I followed this https://wiki.archlinux.org/title/Kernel_module but it doesn't works. I'm kinda lost again on what to do. Can anyone help ?

Offline

#9 2021-05-05 07:55:56

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

Re: [solved] i810 graphics give me garbled text

Do you get a /dev/fb0 device? Any kernel messages while modprobing i810fb?

Some links maybe (sadly in German):
http://www.vdr-wiki.de/wiki/index.php/F … fer_i810fb
We should see, if the code in the kernel is activated for i810fb and all settings are correct
(https://git.archlinux32.org/packages/tree/core/linux/config.pentium4 , there I see
CONFIG_FB_I810=m, so this would indicate the module is around).

The fact it is for kernel 2.6 makes me wonder..

I read a little bit the interwebs, and the i810fb driver looks shacky at best and is currently unmaintaned..

I don't have similar hardware (mine runs xf86-video-intel X and kernel module i915), so testing is not easy for me..

Offline

#10 2021-05-05 21:15:22

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

There is a fb0 appearing in /dev when I load i810fb and dmesg gives me this when I load it :

[  211.810729] i810-i2c: Probe DDC1 Bus
[  212.003527] i810fb_init_pci: DDC probe successful
[  212.011727] fbcon:  (fb0) is primary device
[  212.041362] Console: switching to colour frame buffer device 128x48
[  212.047401] I810FB: fb0         : Intel(R) 810E Framebuffer Device v0.9.0
               I810FB: Video RAM   : 4096K
               I810FB: Monitor     : H: 30-67 KHz V: 50-120 Hz
               I810FB: Mode        : 1024x768-16bpp@75Hz

Offline

#11 2021-05-06 10:23:10

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

Re: [solved] i810 graphics give me garbled text

Try adding 'i810fb' to MODULE in 'etc/mkinitcpio.conf' and rebuild your ramdisks with 'mkinitcpio -P'.
So the framebuffer should be used early on.

Offline

#12 2021-05-06 16:36:21

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

It doesn't do anything, the only mentions of i810fb I can find in dmesg is :

[    2.275681] i810fb_alloc_fbmem: cannot acquire agpgart
[   17.717589] agpgart-intel 0000:00:00.0: Intel i810 Chipset

Offline

#13 2021-05-06 17:00:55

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

Re: [solved] i810 graphics give me garbled text

Offline

#14 2021-05-06 18:13:41

nintenloup
Member
Registered: 2021-01-14
Posts: 13

Re: [solved] i810 graphics give me garbled text

Thant you so much for the help !

By adding intel_agp and agpgart to modules, I'm now able to load i810fb thru modules-load.d with the options in modprobe.d and I now have my tty in 1024x768

Offline

#15 2021-05-06 18:26:27

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

Re: [solved] i810 graphics give me garbled text

Np. Thank the guy writting a solution in 2006 in the Archlinux wiki upstream. :-)

Offline

Board footer

Powered by FluxBB