You are not logged in.

#1 2021-06-08 16:01:23

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 322
Website

HP Proliant DL140 G1

DL140

00:00.0 Host bridge: Broadcom GCNB-LE Host Bridge (rev 32)
00:00.1 Host bridge: Broadcom GCNB-LE Host Bridge
00:03.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Rage 3 [Rage XL PCI] (rev 27)
00:0f.0 ISA bridge: Broadcom CSB6 South Bridge (rev a0)
00:0f.1 IDE interface: Broadcom CSB6 RAID/IDE Controller (rev a0)
00:0f.2 USB controller: Broadcom CSB6 OHCI USB Controller (rev 05)
00:0f.3 Host bridge: Broadcom GCLE-2 Host Bridge
00:10.0 Host bridge: Broadcom CIOB-E I/O Bridge with Gigabit Ethernet (rev 12)
00:10.2 Host bridge: Broadcom CIOB-E I/O Bridge with Gigabit Ethernet (rev 12)
01:06.0 SCSI storage controller: Adaptec ASC-29320A U320 (rev 10)
02:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM5704 Gigabit Ethernet (rev 02)
02:00.1 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM5704 Gigabit Ethernet (rev 02)

The machine has only very slow USB ports, no RAID controller with SCSI (I had to put one in and change the original setup, as the
original setup is PATA and even I don't have spare PATA disks around).

If you stick in a non-HP-branded SCSI card, you can attach only one harddisk, no RAID1 possible (strange BIOS, SCSI-card
incompatibily issue, presumably).

My CDROM-drive is broken (or was never there), there is a nice black metal plate in its place, so booting from CDROM is
no option.

Booting from USB is possible, but it seems it only boots when the USB stick contains a floppy image.

The machine boots from one USB port into the plop boot manager (https://www.plop.at/en/bootmanager/download.html)
and then we can chainload the normal Archlinux32 USB stick from port 2.

dd if=plpbt.img of=/dev/sdb
dd if=archlinux32-2021.04.06-i686.iso of=/dev/sdb

This is also an interesting test case for recent kernels: 5.11.16 works fine, 5.12.x simply hangs when decompressing the ramdisk
(or afterwards). I fail to see anything at any loglevel.. (maybe a missing scsi driver? must investigate further)

Offline

Board footer

Powered by FluxBB