You are not logged in.

#1 2021-09-07 19:24:18

megafreakshow
Member
Registered: 2018-03-09
Posts: 19

[CLOSED] Can't upgrade fmt package (mkvtoolnix)

Been like this for a while

installing fmt (8.0.1-1.0) breaks dependency 'libfmt.so=7-32' required by mkvtoolnix-cli

I'm thinking mkvtoolnix needs an upgrade

Last edited by megafreakshow (2021-09-10 12:03:49)

Offline

#2 2021-09-07 20:05:52

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,013

Re: [CLOSED] Can't upgrade fmt package (mkvtoolnix)

Seems to be a newer one in i486 than any of the others, but the simplest solution may just be to port all of the version 61's out of staging across all of the release repos, or maybe post it to testing so we get to look at it before prime time.  It's not something I use myself though, but I could more easily check that it depends on the right things.

Last edited by levi (2021-09-07 20:07:25)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2021-09-08 09:33:50

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 419
Website

Re: [CLOSED] Can't upgrade fmt package (mkvtoolnix)

I rebuilt and pushed mkvtoolnix to stable.

Offline

#4 2021-09-08 14:47:38

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,013

Re: [CLOSED] Can't upgrade fmt package (mkvtoolnix)

Thanks; that looks better now.  Seems to be a rebuild of that already in staging, but that's not a problem in itself.  But yeah, now dependency versions match between mkvtoolnix-cli and what fmt provides.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB