You are not logged in.

#1 2021-09-27 21:19:31

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

[SOLVED}-Error when gio mounting my phone

When I gio mount my phone to transfer mp3s to it, it currently stalls to begin with and prints out this error:

Error creating proxy: Error calling StartServiceByName for org.gtk.vfs.UDisks2VolumeMonitor: Timeout was reached (g-io-error-quark, 24)

But after that timeout the device is mounted and accessible.
When I try to umount it I get:

(gio mount:2152): GVFS-RemoteVolumeMonitor-WARNING **: 16:04:38.430: remote volume monitor with dbus name org.gtk.vfs.UDisks2VolumeMonitor is not supported

When I try to run the process again, I get the latter warning at the mount and umount stages, but that takes an inappreciable time to complete, so apart from the noise that's not a problem any more.  It's not really much strife at all, just a wait for the timeout the first time you use it, but perhaps it indicates a wider problem.

Last edited by levi (2021-10-25 17:34:02)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#2 2021-09-28 06:18:02

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: [SOLVED}-Error when gio mounting my phone

I'm runing kernel 5.14.7 fwiw as of yesterday.

The following packages were updated yesterday:

linux-5.14.7.arch1-1.0-pentium4.pkg.tar.zst
firefox-92.0.1-1.0-pentium4.pkg.tar.zst
webkit2gtk-2.32.4-1.0-pentium4.pkg.tar.zst
inkscape-1.1.1-1.0-pentium4.pkg.tar.zst
qt5-base-5.15.2+kde+r227-1.0-pentium4.pkg.tar.zst
gtk3-1:3.24.30+62+g8d04980f38-2.0-pentium4.pkg.tar.zst
sway-1:1.6.1-1.0-pentium4.pkg.tar.zst
python-numpy-1.21.2-1.0-pentium4.pkg.tar.zst
gdb-11.1-1.0-pentium4.pkg.tar.zst
links-2.24-2.0-pentium4.pkg.tar.zst
imagemagick-7.1.0.8-1.0-pentium4.pkg.tar.zst
newsboat-2.25-1.0-pentium4.pkg.tar.zst
gst-plugins-bad-libs-1.18.5-1.0-pentium4.pkg.tar.zst
npm-7.24.1-1.0-any.pkg.tar.zst
gst-plugins-good-1.18.5-1.0-pentium4.pkg.tar.zst
sudo-1.9.8.p2-1.0-pentium4.pkg.tar.zst
haskell-hxt-9.3.1.22-17.1-pentium4.pkg.tar.zst
gobject-introspection-1.70.0-1.0-pentium4.pkg.tar.zst
curl-7.79.0-3.0-pentium4.pkg.tar.zst
libnm-1.32.12-1.0-pentium4.pkg.tar.zst
openssh-8.7p1-2.0-pentium4.pkg.tar.zst
gst-plugins-bad-1.18.5-1.0-pentium4.pkg.tar.zst
python2-pycryptodome-3.10.4-1.0-pentium4.pkg.tar.zst
btrfs-progs-5.14.1-1.0-pentium4.pkg.tar.zst
node-gyp-8.2.0-1.0-any.pkg.tar.zst
pacman-6.0.1-2.1-pentium4.pkg.tar.zst
haskell-foundation-0.0.26.1-10.1-pentium4.pkg.tar.zst
tracker3-3.2.0-1.0-pentium4.pkg.tar.zst
libmm-glib-1.18.2-1.0-pentium4.pkg.tar.zst
gsettings-desktop-schemas-41.0-1.0-any.pkg.tar.zst
cryptsetup-2.4.1-1.0-pentium4.pkg.tar.zst
pam-1.5.2-1.0-pentium4.pkg.tar.zst
freetype2-2.11.0-4.0-pentium4.pkg.tar.zst
xterm-369-1.0-pentium4.pkg.tar.zst
tzdata-2021b-1.0-pentium4.pkg.tar.zst
iana-etc-20210903-1.0-any.pkg.tar.zst
sdl-1.2.15+387+gfbfcca32-1.0-pentium4.pkg.tar.zst
openbox-3.6.1-8.0-pentium4.pkg.tar.zst
msmtp-1.8.16-1.0-pentium4.pkg.tar.zst
file-5.40-6.0-pentium4.pkg.tar.zst
libglvnd-1.3.4-1.0-pentium4.pkg.tar.zst
wlroots-0.14.1-2.0-pentium4.pkg.tar.zst
xz-5.2.5-2.0-pentium4.pkg.tar.zst
libinput-1.19.0-1.0-pentium4.pkg.tar.zst
python-dnspython-1:2.1.0-1.0-any.pkg.tar.zst
fluidsynth-2.2.3-1.0-pentium4.pkg.tar.zst
grep-3.7-1.0-pentium4.pkg.tar.zst
libblockdev-2.26-1.0-pentium4.pkg.tar.zst
gobject-introspection-runtime-1.70.0-1.0-pentium4.pkg.tar.zst
libmtp-1.1.19-1.0-pentium4.pkg.tar.zst
neon-0.32.1-1.0-pentium4.pkg.tar.zst
gd-2.3.3-2.0-pentium4.pkg.tar.zst
libxi-1.8-1.1-pentium4.pkg.tar.zst
perl-io-socket-ssl-2.072-1.0-any.pkg.tar.zst
perl-libwww-6.57-1.0-any.pkg.tar.zst
haskell-cmark-gfm-0.2.2-72.1-pentium4.pkg.tar.zst
vulkan-icd-loader-1.2.191-1.0-pentium4.pkg.tar.zst
cantarell-fonts-1:0.303-1.0-any.pkg.tar.zst
libass-0.15.2-1.0-pentium4.pkg.tar.zst
libnghttp2-1.45.0-1.0-pentium4.pkg.tar.zst
haskell-network-uri-2.6.4.1-26.1-pentium4.pkg.tar.zst
libxcrypt-4.4.26-1.0-pentium4.pkg.tar.zst
libcap-2.58-1.0-pentium4.pkg.tar.zst
gdb-common-11.1-1.0-pentium4.pkg.tar.zst
wayland-protocols-1.23-1.0-any.pkg.tar.zst
libatomic_ops-7.6.12-1.0-pentium4.pkg.tar.zst
pkgconf-1.8.0-1.0-pentium4.pkg.tar.zst
libnotify-0.7.9-2.0-pentium4.pkg.tar.zst
talloc-2.3.3-1.1-pentium4.pkg.tar.zst
seatd-0.6.2-1.0-pentium4.pkg.tar.zst
xf86-input-libinput-1.2.0-1.0-pentium4.pkg.tar.zst
alsa-card-profiles-1:0.3.36-1.0-pentium4.pkg.tar.zst
haskell-th-compat-0.1.2-19.1-pentium4.pkg.tar.zst
gtk-update-icon-cache-1:4.4.0-1.1-pentium4.pkg.tar.zst

Nothing there jumps out at me as being responsible for this timeout, but the timing indicates it's this update that cause it, I think.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2021-09-29 05:59:43

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 615

Re: [SOLVED}-Error when gio mounting my phone

yeah, only the kernel seems relevant, here (on first glance) - maybe, you can try booting an old(er) kernel (e.g. downgrade it) and see, whether the issue still pops up - if not, we can diff the config of the kernels and look for issues, there smile

Offline

#4 2021-09-29 06:05:14

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: [SOLVED}-Error when gio mounting my phone

Good idea, I've switched out to 5.14.5 which I was running previously for a few weeks without this behaviour.  I'll turn my computer off now, and I'll be transferring mp3s to my phone tomorrow for sure.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#5 2021-09-29 15:47:14

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: [SOLVED}-Error when gio mounting my phone

So, no, just downgrading the kernel produced the same error when mounting my phone.  I don't think I got this timeout before Monday's update but I can't be certain of that.

My next suspicion was libblockdev.  I've downgraded that and my mount is still producing those warnings.  I assumed I don't need to reboot to be using that new old code, unlike the kernel, but perhaps not.

Edit: Yes, downgrading both the kernel and libblockdev and rebooting cleared the timeout and subsequent warning.  Downgrading the kernel alone didn't, so it looks like a gotcha in libblockdev to me.

Last edited by levi (2021-09-29 15:56:18)


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#6 2021-10-25 17:33:33

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

Re: [SOLVED}-Error when gio mounting my phone

Seems my update last night fixed this.  New libblockdev seems to have fixed it.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB