You are not logged in.

#1 2022-01-07 05:50:19

CivilizedGuide
Member
Registered: 2022-01-07
Posts: 4

Kernel panic after random shutdown

Hi, i'm having an issue during the installation of arch after a shutdown because of trying to install a WLAN card while the computer was running

NOTE: everything before the shutdown was working perfectly

after the shutdown no matter how i flash the USB or what other USB use i get a kernel panic error
here is a photo of the error: https://imgur.com/a/sQ8c2LI

another thing to mention is that i think there is no hardware damage issues because i installed windows XP perfectly after the shutdown


the laptop is an Acer Aspire ONE AO751h with 1GB of RAM and an Intel Atom Z520

Offline

#2 2022-01-07 08:42:06

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Kernel panic after random shutdown

The dump shows a generic panic inside a 32-bit system call. This is most likely a bug in the wlan driver.
You can try to boot the machine without wlan enabled and shut it down and see if the error persists.
I have a wlan driver on OLPC-XO-1 which is also randomly segfaulting. This is the problem with
closed source firmware blobs being loaded in the kernel, if they don't work, you have a hard time
to debug, why they are failing..

Offline

#3 2022-01-07 15:06:12

CivilizedGuide
Member
Registered: 2022-01-07
Posts: 4

Re: Kernel panic after random shutdown

Sorry, it will sound dumb but i don't know how to diable WLAN on boot, on the bios I found an option to disable network or something like that but Arch is still giving the kernel panic error and Windows XP is still connected to WIFI

Offline

#4 2022-01-07 15:41:06

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: Kernel panic after random shutdown

You could try here https://help.ubuntu.com/community/AspireOne/AO751h.
Blacklisting the wlan modules.

Offline

#5 2022-01-07 18:10:35

CivilizedGuide
Member
Registered: 2022-01-07
Posts: 4

Re: Kernel panic after random shutdown

I cant edit the /etc/modprobe.d/blacklist-ath_pci.conf file because the kernel panic error, but doing a little search on google I found that adding modprobe.blacklist=ath_pci at the end of the kernel line would blacklist the WLAN kernel module, I added it but is still showing the kernel panic error.

sorry for my bad english

EDIT: I added "debug" at the end of the kernel line, then, recorded a video and slowed it and this is what I found: https://imgur.com/a/2jWnw9e

Last edited by CivilizedGuide (2022-01-08 05:46:05)

Offline

Board footer

Powered by FluxBB