You are not logged in.

#1 2022-03-09 20:11:51

cocon42
Member
Registered: 2022-03-09
Posts: 9

[SOLVED]-Bootvorgang durch Kernelupdate kaputt

Hallo,

nach jedem Kernelupdate bootet die Kiste nicht mehr. Es handelt sich um ein mit dm-crypt verschlüsseltes System.
Heute bei

pacman -Syu

wurde der LTS-Kernel upgedatet, nach einem Neustart war es wieder soweit - nach der
Abfrage des Keys kommt dann nur "Warning - unable to load Kernel modules" und mehrmals "Warning - unable to
reach wireless network". Die Meldungen während des Systemupgrades scheinen mir unauffällig, keine Fehlermeldungen oder
ähnliches, die Images werden (vermutlich) erstellt und auch die Hooks laufen dann.

Ich behelfe mir indem ich mit dem Installationsmedium auf Stick boote, mich mit arch-chroot ins System begebe und
dann ein

pacman -S linux-lts

ausführe. Der Kernel wird schon als aktuell erkannt und reinstalliert, die Images werden erstellt, die
Hooks laufen durch und dann bootet die Kiste auch wieder normal.

Als Bootloader nehme ich den GRUB.

Wieso klappts beim reinstallieren und crasht beim Systemupdate?


viele Grüsse Harry

Last edited by levi (2022-03-13 23:08:40)

Offline

#2 2022-03-09 20:32:13

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Toent etwas verwandt zu https://bbs.archlinux32.org/viewtopic.php?id=3197
Keine Ahnung momentan. :-)

Online

#3 2022-03-10 16:49:35

cocon42
Member
Registered: 2022-03-09
Posts: 9

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Ja, das ist auch mein Problem.

Ich habe die pacman Logs rausgefiltert um mal darzustellen was da passiert.
Leider bin ich noch nicht fit genug um diese auch richtig zu interpretieren, was jedoch auffällt ist dass
ich hier öfter was von systemd lese und ich bei den Hooks udev eingetragen habe.

hier ist das Log von der Aktualisierung mit pacman -Syu

[2022-03-09T12:12:17+0100] [PACMAN] Running 'pacman -Syu --ignore clang'
[2022-03-09T12:12:17+0100] [PACMAN] synchronizing package lists
[2022-03-09T12:12:24+0100] [PACMAN] starting full system upgrade
[2022-03-09T12:14:09+0100] [ALPM] running '60-mkinitcpio-remove.hook'...
[2022-03-09T12:14:09+0100] [ALPM] transaction started
[2022-03-09T12:14:09+0100] [ALPM] upgraded libjpeg-turbo (2.1.2-1.1 -> 2.1.3-1.0)
[2022-03-09T12:14:09+0100] [ALPM] installed tpm2-tss (3.1.0-1.0)
[2022-03-09T12:14:16+0100] [ALPM] upgraded libsecret (0.20.4-1.1 -> 0.20.5-1.1)
[2022-03-09T12:14:29+0100] [ALPM] upgraded linux-lts (5.15.22-1.1 -> 5.15.25-1.1)
[2022-03-09T12:14:29+0100] [ALPM] upgraded pacman-mirrorlist (20220131-1.0 -> 20220131-1.1)
[2022-03-09T12:14:31+0100] [ALPM] upgraded xorg-server-common (21.1.3-6.0 -> 21.1.3-6.1)
[2022-03-09T12:14:31+0100] [ALPM] upgraded xorg-server (21.1.3-6.0 -> 21.1.3-6.1)
[2022-03-09T12:14:31+0100] [ALPM] upgraded xorg-server-devel (21.1.3-6.0 -> 21.1.3-6.1)
[2022-03-09T12:14:31+0100] [ALPM] upgraded xorg-server-xephyr (21.1.3-6.0 -> 21.1.3-6.1)
[2022-03-09T12:14:31+0100] [ALPM] upgraded xorg-server-xnest (21.1.3-6.0 -> 21.1.3-6.1)
[2022-03-09T12:14:32+0100] [ALPM] upgraded xorg-server-xvfb (21.1.3-6.0 -> 21.1.3-6.1)
[2022-03-09T12:14:33+0100] [ALPM] transaction completed
[2022-03-09T12:14:35+0100] [ALPM] running '20-systemd-sysusers.hook'...
[2022-03-09T12:14:35+0100] [ALPM-SCRIPTLET] Creating group 'tss' with GID 972.
[2022-03-09T12:14:35+0100] [ALPM-SCRIPTLET] Creating user 'tss' (tss user for tpm2) with UID 972 and GID 972.
[2022-03-09T12:14:35+0100] [ALPM] running '30-systemd-tmpfiles.hook'...
[2022-03-09T12:14:36+0100] [ALPM] running '30-systemd-udev-reload.hook'...
[2022-03-09T12:14:36+0100] [ALPM] running '30-systemd-update.hook'...
[2022-03-09T12:14:36+0100] [ALPM] running '60-depmod.hook'...
[2022-03-09T12:14:51+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2022-03-09T12:14:51+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2022-03-09T12:14:51+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2022-03-09T12:14:52+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.25-1.1-lts
[2022-03-09T12:14:52+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-03-09T12:14:54+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-03-09T12:14:55+0100] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2022-03-09T12:14:56+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-03-09T12:14:56+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2022-03-09T12:14:57+0100] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2022-03-09T12:14:57+0100] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration
[2022-03-09T12:14:57+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-03-09T12:14:57+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-03-09T12:14:59+0100] [ALPM-SCRIPTLET]   -> Running build hook: [encrypt]
[2022-03-09T12:15:02+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qat_4xxx
[2022-03-09T12:15:04+0100] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2022-03-09T12:15:06+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-03-09T12:15:07+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-03-09T12:15:07+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-03-09T12:15:08+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
[2022-03-09T12:15:15+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-03-09T12:15:15+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2022-03-09T12:15:15+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2022-03-09T12:15:15+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.25-1.1-lts
[2022-03-09T12:15:16+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-03-09T12:15:17+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-03-09T12:15:18+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-03-09T12:15:18+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-03-09T12:15:23+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2022-03-09T12:15:23+0100] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2022-03-09T12:15:23+0100] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration
[2022-03-09T12:15:23+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-03-09T12:15:23+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-03-09T12:15:26+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2022-03-09T12:15:26+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2022-03-09T12:15:27+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2022-03-09T12:15:27+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2022-03-09T12:15:27+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2022-03-09T12:15:28+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2022-03-09T12:15:34+0100] [ALPM-SCRIPTLET]   -> Running build hook: [encrypt]
[2022-03-09T12:15:35+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qat_4xxx
[2022-03-09T12:15:37+0100] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2022-03-09T12:15:38+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-03-09T12:15:41+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-03-09T12:15:45+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-03-09T12:15:45+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2022-03-09T12:15:59+0100] [ALPM-SCRIPTLET] ==> Image generation successful

und hier das Log bei dem ich in arch-chroot nochmals pacman -S linux-lts ausgeführt habe:

[2022-03-09T13:14:14+0100] [PACMAN] Running 'pacman -S linux-lts'
[2022-03-09T13:14:41+0100] [ALPM] transaction started
[2022-03-09T13:14:51+0100] [ALPM] reinstalled linux-lts (5.15.25-1.1)
[2022-03-09T13:14:53+0100] [ALPM] transaction completed
[2022-03-09T13:14:54+0100] [ALPM] running '30-systemd-update.hook'...
[2022-03-09T13:14:54+0100] [ALPM] running '60-depmod.hook'...
[2022-03-09T13:15:10+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2022-03-09T13:15:10+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2022-03-09T13:15:10+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2022-03-09T13:15:10+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.25-1.1-lts
[2022-03-09T13:15:11+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-03-09T13:15:13+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-03-09T13:15:15+0100] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2022-03-09T13:15:16+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-03-09T13:15:17+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2022-03-09T13:15:18+0100] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2022-03-09T13:15:18+0100] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration
[2022-03-09T13:15:18+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-03-09T13:15:19+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-03-09T13:15:22+0100] [ALPM-SCRIPTLET]   -> Running build hook: [encrypt]
[2022-03-09T13:15:25+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qat_4xxx
[2022-03-09T13:15:27+0100] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2022-03-09T13:15:30+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-03-09T13:15:30+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-03-09T13:15:31+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-03-09T13:15:32+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
[2022-03-09T13:15:40+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2022-03-09T13:15:40+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2022-03-09T13:15:40+0100] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2022-03-09T13:15:40+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.15.25-1.1-lts
[2022-03-09T13:15:40+0100] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2022-03-09T13:15:42+0100] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2022-03-09T13:15:44+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2022-03-09T13:15:44+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2022-03-09T13:15:50+0100] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2022-03-09T13:15:50+0100] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2022-03-09T13:15:50+0100] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration
[2022-03-09T13:15:50+0100] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2022-03-09T13:15:50+0100] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2022-03-09T13:15:55+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2022-03-09T13:15:55+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2022-03-09T13:15:55+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2022-03-09T13:15:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2022-03-09T13:15:56+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2022-03-09T13:15:57+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2022-03-09T13:16:05+0100] [ALPM-SCRIPTLET]   -> Running build hook: [encrypt]
[2022-03-09T13:16:07+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qat_4xxx
[2022-03-09T13:16:09+0100] [ALPM-SCRIPTLET]   -> Running build hook: [lvm2]
[2022-03-09T13:16:10+0100] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2022-03-09T13:16:14+0100] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2022-03-09T13:16:17+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2022-03-09T13:16:18+0100] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2022-03-09T13:16:33+0100] [ALPM-SCRIPTLET] ==> Image generation successful

vielleicht fällt jemandem was auf was zur Lösung führt.

viele Grüße Harry

Offline

#4 2022-03-10 17:02:58

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Sieht Alles ziemlich ok aus.

Waehrend dem Booten wuerde ich mal 'quiet' wegnehmen aus den Bootoptionen von grub, 'debug' und 'loglevel' hochschrauben, etc.
Irgendwas muss er ausgeben..

Online

#5 2022-03-11 10:49:27

cocon42
Member
Registered: 2022-03-09
Posts: 9

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Danke für die Info!

hab ich gemacht. Vielleicht bin ich nun selber drauf gekommen, ich habe die linux-lts-headers nicht mit installiert. Könnte das der Grund für das
Verhalten nach einem Kernelupdate sein?
Würde es etwas bringen das Paket dkms noch zu installieren?

Offline

#6 2022-03-11 10:57:50

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Kommt sehr auf die Hardware an. Wenn zentrale Hardware dkms braucht, dann natuerlich. Aber normalerweise reicht der Kernel alleine..

Online

#7 2022-03-13 12:38:06

cocon42
Member
Registered: 2022-03-09
Posts: 9

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

jetzt funktioniert alles. Der Grund war die fehlenden

pacman -S linux-lts-headers

vielen Dank an @abaumann

Harry

Last edited by cocon42 (2022-03-13 12:40:52)

Offline

#8 2022-03-15 16:48:03

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Oh gut.

Kein Problem. :-)

Online

#9 2022-04-05 20:08:53

cocon42
Member
Registered: 2022-03-09
Posts: 9

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Hallo nochmal,

leider ist der Fehler doch wieder aufgetreten. Ich bin jetzt durch Zufall auch vermutlich darauf gekommen.
Nochmal mein Systemsetup:
Partition sda2 ist verschlüsselt, darauf ein LVM mit dem Rootfilesystem.
Auf der Partition sda1 liegen unverschlüsselt die initramfs-linux.img und vmlinuz-linux Dateien.

Wenn ich das System über arch-chroot "retten" muss mounte ich das entsperrte Rootfilesystem
nach /mnt und die Partition mit den Images nach /mnt/boot und installiere die Kernel neu.

Jetzt, im Produktivsystem gibt mir lsblk aus dass die Partition /dev/sda1 gar nirgends gemountet ist!
Folglich kann pacman die Kernelimages die dort liegen gar nicht aktualisieren und schreibt mir das
unter /boot rein, was sich ja auf dem verschlüsselten Teil des Rootfilesystems befindet.

Die kurze Frage bevor ich was kaputt mache: wäre es die richtige Lösung, beim hochfahren /dev/sda1
einfach nach /boot zu mounten?

Gruss Harry

Last edited by cocon42 (2022-04-05 20:11:36)

Offline

#10 2022-04-06 17:27:36

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

Sollte klappen, ja.
Auch eine Variante ist sich ein pacman Hook zu installieren, der einen warnt, wenn man vergessen hat /boot zu mounten (deepthought hatte mal so eins, ich muss mal
suchen, hatte es auch irgendwo..).

Online

#11 2022-04-06 17:33:42

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 810
Website

Re: [SOLVED]-Bootvorgang durch Kernelupdate kaputt

https://bbs.archlinux.org/viewtopic.php?id=234607

aehnlich. Aber ich wuerde es einfach fix mounten oder ein Skript aufrufen, welches einfach terminiert, wenn
/boot nicht schreibbar als gemountete Parition vorhanden ist.

Automatisch Mounten toent nach "automatischen" Problemen. :-)

Online

Board footer

Powered by FluxBB