You are not logged in.

#1 2022-04-14 18:37:31

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,179

keyboard and mouse not recognised by LXDE after upgrade

Two days ago I performed my regular system update, which touched at least xorg-server and libx11.  After I'd shut down the computer overnight and brought it back up running startx worked but neither my touchpad acting as my mouse nor my keyboard were working, so I was unable to use it properly, and I ended up killing it from another login, and working that day in text mode only.

I'd noticed some error appearing in the screen log of startx which looked like it might have had something to do with the problem, but had no effective way of capturing that log.  I piped the stderr into a logfile the first thing today, but to my surprise it's all working today.  But here's the pertinent part of the log in case it's of any use:

==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Could not resolve keysym XF86EmojiPicker
Errors from xkbcomp are not fatal to the X server
** Message: 17:10:28.148: main.vala:102: Session is LXDE
** Message: 17:10:28.150: main.vala:103: DE is LXDE
libGL error: MESA-LOADER: failed to open i915: /usr/lib/dri/i915_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib/dri, suffix _dri)
libGL error: failed to load driver: i915
** Message: 17:10:29.915: main.vala:134: log directory: /home/\[user\]/.cache/lxsession/LXDE
** Message: 17:10:29.915: main.vala:135: log path: /home/\[user\]/.cache/lxsession/LXDE/run.log

But as of today it seems like a transient error, so I'm only leaving this here in case it's of use to anyone else.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB