You are not logged in.

#1 2023-01-06 19:30:00

chrisd
Member
Registered: 2020-09-06
Posts: 7

[SOLVED] latest coq/coqide packages are rather old

Hello All,

Would it be possible that the coq, coqide and coq-doc packages are updated to the latest version? Current
version is from August 2020 so that is a rather long time ago. In the meantime standard library theorems
have been deprecated in the newest version but their replacements are not yet in archlinux32 coq, so that
becomes a bit of a nuisance.

Kind Regards,
Chris

Last edited by levi (2023-01-07 20:29:29)

Offline

#2 2023-01-07 09:01:40

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 846
Website

Re: [SOLVED] latest coq/coqide packages are rather old

COQC      theories/setoid_ring/Rings_R.v
SPHINXBUILD doc/sphinx (html)
rm -rf _build_vo/default/doc/stdlib/html/
mkdir -p -p _build_vo/default/doc/stdlib/html/
COQDOC VFILES
Running Sphinx v5.3.0
WARNING: Invalid configuration value found: 'language = None'. Update your configuration to a valid language code. Falling back to 'en' (English).

Exception occurred:
  File "/usr/lib/python3.10/site-packages/antlr4/atn/ATNDeserializer.py", line 50, in checkVersion
    raise Exception("Could not deserialize ATN with version " + str(version) + " (expected " + str(SERIALIZED_VERSION) + ").")
Exception: Could not deserialize ATN with version  (expected 4).
The full traceback has been saved in /tmp/sphinx-err-4z5t2eiy.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphinx/issues>. Thanks!
make[1]: *** [Makefile.doc:84: refman-html] Error 2
make[1]: *** Waiting for unfinished jobs....
mv _build_vo/default/doc/stdlib/html//index.html _build_vo/default/doc/stdlib/html//genindex.html
make[1]: Leaving directory '/build/coq/src/coq-8.16.1'
make: *** [Makefile.make:122: submake] Error 2

I'll try to ommit the documentation and see if it builds then..

Offline

#3 2023-01-07 10:39:08

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 846
Website

Re: [SOLVED] latest coq/coqide packages are rather old

modern configure stuff: you say --with-doc no or ommit it and the build still shows:

SPHINXBUILD doc/sphinx (html)
mkdir -p -p _build_vo/default/doc/stdlib/html/
/bin/sh: line 1: sphinx-build: command not found

Offline

#4 2023-01-07 11:28:35

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 846
Website

Re: [SOLVED] latest coq/coqide packages are rather old

aha, there where some explicit doc targets in MAKE_TARGETS in PKGBUILD..
rebuilding now..

Offline

#5 2023-01-07 17:40:57

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 846
Website

Re: [SOLVED] latest coq/coqide packages are rather old

..pushed to stable

Offline

#6 2023-01-08 19:33:35

chrisd
Member
Registered: 2020-09-06
Posts: 7

Re: [SOLVED] latest coq/coqide packages are rather old

Hello Abaumann,

I have upgraded and it works.

Many Thanks!
Chris

Offline

#7 2023-01-09 12:51:35

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 846
Website

Re: [SOLVED] latest coq/coqide packages are rather old

np. glad it worked. :-)

Offline

Board footer

Powered by FluxBB