You are not logged in.

#1 2018-10-13 08:48:10

Vladdy
Member
Registered: 2017-11-17
Posts: 9

GPGME Error

I need to fix this issue with GPGME error. I cannot upgrade or install anything. This is what I get in terminal:

sudo pacman -Syyu
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
 core                    1424.0   B  0.00B/s 00:00 [######################] 100%
 core.sig                1424.0   B  0.00B/s 00:00 [######################] 100%
error: GPGME error: No data
error: failed to update core (invalid or corrupted database (PGP signature))
 extra                   1424.0   B  0.00B/s 00:00 [######################] 100%
 extra.sig               1424.0   B  0.00B/s 00:00 [######################] 100%
error: GPGME error: No data
error: failed to update extra (invalid or corrupted database (PGP signature))
 community               1424.0   B  0.00B/s 00:00 [######################] 100%
 community.sig           1424.0   B  0.00B/s 00:00 [######################] 100%
error: GPGME error: No data
error: failed to update community (invalid or corrupted database (PGP signature))
 archlinuxfr                7.8 KiB  0.00B/s 00:00 [######################] 100%

I tried lots of workarounds like

pacman-key --init

and

pacman-key --populate archlinux

nothing helps.

If I edit

etc/pacman.conf

and insert

SigLevel = Never

to core and community then I get this output:

sudo pacman -Syyu
:: Synchronizing package databases...
 core                    1424.0   B   348K/s 00:00 [######################] 100%
 extra                   1424.0   B  0.00B/s 00:00 [######################] 100%
 community               1424.0   B  0.00B/s 00:00 [######################] 100%
 archlinuxfr                7.8 KiB  2.55M/s 00:00 [######################] 100%
:: Starting full system upgrade...
error: could not open file /var/lib/pacman/sync/core.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/extra.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/community.db: Unrecognized archive format
 there is nothing to do

Offline

#2 2018-10-13 11:34:54

Vladdy
Member
Registered: 2017-11-17
Posts: 9

Re: GPGME Error

SOLVED!

Finally I managed to solved this. I'll write what I've done.

sudo rm /var/lib/pacman/sync/*db.sig*

Edit & uncomment:

sudo nano /etc/pacman.d/mirrorlist

## Germany
Server = http://archlinux32.vollzornbrot.de/$arch/$repo
Server = https://archlinux32.vollzornbrot.de/$arch/$repo
Server = http://mirror.archlinux32.org/$arch/$repo
Server = https://mirror.archlinux32.org/$arch/$repo
# note: you need to resolve via openNIC (or similar) to access the next mirror
#Server = http://mirror.archlinux32.oss/$arch/$repo

Then:

sudo pacman-key --init

sudo pacman-key --populate archlinux

sudo pacman -Syy

sudo pacman -Syyu

Done!

Offline

Board footer

Powered by FluxBB