You are not logged in.

#1 2019-07-24 11:20:35

Registered: 2019-07-24
Posts: 3

keyboard layout not honored on boot

Greetings to everyone,

my system resets to us keyboard layout after every reboot and ignores the /etc/vconsole.conf i have created during install; i am fairly certain i have written correctly everything.
I also tried using localectl to achieve the same result (as detailed in the Arch Wiki) but after reboot settings are lost
The keymap is italian (if relevant) and the computer is an Acer Aspire One A110L with Atom N270 CPU

I can provide more logs if necessary (i don t have the netbook with me right now)

Thanks in advance


#2 2019-08-07 15:08:48

Registered: 2019-08-07
Posts: 6

Re: keyboard layout not honored on boot

Same here, with Brazilian keyboard in both real and virtual machines. Every time I boot, I need to issue loadkeys command in order to load the correct keyboard layout.

My configuration:

$ cat /etc/vconsole.conf
$ ls -lh /usr/share/kbd/keymaps/i386/qwerty/ | grep br-abnt2
-rw-r--r-- 1 root root 1,2K mai  3 09:15


#3 2019-08-07 20:01:12

From: Jena, Germany
Registered: 2017-06-17
Posts: 608

Re: keyboard layout not honored on boot

I just booted up an old pc running the i486 version of archlinux32 - and it shows the same issue (keyboard layout should become de-latin1)


#4 2019-09-21 18:45:01

Registered: 2019-09-21
Posts: 1

Re: keyboard layout not honored on boot

Greetings folks,

Same here with fresh install today.
Hope my solution helps even if it is a bit overkill :
Modify your /etc/vconsole.conf to your needs.
Then open your favorite editor as root to modify /etc/mkinitcpio.conf.

In the HOOKS section, add


So it gives something like that:

HOOKS=(base udev autodetect modconf block filesystems keyboard fsck keymap)

Then, for standard archlinux kernel, you regenerate your initram with:

mkinitcpio -p linux

for the lts one:

mkinitcpio -p linux-lts

Solves it here, hopefully it helps.


#5 2019-09-21 19:34:11

Registered: 2019-02-20
Posts: 9

Re: keyboard layout not honored on boot

There is an original post about this issue, with some details, and the same solution :-)

Trouble setting the propper keymap layout


Board footer

Powered by FluxBB