You are not logged in.

#1 2020-09-28 22:23:08

cx
Member
Registered: 2019-08-17
Posts: 93

[Solved] Gimp / Glimpse segfaulting (pentium4)

Hello all!

My system suffers from a crashing Gimp! Though it may start completely, it always falls into digital nirvana when attempting to open a file:

$ gimp
GIMP-Warnung: Fehler beim Verarbeiten von »/home/mito/.config/GIMP/2.10/toolrc« in Zeile 3: unexpected identifier 'GimpToolInfo', expected symbol - Schwerwiegender Verarbeitungsfehler

gimp: fatal error: Speicherzugriffsfehler

(script-fu:1303): LibGimpBase-WARNING **: 17:36:37.700: script-fu: gimp_wire_read(): error

Same issue with Glimpse (replacing Gimp; took 2 hrs to compile...):

$ LANG=en_DK.utf8 glimpse
glimpse: fatal error: Segmentation fault

(script-fu:4664): LibGimpBase-WARNING **: 22:10:41.003: script-fu: gimp_wire_read(): error

Happens both in X and Wayland btw.

Besides, due to this solved issue in the main Arch forums, my LCMS2 version is 2.11-2.0 and seems up-to-date.


No problems on my Arch64 though.
Any ideas? Does somebody around here also have trouble running Gimp?


(At least Krita works, but it can not cope with recent .xcf-Gimp files...)

Last edited by cx (2020-09-28 23:20:23)

Offline

#2 2020-09-28 22:36:17

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 952

Re: [Solved] Gimp / Glimpse segfaulting (pentium4)

Check you're up to date; pango was updated last week and fixed a similar error for me.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2020-09-28 23:19:26

cx
Member
Registered: 2019-08-17
Posts: 93

Re: [Solved] Gimp / Glimpse segfaulting (pentium4)

Awesome, thanks! Yet I already do pacman -Syu every day at least once lately and wouldn't have expected this one!

And know what: suddenly also now the graphical text editors work again – and it's not Sway to blame! Good old Pango! big_smile

Offline

Board footer

Powered by FluxBB