You are not logged in.

#1 2021-06-21 00:23:44

da
Member
Registered: 2021-05-07
Posts: 3

can't find the right package for cross compiling c code

Hi, I used to use mingw-w64 in the 64 bit version of ArchLinux, but when I install both mingw-w64-binutils and mingw-w64-headers (those were the only two packages in the result of pacman -Ss mingw command), I only got the following commands

i686-pc-linux-gnu-c++        i686-w64-mingw32-as           i686-w64-mingw32-objdump
i686-pc-linux-gnu-g++         i686-w64-mingw32-c++filt      i686-w64-mingw32-ranlib
i686-pc-linux-gnu-gcc         i686-w64-mingw32-dlltool      i686-w64-mingw32-readelf
i686-pc-linux-gnu-gcc-11.1.0  i686-w64-mingw32-dllwrap      i686-w64-mingw32-size
i686-pc-linux-gnu-gcc-ar      i686-w64-mingw32-elfedit      i686-w64-mingw32-strings
i686-pc-linux-gnu-gcc-nm      i686-w64-mingw32-gprof        i686-w64-mingw32-strip
i686-pc-linux-gnu-gcc-ranlib  i686-w64-mingw32-ld           i686-w64-mingw32-windmc
i686-pc-linux-gnu-pkg-config  i686-w64-mingw32-ld.bfd       i686-w64-mingw32-windres
i686-w64-mingw32-addr2line    i686-w64-mingw32-nm           
i686-w64-mingw32-ar           i686-w64-mingw32-objcopy      

I have everything but the i686-w64-mingw32-gcc and i686-w64-mingw32-g++ commands, same issue with the x86 variants, can't I install them using pacman ?

thanks in advance

Last edited by da (2021-06-21 00:24:14)

Offline

#2 2021-06-21 01:02:07

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,009

Re: can't find the right package for cross compiling c code

On 64-bit archlinux you get the following packages when searching for mingw:

community/mingw-w64-binutils 2.36.1-1 (mingw-w64-toolchain mingw-w64)
    Cross binutils for the MinGW-w64 cross-compiler
community/mingw-w64-crt 9.0.0-1 (mingw-w64-toolchain mingw-w64)
    MinGW-w64 CRT for Windows
community/mingw-w64-gcc 11.1.0-2 (mingw-w64-toolchain mingw-w64)
    Cross GCC for the MinGW-w64 cross-compiler
community/mingw-w64-headers 9.0.0-2 (mingw-w64-toolchain mingw-w64)
    MinGW-w64 headers for Windows
community/mingw-w64-winpthreads 9.0.0-1 (mingw-w64-toolchain mingw-w64)
    MinGW-w64 winpthreads library

I'd guess the tools you want are in mingw-w64-gcc.  This is amongst the broken packages list.  Looking at the build logs, we seem to have a circular dependency set up; mingw-w64-gcc depends on mingw-w64-winpthreads which in turn depends on wingw-w32-gcc so it all falls over in  a big heap.

Perhaps this eyes on the problem will prompt someone else to do something about this, especially if you want to use it.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB