You are not logged in.

#1 2017-12-03 21:50:43

Registered: 2017-12-03
Posts: 1

Archlinux32 on a EFI tablet

I have an old shitty local market tablet which runs a heavely restricted version of Windows 8.
It served no use until now because all specs are low end but recently yesterday I decided to started tinker with it after the new alpine linux release got out.
( the release notes specify that it now has EFI support and I remembered the tablet was 32bit EFI only )
To my suprise, the I could get the extended version booting and wifi working but I feel like a more familiar medium would be more comfortable despite the alpine medium being lighter (musl,busybox)

I've tried getting the current archlinux32 iso EFI ready using these two archwiki articles but I feel like I'm not understanding what I'm doing and doing something fundamentally wrong. … boot_image … tall_media
Can someone help me ?


#2 2017-12-23 09:57:04

Mr Green
Registered: 2017-11-11
Posts: 36

Re: Archlinux32 on a EFI tablet

I too have an old iconica tablet and currently trying to load Archlinux32. My first attempt was to try to get linux mint 32bit iso working via an article I found on the web. Basically formatting device then adding file to usb drive. This worked and grub menu appeared and then I could start Linux Mint. Thought I would try to load Archlinux32 via grub.cfg as yet only managed to get to rootfs (shell).

Basically format and partition drive (FAT32) then add files from iso to it (number of ways to do this)

To see files on iso:

mkdir iso
sudo mount -t loop foo.iso iso


#3 2017-12-31 17:03:18

From: Belgium (Brussels)
Registered: 2017-12-31
Posts: 2

Re: Archlinux32 on a EFI tablet

The trick is usually to make a grub32 efi executable; see this. Boot from it a use a self made grub.cfg (avoid their scripts, making a workable grub.cfg by hand is much less error prone and is not that difficult). For example (but adapt it to your need):

insmod efi_gop
insmod efi_uga
insmod ext2
terminal_input console
terminal_output console
search --fs-uuid --set=root <UUID1> # UUID of the boot partition.
set default=0
set timeout=3
set rootdev="<UUID2>" # UUID of the partition of the root filsesystem.

menuentry "Archlinux" {
          linux /boot/vmlinuz-linux root=${rootdev} rw
          initrd /boot/initramfs-linux.img

Use that to boot the kernel.

Note that many of these tablets have a processor that is 64 bits capable, even if the UEFI (and the preinstalled Windows) is 32 bits. In that case you can use the standalone grub made above to load a 64 bits kernel and install a 64 bits distribution.

Last edited by olive (2017-12-31 17:03:53)


#4 2018-01-14 08:59:07

Registered: 2018-01-14
Posts: 1

Re: Archlinux32 on a EFI tablet

I'm also trying to install on an old shitty tablet, an Asus Vivotab (tf810c), with an Atom Z2760 CPU which is actually only 32-bit.

I just followed the instructions you already linked to: … tall_media

It then manages to boot into GRUB fine, but I can't boot Linux from there, it just hangs on a blank screen.

Similar in Alpine, but it hangs with "trying to terminate efi service again", same thing this guy got:!topic … 1WIdiM0z-Q

Not really sure how to get any more information from here... obviously these 32-bit Atom devices aren't well supported from googling, but it seems like it should at least be able to boot. Can I tweak grub.cfg to let me see more console output?


Board footer

Powered by FluxBB