You are not logged in.

#1 2018-03-15 15:28:34

Registered: 2018-03-15
Posts: 5

[Solved}cannot update from archlinux32

I switched to archlinux32 sources yesterday and I have problems to complete the update. I followed the instructions:

If you plan to move from the official repositories to our community maintained repositories, follow these steps:

    Put any mirror from our mirrolist into /etc/pacman.d/mirrorlist.
    Execute pacman -Syy archlinux32-keyring-transition to install our keyring transition package signed by one of the x86_64 archlinux devs.
    Execute pacman -S archlinux32-keyring to install our most recent keyring package.
    Run pacman -Syuu for a full transition.
        Note, that some packages are currently newer in the official repositories and will be downgraded, therefore.
        Also note, that packages found in your package cache won't match the signatures from archlinux32 - either allow pacman to delete these cached packages or run pacman -Sc to clean your cache before you start and after you finish upgrading.

The update cannot be completed because of absense of a pgp key:
pgp key: 2048R/16194A82231E9EF823562181C8E8F5A0AF9BA7E7, "Andreas Baumann (sign) <>" could not be imported

Any help to fix this?

Last edited by dancaer69 (2018-03-16 13:10:11)


#2 2018-03-15 18:34:42

Registered: 2017-11-14
Posts: 3

Re: [Solved}cannot update from archlinux32

Hi, I just tested an import of that key and it worked:

$ gpg --recv-key 16194A82231E9EF823562181C8E8F5A0AF9BA7E7
gpg: key C8E8F5A0AF9BA7E7: 6 signatures not checked due to missing keys
gpg: key C8E8F5A0AF9BA7E7: public key "Andreas Baumann (sign) <>" imported
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   3  signed:   2  trust: 0-, 0q, 0n, 0m, 0f, 3u
gpg: depth: 1  valid:   2  signed:   0  trust: 2-, 0q, 0n, 0m, 0f, 0u
gpg: Total number processed: 1
gpg:               imported: 1


#3 2018-03-16 10:00:58

Registered: 2018-03-15
Posts: 5

Re: [Solved}cannot update from archlinux32

By using this command I found that the time setting was wrong. I have arch linux installed on a netbook and I didn't use it for months. I checked the time in bios and was the default time/date(01-01-2002). I corrected it and now I'm trying to do the update again. I think that l'll not have problem with the key now.
Seems that problem solved, the update completed successfully.

Last edited by dancaer69 (2018-03-16 13:09:46)


Board footer

Powered by FluxBB