You are not logged in.

#1 2018-03-12 23:51:46

p0wder
Member
Registered: 2018-03-11
Posts: 4

[Solved] How do I turn off system beep?

Does anybody know how I can disable the system beep?

I came across a post that showed how to disable it for the current session, but I was wondering if there is a way to disable it permanently?

It beeps every time I click on 'Logout', and it beeps when I auto-scroll too far in the terminal.

This can be really obnoxious when it is late at night..  sad

Any help with this would be awesome!  cool

Thanks.


The command I found to temporarily disable it:

sudo xset b off
sudo xset b 0 0 0

Last edited by p0wder (2018-04-04 02:07:50)

Offline

#2 2018-03-20 14:22:49

cro
Member
Registered: 2018-01-19
Posts: 3

Re: [Solved] How do I turn off system beep?

What I usually do is blacklisting the kernel modules for the PC speaker.

In a file below /etc/modprobe.d/ add something like:

blacklist pcspkr                                                                                                                                                                                                                              
blacklist snd_pcsp

I'm not sure if this is the right or best way to do it.
I'm not even completely sure it will work, but I think it works for me (made this configuration many years ago and haven't touched it since).

see also https://wiki.archlinux.org/index.php/PC_speaker

Offline

#3 2018-03-23 12:12:11

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 346
Website

Re: [Solved] How do I turn off system beep?

For X11: xset -b
setterm -blength 0

See https://debian-administration.org/artic … sole_beeps

Offline

#4 2018-04-04 02:06:46

p0wder
Member
Registered: 2018-03-11
Posts: 4

Re: [Solved] How do I turn off system beep?

I finally got it figured out !  smile  tongue

Thank you for the reply guys! I will mark this post as solved and post the solution for any one else that has the same issue.

The blacklisting method suggested by cro didn't work for me.. sad
And the commands suggested by andreas_baumann worked, but the beeps were back after I rebooted.. roll


What I did to get the beep to go away for good was -

  • Drop to console (Ctl+Alt+F2)

  • Log in as 'root'

  • Run:

echo "blacklist pcspkr" > /etc/modprobe.d/nobeep.conf

After reboot, no more beeps !! cool

Offline

Board footer

Powered by FluxBB