You are not logged in.

#1 2018-11-03 18:10:43

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 254

Installing boost-libs (1.68.0-1.0) breaks dependency 'boost-libs=1.67'

...required by boost

I get this error with the testing repos enabled when doing an -Syu upgrade.  I don't think this affects anyone not on the testing repos yet, but I'm just flagging this up to hopefully stop a bad configuration being pushed to stable.

The version of boost I'm currently using is 1.67.0-7.0 from testing (extra has 1.67.0-5.0), so one way to fix this might be to build a version 1.68 of boost which presumably works with a 1.68 version of boost-libs.  It wouldn't surprise me if there is a failing build for boost at present, but I've not checked (and can't remember off the top of my head how to check).

I worked around this issue while still using the testing repos by adding --ignore boost-libs to my upgrade command.  The upgrade at least has gone though fine, though I've not rebooted yet or gone out of my way to use any of the upgraded tools and libs.

In other news, thanks to everyone for helping upgrade so many packages on my system just fine.  I'm not sure when I last did an upgrade, and a lot of new packages just came through (maybe a month to 6 weeks ago I think). but they all seem to coexist on my system perfectly well.

Edit: I rebooted a few hours ago now, and it all still looks good.

Last edited by levi (2018-11-04 04:18:53)

Offline

#2 2018-11-05 13:28:59

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 383

Re: Installing boost-libs (1.68.0-1.0) breaks dependency 'boost-libs=1.67'

no boost on the build list: https://packages.archlinux32.org/buildm … ken=&next=
but it looks, like we have it in staging: https://packages.archlinux32.org/?sort= … ification=

Offline

#3 2018-11-05 13:35:41

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 383

Re: Installing boost-libs (1.68.0-1.0) breaks dependency 'boost-libs=1.67'

looks, like boost falsely claims to need boost-libs>=1.67.0 in the database (instead of "=") - fixed it manually

Offline

#4 2018-11-05 13:39:23

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 383

Re: Installing boost-libs (1.68.0-1.0) breaks dependency 'boost-libs=1.67'

ah, no, damn, the version info was _completely_ lost for boost=1.67.0 ... I will /really/ fix it now (I had some problem with importing stuff into the database lately, so some version infos of dependencies and providers being lost is no unknown thing)

Offline

#5 2018-11-05 17:52:46

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 254

Re: Installing boost-libs (1.68.0-1.0) breaks dependency 'boost-libs=1.67'

Yes, we'd have less trouble if boost 1.67 actually claimed it needed boost-libs >= 1.67.  My currently installed copy depends on =1.67, which breaks when pacman tries to upgrade boost-libs to 1.68.

It looks like boost 1.68 in staging also depends on =1.68 of boost-libs.  So you either need to always publish these in step with each other, or perhaps that should also be tweaked to say >=1.68 assuming that's safe to do, so that if boost-libs gets upgraded to 1.69 or something that can coexist with boost 1.68 while that's being built and publshed.  If boost gets published before boost-libs that will still break, but that's probably a valid break because it's really unlikely to be compatible.

Offline

#6 2018-11-05 18:05:26

deep42thought
Administrator
From: Jena, Germany
Registered: 2017-06-17
Posts: 383

Re: Installing boost-libs (1.68.0-1.0) breaks dependency 'boost-libs=1.67'

levi, you got me wrong: the info in pacman / the package should not be changed - that comes from upstream. But somehow our (mysql) database had the wrong information, so the packages got separated.

Offline

Board footer

Powered by FluxBB