You are not logged in.

#1 2019-01-05 21:13:44

archlinux32forever
Member
Registered: 2018-05-21
Posts: 14

[SOLVED] rsync hangs in backup

Hi

Since I installed Archlinux32 in my netbook mobii about four years ago I noticed this issue. Sometimes copying with caja (MATE desktop) througth the network using wifi it hangs. Also copy lots of files with rsync througth network sometimes it hangs and returns this error:

rsync: [sender] write error: Broken pipe (32)
rsync error: unexplained error (code 255) at io.c(820) [sender=3.1.3]

I usually solve the issue reloading the wifi module, but yesterday I tried to test all options to set the wifi card with iwconfig. This is my wifi card:

$ sudo lspci -v

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller (rev 22)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller
    Flags: bus master, fast devsel, latency 0, IRQ 17
    I/O ports at ec00 [size=256]
    Memory at febfc000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Legacy Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Virtual Channel
    Capabilities: [160] Device Serial Number xx-xx-xx-xx-xx-xx-xx-xx
    Kernel driver in use: rtl818x_pci
    Kernel modules: rtl818x_pci

And this is the command to solve the issue:

$ sudo iwconfig wlp2s0 frag 512

By default is off. I tested with 1024 and also hangs and returns the same error.

I found  the information for this option in man iwconfig and at http://kmkeen.com/linux-wifi/2012-06-18 … 0-044.html

I hope this helps someone with the same issue.

Cheers!

Last edited by archlinux32forever (2019-01-20 12:34:43)

Offline

#2 2019-01-06 08:03:16

andreas_baumann
Administrator
From: Zurich, Switzerland
Registered: 2017-08-10
Posts: 568
Website

Re: [SOLVED] rsync hangs in backup

Thanks for this hint. :-)

Offline

Board footer

Powered by FluxBB