You are not logged in.

#1 2019-03-13 17:12:16

emgaron
Member
Registered: 2018-03-31
Posts: 13

Quirks with BookPC i810

I have an ancient BookPC i810 (P3 Celeron 1GHz, Intel i810 chipset) which I intend to give away. To check whether it is actually still working, I installed Arch32 and eventually succeeded, but I did run into two issues:

  • When booting, the text on the console got garbled. I think this might be related to this problem, though I did not spend much time investigating. I ended up setting GRUB_GFXPAYLOAD_LINUX=text in /etc/default/grub, which solved the problem.

  • The PS/2 devices (both mouse and keyboard) were not detected once the machine was up. Fortunately, I had a USB keyboard, so I could continue... This turned out to be related to PS/2 support being modular. Contrary to what is written in that article, it was not sufficient to add "atkdb" to the "MODULES=" line in mkinitcpio.conf - I also had to add the "i8042" module explicitly, as the kernel apparently failed to detect that. After that, the PS/2 devices worked normally again.

Hopefully, this is helpful for someone at some point. :-)

Offline

Board footer

Powered by FluxBB