You are not logged in.

#1 2019-08-07 19:05:43

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 389

netsurf and libcss broken

I currently have libcss and libwapcaplet installed.  Libwapcaplet seems to be a dependency of netsurf, while I can't actually determine why I installed libcss, but it also depends on the same.

I found that when trying to upgrade my system, that libcss depends on >0.4.2 of libwapcaplet, but libwapcaplet is still only at 0.4.1-2.0.

Netsurf claims to depend directly on libwapcaplet itself.  As I stated in the first para, I don't actually know why I have libcss installed, and testing an -Rs on it seems to suggest it is entirely orphaned these days.

Removing libcss stops the upgrade failing, but when I test run netsurf I get the following assertion fail:

netsurf-gtk3: content/fetchers/curl.c:718: fetch_curl_initiate_fetch: Assertion `codem == CURLM_OK || codem == CURLM_CALL_MULTI_PERFORM' failed.

I don't actually need netsurf, and have proved pacman doesn't think I need libcss.  I think I'll remove both; I think I only installed netsurf to see where it was at these days.  But still, libcss was built on July30th and a new libwapcaplet is required for anyone genuinely using it.  And netsurf as shipped appears to be broken.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB