You are not logged in.

#1 2020-05-22 22:36:01

linuxnomo
Member
Registered: 2020-05-22
Posts: 2

Installing Xorg with xf86-video-savage driver

Hi there,

I have an old IBM Thinkpad T23 which I am trying to use with archlinux32. I checked the CPU flags and so far managed to install arch so that I have network and command prompt.

Next challenge is to set up X. I tried to install the savage-driver with pacman, but it's in the AUR. I cloned the corresponding repository (https://aur.archlinux.org/xf86-video-savage.git) and tried to build it with "makepkg -si". Unfortunately I got errors pointing out the wrong X-ABI-VERSION (Fehlende Abhängigkeiten: X-ABI-VIDEODRV_VERSION=23).

I then downloaded xf86-video-savage directly from the source (https://github.com/freedesktop/xorg-xf86-video-savage), configured, made and installed it, this worked without error.

Nevertheless, when I try to run startx, I get an error in the Xorg.0.log:

(II) LoadModule: "savage"
(WW) Warning, couldn't open module savage
(EE) Failed to load module "savage" (module does not exist, 0)
(EE) No drivers available

So here I am, stuck trying to get some graphics on arch.

I am new to arch, so that may be due to that. I have to admit, Lubuntu did install without problems (with X), but now I would like get archlinux32 to work.

Looking forward for any help,

linuxnomo

Offline

#2 2020-05-23 06:47:44

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 127
Website

Re: Installing Xorg with xf86-video-savage driver

xorg-server<1.19, Lubuntu has an older X (supposedly), Xorg 1.20 dropped a lot of old
X drivers (I had trouble to get SiS working, Mach64, Matrox, AMD Geode GPU are still failing
on me).

You can try to upgrade  dependencies and check on the original git repo for
a newer version.

In the worst case you have to dig into the C code and fix it yourself. :-)

I would also try once if a VESA mode is working, just to see if you can get some
(slow) graphics.

Offline

#3 2020-05-23 15:30:31

linuxnomo
Member
Registered: 2020-05-22
Posts: 2

Re: Installing Xorg with xf86-video-savage driver

Thanks for the answer. I'll try to dig a little bit deeper if that's the problem...

Offline

Board footer

Powered by FluxBB