You are not logged in.

#1 2021-03-30 02:37:48

jetfrog28
Member
Registered: 2018-08-25
Posts: 17

[SOLVED] pango symbol loading errors, wrong glib version?

Hello,

I've managed to solve this problem for the time being, but I'm posting in the hopes that it may help someone else if they face the same problem, and that it may help with a more permanent solution.  Downgrading pango (1:1.48.4-1.0 => 1:1.48.2-1.0) solves the problem, at least for the moment.

There were two issues that I think were unrelated during my most recent upgrade (pentium4, testing repos).  The first I encountered was an unresolvable dependency for mpv:

:: installing libplacebo (3.104.0-2.0) breaks dependency 'libplacebo.so=72-32' required by mpv

I upgraded with

$ sudo pacman -Syu --ignore libplacebo

and the update proceeded.  mpv continued to work.  (later, I upgraded libplacebo (and x264 and x265, which libplacebo held back), ignoring dependency version checks, and this broke mpv, so I downgraded libplacebo (and x264 and x265) again).

That was the lesser of the two problems.  The greater: After the upgrade finished, many programs (vim, termite) failed to launch with an error like the following:

vim: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_memdup2

This seemed to affect a lot.  Using nm -D on both versions of the pango object file indicates that the old file referenced g_memdup, where the new one references g_memdup2, which then can't be resolved:

$ nm -D /usr/lib/libpango-1.0.so.0 | grep memdup # (pango version 1:1.48.2-1.0 installed)
         U g_memdup
$ nm -D /usr/lib/libpango-1.0.so.0  | grep memdup # (pango version 1:1.48.4-1.0 installed)
         U g_memdup2

From a post I've found [1], it seems that g_memdup was deprecated at short notice, and the version of glib I have installed doesn't seem to export g_memdup2.  Perhaps this is just unlucky upgrade timing and this will be fixed as the mirrors update.  If not, it looks like a higher minor version of glib2 is necessary, or a patch is required.  My version of glib2 is 2.66.7-1.1, and it looks like, according to the linked post, version 2.67.3 or higher is necessary for the g_memdup2 symbol, so this is expected to happen with the version of glib2 in the repos.

[1]: https://discourse.gnome.org/t/port-your … 2-now/5538

Offline

#2 2021-04-05 13:25:57

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 416
Website

Re: [SOLVED] pango symbol loading errors, wrong glib version?

Pushing glib2 2.68.0-5.1 to stable did the trick.

Offline

Board footer

Powered by FluxBB