You are not logged in.

#1 2021-11-18 04:42:32

wilbefast
Member
Registered: 2021-11-18
Posts: 2

WiFi needs to be kicked over on launch

Hi all,

I have an issue that has plagued me across multiple installations of Arch on my MSI GE60 2PL Apache: whenever I boot up I need to run the following script to get the WiFi to work.

#!/bin/bash

sudo ip link set wlp5s0 down
sleep 3
sudo netctl start MY_WIFI_PROFILE

It should be noted that I I try to run the final command without first turning off wlp5s0 then it will fail. It will also fail if I don't wait for a few seconds in between the two commands. In other words I need to kick it over, waiting for it to fully die before starting it again. At least that's my interpretation.

At this point I'd settle for some way of executing the script automatically on login (as root), but if anyone has an idea why this might be occuring and how I might fix it I'm all ears. The profile in question was generated automatically by wifi-menu, and I'm using the LXDE desktop environment.

Many thanks,

William

Last edited by wilbefast (2021-11-18 04:42:54)

Offline

#2 2022-02-10 19:19:25

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 740
Website

Re: WiFi needs to be kicked over on launch

I had something similar on Archlinux 64-bit with a HP Papillon dm1. Not sure what it is, but netctl just didn't want to start any profiles at startup.
It could point to something not necessarily Archlinux32 specific. So far, I have not found what's going wrong..

Offline

#3 2022-02-10 23:14:51

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,149

Re: WiFi needs to be kicked over on launch

I think my wifi stick is on the way out, but it normally works for a couple of hours after I boot the machine.  This morning, it reported a bad USB connection on bootup, and it turned out it was my wifi stick, so I had to uplug it an replug it in, then kick it with a netctl stop and netctl start.  Normally I have a script that stops it after I hit enter and restarts it when I hit enter again, for use ideally just before it conks out on me naturally, so I can manually disconnect from whatever network services I'm using.  My video server running arch64 has a TP_Link PCIe network adaptor which comes up at boot time just fine.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#4 2022-02-19 04:13:48

wilbefast
Member
Registered: 2021-11-18
Posts: 2

Re: WiFi needs to be kicked over on launch

Probably I'm going to get some well deserved ribbing for this, but it seems like the following did the job:

sudo netctl enable PROFLE_NAME_OF_WIFI

I could have sworn I already tried this in the past to no avail, but I've changed network and done a full updates since then. Anyway, hope this helps someone who encounters a similar issue.

Offline

#5 2022-02-19 19:57:07

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 740
Website

Re: WiFi needs to be kicked over on launch

Good old netctl :-)

Offline

Board footer

Powered by FluxBB