You are not logged in.

#1 2021-11-26 04:23:20

garock
Member
From: BR
Registered: 2021-11-26
Posts: 2

[SOLVED] Can't start DE after install

Hello, I'm new to this forum. Sorry If I made any mistake. (also english is not my native language, sorry for any grammar errors, I don't use translators)
I just installed arch32 on a old PC (specs bellow)
The problem is, after I installed it (as I usually install the normal arch) I tried to install a DE but none of them worked for me. (strangely I can use zorin on it but I'm not so fan of it, and, manjaro32 works too but I can't install it since it has less than 1GB ram)

I tried to install: xorg, xfce and lightdm. When I started lightdm only black screen appears. I also tried to install cinnamon but without the DM working I couldn't start the DE properly.
So I tried other DMs such as GDM and SDDM, the only one that shows a pointer on the screen is SDDM. Others just don't show anything but black screen and I have to change tty and use the terminal.
Also a strange error appears when I try to restart all services from systemctl, it says

sudo systemctl restart *
Failed to restart Desktop.service: Unit Desktop.service not found.

This error disappears when I disable DM.

Any help is appreciated since I couldn't do anything to solve this problem. sad

I'll also put a link to a pastebin containing all the packs installed on it, link is here: >Packets Installed<

 Solution: I could solve it by installing LXDM, strangely it works just fine with no errors, however systemboot is slower than with zorin.

Specs of the machine:
Pentium 4 (3.06 GHz)
768 DDR2
64GB sata SSD
No external GPU added.

Last edited by garock (2021-11-26 04:58:08)

Offline

#2 2021-11-26 05:53:06

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,009

Re: [SOLVED] Can't start DE after install

Yes, I have also settled on a subset of lxde and bits of xfce installed for this machine.  Also, wayland works with weston on top, but less can be said of other wayland DE's I've tried.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

#3 2021-11-26 06:47:38

garock
Member
From: BR
Registered: 2021-11-26
Posts: 2

Re: [SOLVED] Can't start DE after install

levi wrote:

Yes, I have also settled on a subset of lxde and bits of xfce installed for this machine.  Also, wayland works with weston on top, but less can be said of other wayland DE's I've tried.

The question is, is this setup compatible with lightdm?

Offline

#4 2021-11-27 14:07:01

abaumann
Administrator
From: Zurich
Registered: 2019-11-14
Posts: 416
Website

Re: [SOLVED] Can't start DE after install

lightdm is compatible with pretty much anything.
Currently there might be hickups in gnome-shell and possibly plasma (they tend to break frequently).
Try a really simple window manager first like JWM or FVWM (you might even stick to that one) and
then try the more complex ones afterwards.

Offline

#5 2021-11-27 18:33:29

levi
Moderator
From: Yorkshire, UK
Registered: 2018-06-16
Posts: 1,009

Re: [SOLVED] Can't start DE after install

Yeah, I have run it with lightdm in the past, but I prefer running X in user mode, so instead I log in in termal mode then startx these days.  It certainly used to work, and it's good to hear it should continue to do so.


Architecture: pentium4, Testing repos: Yes, Hardware: EeePC 901+2GB RAM+OS half on the SD card.

Offline

Board footer

Powered by FluxBB