You are not logged in.

#1 2023-03-03 18:00:10

Registered: 2023-03-03
Posts: 1

Archinstall partitioning error

I'm on the latest ISO build, with fully updated and refreshed keys, with the latest Archinstall version available on Arch32's pacman (2.5.2-1.2).

When Archinstall begins partitioning, it fails and gives the error "AttributeError: 'NoneType' object has no attribute 'partitions'"

A few days ago I tried the January build (which was the latest available then), and I still had this issue. I tried fixing this by installing the latest, bleeding edge version of Archinstall off of GitHub, but that didn't work either. I'm guessing it's because *that* version of Archinstall tried to install package versions that weren't available on Arch32's pacman? hmm

About the AttributeError, it's apparently because the latest Archinstall available is just broken.

So, does this mean I should wait until a newer version of Archinstall is available? When do they normally update?

(Keep in mind, I'm no expert on this topic. I'm likely getting something wrong.)


#2 2023-03-04 07:33:58

From: Zurich
Registered: 2019-11-14
Posts: 859

Re: Archinstall partitioning error

I tried both a "released" version and the master github version of archinstall. Sadly both don't work. … l#07:23:54

I decided to make a new ISO nevertheless (because on the older ones the keys were not up to date).

Just try the real Arch way of installation (, I think archinstall
is still just alpha quality and it makes questionable decisions like zram over swap partition (which is totally
unusable if you want to hibernate a running system).

Also I don't like everything is rewritten in Python: it creates dependencies. And currently Python is
in the middle of a rebuild, so it could also be some modules not being up to date causing the
error above.


Board footer

Powered by FluxBB